Mike "Wuzzy121". Rest in peace, brother

Go Back   Tacoma World Forums > Tacoma Discussion > 1st Gen. Tacomas

Notices

Cruise control won't engage

Reply
 
Thread Tools Search this Thread
Old 06-25-2008, 09:42 PM   #1
morse764 [OP] morse764 is offline
Junior Member
morse764 is on a distinguished road
Joined: Jun 2007, #1794
Posts: 20
morse764's Tacoma Gallery
Cruise control won't engage

I have an 03 tacoma with cruise control, which has been working fine until i took it in for its 50,000 mile check up. The dealer insisted that it was the switch so they replaced that for $216 and turns out it wasn't the switch and they still charged me. And then they said it was the ecm and that it would have to replace but i didn't, so i left it at that. But the odd thing is that the cruise control does not blink when you turn it on, however it does not engage at all when you press on the switch. Any solutions?
  Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
4wd won't engage, troubleshooting rawtaco Technical Chat 14 11-16-2013 04:49 PM
4 wheel drive won't engage... Jimkana 2nd Gen. Tacomas 3 12-08-2011 07:18 PM
96 won't engage to 4H Chewmanfoo 1st Gen. Tacomas 8 12-16-2010 02:37 PM
06 4x4 won't engage danknutson Technical Chat 9 11-23-2010 06:26 AM
4LO won't engage concrete jedi 2nd Gen. Tacomas 5 02-14-2008 01:54 PM


Copyright © 2014 Tacoma Forum. Tacoma World is not owned by, or affiliated with Toyota Motor Corporation.