LSC15's 95 Tacoma 4x4

Go Back   Tacoma World Forums > Tacoma Discussion > 1st Gen. Tacomas

Notices

My first Pickup

Reply
 
Thread Tools Search this Thread Display Modes
Old 06-25-2008, 11:56 PM   #1
Member
flesheatingvirus is on a distinguished road
 
flesheatingvirus's Avatar
Joined: Jun 2008, #7570
Location: ABQ, NM
Gender: Male
Posts: 46
flesheatingvirus's Tacoma Gallery
My first Pickup

I just got my first pickup, a 96 Tacoma 2.4L 4CYL 2x4 with the X-tended cab and automatic trans. I have some initial questions.

First off, the cover to the fuse/relay center under the hood is missing. I would really like to have one, but the junkyards around here are DRY of Tacomas. Know where I might order one? I've Googled and Ebayed with no luck except for the interior fuse panel cover, but not one for under the hood.

I've never used synthetic oil, but the Mobile 1 seems to be getting a broad consensus here, so I think I'll try that with 5000 mile changes.

Can I tell where my truck was manufactured?

I also noticed something strange, that I might be blowing out of proportion. When I accelerate from a stop, up to about 55, the acceleration isn't very smooth, but makes me rock forward and rearward a bit. What could that be? I'm not used to the way it drives yet, but it also doesn't quite seem to take of very fast, or with much power. I just changed the spark plugs. Thoughts?

Thanks, all!
  Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
First Pickup nsene001 New Members 6 07-26-2011 09:19 PM
88 pickup TTGuy711 Buy / Sell / Trade 14 01-13-2011 08:28 AM
First Pickup ever! Cyclonicks New Members 19 04-27-2010 02:45 AM
My first pickup truck bobatstar76 New Members 6 02-09-2010 01:22 PM
My new Pickup Car... gaiserrc New Members 15 09-05-2009 09:56 PM


Copyright © 2014 Tacoma Forum. Tacoma World is not owned by, or affiliated with Toyota Motor Corporation.