LSC15's 95 Tacoma 4x4

Go Back   Tacoma World Forums > Tacoma Discussion > 1st Gen. Tacomas

Notices

P0171 Code

Reply
 
Thread Tools Search this Thread Display Modes
Old 08-17-2010, 03:52 PM   #1
shaniac [OP] shaniac is offline
Senior Member
shaniac is on a distinguished road
 
shaniac's Avatar
Joined: Nov 2009, #25883
Location: Charleston, SC
Gender: Male
Posts: 127
shaniac's Tacoma Gallery
P0171 Code

My check engine light came on so I went to a local part store and code P0171 came up and it said "system too lean" and "bank 1".
I got home and looked up the code in my Haynes and code P0171 is "System Adaptive fuel too lean".
Where do I need to go from here? I am thinking either I need to clean my K&N air filter or could it be a bad O2 sensor?

I have noticed that when I step on the gas there is a pinging sound coming from the engine; to remedy this I went to 89 grade octane and sometimes I have had to put in the 91 grade octane fuel, which has helped.
  Reply With Quote
Old 08-17-2010, 03:54 PM   #2
With sufficient thrust, pigs fly just fine.
chris4x4 is one of the sharper tools in the shedchris4x4 is one of the sharper tools in the shedchris4x4 is one of the sharper tools in the shedchris4x4 is one of the sharper tools in the shedchris4x4 is one of the sharper tools in the shedchris4x4 is one of the sharper tools in the shedchris4x4 is one of the sharper tools in the shedchris4x4 is one of the sharper tools in the shedchris4x4 is one of the sharper tools in the shedchris4x4 is one of the sharper tools in the shedchris4x4 is one of the sharper tools in the shed
 
chris4x4's Avatar
Name: FlimFlubberJAM
Joined: May 2008, #6497
Location: Tenoe, AZ
Gender: Male
Posts: 94,083
chris4x4's Tacoma Gallery
Clean the MAF first.
  Reply With Quote
Old 08-17-2010, 03:56 PM   #3
shaniac [OP] shaniac is offline
Senior Member
shaniac is on a distinguished road
 
shaniac's Avatar
Joined: Nov 2009, #25883
Location: Charleston, SC
Gender: Male
Posts: 127
shaniac's Tacoma Gallery
Thanks, I will try that...hopefully that will solve the problem.
  Reply With Quote
Old 08-17-2010, 07:57 PM   #5
shaniac [OP] shaniac is offline
Senior Member
shaniac is on a distinguished road
 
shaniac's Avatar
Joined: Nov 2009, #25883
Location: Charleston, SC
Gender: Male
Posts: 127
shaniac's Tacoma Gallery
I used CRC MAF Cleaner. I also purchased a new air filter and had the check engine light reset. It has not come back on yet. I spoke with a friend of mine that has been a auto mechanic for 20+ years and he also told me to check for leaks in the vacuum lines before I go and purchase a O2 sensor...
Fingers are crossed, LOL
  Reply With Quote
Old 08-17-2010, 08:01 PM   #6
Senior Member
cmack cmack cmack cmack cmack cmack cmack cmack cmack cmack cmack
Joined: Jun 2009, #18119
Posts: 386
cmack's Tacoma Gallery
This code has been ruining my life
  Reply With Quote
Old 08-17-2010, 10:07 PM   #8
Senior Member
shampoop has much to be proud ofshampoop has much to be proud ofshampoop has much to be proud ofshampoop has much to be proud ofshampoop has much to be proud ofshampoop has much to be proud ofshampoop has much to be proud ofshampoop has much to be proud of
Joined: Feb 2010, #30685
Location: southwest WA
Gender: Male
Posts: 589
shampoop's Tacoma Gallery
maf and vacuum leaks. there aren't that many things that cause n/a engines to run lean.

i once worked on a taco that had a bad pcv valve which caused a ton of oil to get sucked into the intake and soak the maf.
  Reply With Quote
Old 08-18-2010, 06:21 AM   #9
With sufficient thrust, pigs fly just fine.
chris4x4 is one of the sharper tools in the shedchris4x4 is one of the sharper tools in the shedchris4x4 is one of the sharper tools in the shedchris4x4 is one of the sharper tools in the shedchris4x4 is one of the sharper tools in the shedchris4x4 is one of the sharper tools in the shedchris4x4 is one of the sharper tools in the shedchris4x4 is one of the sharper tools in the shedchris4x4 is one of the sharper tools in the shedchris4x4 is one of the sharper tools in the shedchris4x4 is one of the sharper tools in the shed
 
chris4x4's Avatar
Name: FlimFlubberJAM
Joined: May 2008, #6497
Location: Tenoe, AZ
Gender: Male
Posts: 94,083
chris4x4's Tacoma Gallery
Quote:
Originally Posted by shampoop View Post
maf and vacuum leaks. there aren't that many things that cause n/a engines to run lean.

i once worked on a taco that had a bad pcv valve which caused a ton of oil to get sucked into the intake and soak the maf.
Well...The 3.4 doesnt have a PCV.
  Reply With Quote
Old 08-18-2010, 09:19 PM   #10
Senior Member
shampoop has much to be proud ofshampoop has much to be proud ofshampoop has much to be proud ofshampoop has much to be proud ofshampoop has much to be proud ofshampoop has much to be proud ofshampoop has much to be proud ofshampoop has much to be proud of
Joined: Feb 2010, #30685
Location: southwest WA
Gender: Male
Posts: 589
shampoop's Tacoma Gallery


TIS disagrees
  Reply With Quote
Reply

Products Discussed in this Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
P0171 CEL Code Greensystemsgo 1st Gen. Tacomas 23 03-27-2014 10:59 PM
Code P0171 Flaadog Technical Chat 10 10-28-2011 05:58 AM
CEL CODE P0171 harley09 Technical Chat 28 10-13-2010 11:38 AM
P0171 code wont go away tmantstud 1st Gen. Tacomas 28 11-28-2009 10:25 PM
code p0171 trailinTaco 1st Gen. Tacomas 1 06-23-2009 08:23 PM


Copyright © 2014 Tacoma Forum. Tacoma World is not owned by, or affiliated with Toyota Motor Corporation.