LSC15's 95 Tacoma 4x4

Go Back   Tacoma World Forums > Tacoma Discussion > 1st Gen. Tacomas

Notices

severe sputtering

Reply
 
Thread Tools Search this Thread Display Modes
Old 04-21-2007, 05:27 PM   #1
Dotsoid [OP] Dotsoid is offline
Junior Member
Dotsoid is on a distinguished road
Joined: Apr 2007, #1384
Posts: 1
Dotsoid's Tacoma Gallery
Question severe sputtering

Hello All,
New to the forum here.....97 Tacoma owner.

Heading home from work today check engine light started flashing and truck started hesitating really bad. 2.7L, 4 banger. It continued to run so I limped her home...
Could this be catalytic converter plugged, 02 sensors bad.....
All of it sound expensive but I gotta fix it.................

Replies appreciated.....
  Reply With Quote
Old 04-22-2007, 03:42 PM   #2
Senior Member
twoarezee is one of the sharper tools in the shedtwoarezee is one of the sharper tools in the shedtwoarezee is one of the sharper tools in the shedtwoarezee is one of the sharper tools in the shedtwoarezee is one of the sharper tools in the shedtwoarezee is one of the sharper tools in the shedtwoarezee is one of the sharper tools in the shedtwoarezee is one of the sharper tools in the shedtwoarezee is one of the sharper tools in the shedtwoarezee is one of the sharper tools in the shedtwoarezee is one of the sharper tools in the shed
 
twoarezee's Avatar
Joined: Sep 2006, #20
Location: esco, ca
Age: 29
Posts: 281
twoarezee's Tacoma Gallery
take it to autozone or whatever and scan the codes to see what they are. could be o2 sensor, mis fire,bad spark plugs, etc...
  Reply With Quote
Old 04-22-2007, 04:55 PM   #3
Senior Member
sak3358 is on a distinguished road
 
sak3358's Avatar
Joined: Feb 2007, #964
Location: Annapolis, MD
Posts: 199
sak3358's Tacoma Gallery
If your under 80K miles the cats are still under warranty....I believe.
  Reply With Quote
Old 05-29-2007, 01:21 PM   #4
Senior Member
jrallan26 is on a distinguished road
 
jrallan26's Avatar
Joined: Sep 2006, #32
Location: Iowa
Posts: 118
jrallan26's Tacoma Gallery
Disconnect your battery terminals, this will clear your ECU. Then see if engine still running bad. If so, go to Autozone and get your check engine light code read.
  Reply With Quote
Old 08-02-2007, 09:52 AM   #5
Junior Member
eDubs is on a distinguished road
Joined: Aug 2007, #2274
Posts: 6
eDubs's Tacoma Gallery
I've got a 98 Taco 2.4L and my check engine light came on I had autozone read the codes and they pointed to the catalytic converter and possible O2 sensor and some vapor vacumn thing. I had a new cat put on but the guy didnt clear the light. It ended going off all on its own. Then a few days later the light came on again and the codes were the exact same. This was 2 weeks ago ive been driving it with the light on, it runs ok, but sputters a bit starting out.
  Reply With Quote
Old 08-26-2009, 08:44 PM   #6
Spartacus!
XBrown is on a distinguished road
 
XBrown's Avatar
Name: Xavier
Joined: Jun 2009, #18334
Location: Phoenix, AZ
Age: 23
Gender: Male
Posts: 58
XBrown's Tacoma Gallery
Did auto zone tell you what codes you had? Like P0300 or P0420?
  Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
severe groaning when braking JustADriver Technical Chat 5 10-28-2013 12:54 PM
Tacoma's in severe weather 2011TacomaSR5 Off-Topic Discussion 129 03-29-2012 09:15 AM
Tranny Amsoil Severe Gear oil problems Saint Paulian 1st Gen. Tacomas 12 05-20-2011 04:48 AM
Severe Binding - What Am I Doing Wrong? CrazyOzzy Technical Chat 4 03-28-2011 08:35 AM
How to get rid of severe smoke smell Messmed1 Detailing 22 08-14-2009 06:48 PM


Copyright © 2014 Tacoma Forum. Tacoma World is not owned by, or affiliated with Toyota Motor Corporation.