Mike "Wuzzy121". Rest in peace, brother

Go Back   Tacoma World Forums > Tacoma Discussion > 1st Gen. Tacomas

Notices

What's my next move?

Reply
 
Thread Tools Search this Thread
Old 05-12-2011, 12:28 PM   #1
2toys [OP] 2toys is offline
Member
2toys is on a distinguished road
Joined: Mar 2009, #15424
Location: Los Angeles
Gender: Male
Posts: 59
2toys's Tacoma Gallery
What's my next move?

My 2001 2.7 has been throwing p0300 & p0303 (misfire) codes for the last couple weeks. Here's what I've done so far.

Replaced fuel filter.
Checked plugs - ok
Swapped coil packs - no change
compression test - #3 about 5% off but within limits
Leak down - slight leak in #3, no bubbles in rad, no noise in oil or exhaust!
Seafoamed in break vac line - lots of white smokeand ran a bit smoother.
Bottle of Seafoam in current tank of gas.

What's next? I'm thinking injector swap, but I guess I need to find o rings.

Maybe sticky valve? Idk there. Bad Cat?

any help appreciate!

UPDATE:
I have now cleaned the throttle body real well.
Added some seafoam to the crankcase.
Replaced the fuel injectors
Replaced spark plugs (denso oem, .043 gap)

All the above with no real noticeable improvement, though a bit more throttle response. A p0303 code will still come on, sometimes at a cold startup. A flashing CEL will happen under load conditions such as climbing a grade.
  Reply With Quote
Old 05-12-2011, 03:13 PM   #2
Solid Axle FTMFW!!
Supra TT is one of the sharper tools in the shedSupra TT is one of the sharper tools in the shedSupra TT is one of the sharper tools in the shedSupra TT is one of the sharper tools in the shedSupra TT is one of the sharper tools in the shedSupra TT is one of the sharper tools in the shedSupra TT is one of the sharper tools in the shedSupra TT is one of the sharper tools in the shedSupra TT is one of the sharper tools in the shedSupra TT is one of the sharper tools in the shedSupra TT is one of the sharper tools in the shed
 
Supra TT's Avatar
Name: Eric
Joined: Jan 2011, #48645
Location: Lafayette, Indiana
Gender: Male
Posts: 4,716
Supra TT's Tacoma Gallery
What codes are those?
  Reply With Quote
Old 05-12-2011, 05:45 PM   #3
2toys [OP] 2toys is offline
Member
2toys is on a distinguished road
Joined: Mar 2009, #15424
Location: Los Angeles
Gender: Male
Posts: 59
2toys's Tacoma Gallery
Quote:
Originally Posted by Supra TT View Post
What codes are those?
300 = random misfire
303 = misfire cylinder #3
  Reply With Quote
Old 05-14-2011, 10:19 AM   #4
2toys [OP] 2toys is offline
Member
2toys is on a distinguished road
Joined: Mar 2009, #15424
Location: Los Angeles
Gender: Male
Posts: 59
2toys's Tacoma Gallery
Just an update.

I've cleaned the MAF sensors and checked by washable filter. All there looks OK and made little to no difference. I'm still throwing a p0303 daily. I did take it on the freeway last night and really stomped on it! No codes and it felt like it was more responsive, still working through the tank with the Seafoam. If this tank goes and still is throwing the 303, I'll look to pull the #3 injector. I have 160k on this truck and to my knowledge nothing has been done with the injectors. Do the injectors need an annual maintenance or something?
  Reply With Quote
Old 05-14-2011, 10:44 AM   #5
Senior Member
Littlebro 5 will become famous soon enough
 
Littlebro 5's Avatar
Name: Tyler
Joined: Jan 2011, #49292
Location: Wilsonville or
Gender: Male
Posts: 783
Littlebro 5's Tacoma Gallery
check the plug wires
  Reply With Quote
Old 05-14-2011, 11:37 AM   #6
Solid Axle FTMFW!!
Supra TT is one of the sharper tools in the shedSupra TT is one of the sharper tools in the shedSupra TT is one of the sharper tools in the shedSupra TT is one of the sharper tools in the shedSupra TT is one of the sharper tools in the shedSupra TT is one of the sharper tools in the shedSupra TT is one of the sharper tools in the shedSupra TT is one of the sharper tools in the shedSupra TT is one of the sharper tools in the shedSupra TT is one of the sharper tools in the shedSupra TT is one of the sharper tools in the shed
 
Supra TT's Avatar
Name: Eric
Joined: Jan 2011, #48645
Location: Lafayette, Indiana
Gender: Male
Posts: 4,716
Supra TT's Tacoma Gallery
You said you checked plugs, however one may still be bad and it looks good, trying replacing the plugs
  Reply With Quote
Old 05-14-2011, 02:32 PM   #7
Member
glamis3000 is on a distinguished road
Name: Brant
Joined: Feb 2011, #50795
Location: Cottage Grove OR
Age: 24
Gender: Male
Posts: 73
glamis3000's Tacoma Gallery
mine did this and it was because my spark plug boot would come off it was cracked and you couldnt see it. i bought all new spark plugs and wires and since then never have had a misfire since. it would also run funny, thats how i knew something was wrong. the rpm range was way off due to one cylinder not firing right.
  Reply With Quote
Old 05-14-2011, 09:50 PM   #8
2toys [OP] 2toys is offline
Member
2toys is on a distinguished road
Joined: Mar 2009, #15424
Location: Los Angeles
Gender: Male
Posts: 59
2toys's Tacoma Gallery
Thanks for all the suggestions, I have some plugs on order.

Today I added 1/3 Seafoam to the crankcase in hopes that something is gunked up in there. I did the paper at the tailpipe trick, and it didn't suck in so I thought that was good.

Also I cleaned up the throttle body. I looked in there first and it didn't look too bad. But I sprayed some cleaner in there and WOW! I cleaned and cleaned, as best I could without taking it off (as I don't have a gasket). Well this made a marked improvement. The RPMs are much more steady and the idle much more smooth. So far no codes.

I will report back more after I change the plugs.

Thanks!
  Reply With Quote
Old 05-15-2011, 07:32 AM   #9
Junior Member
sourdough44 is on a distinguished road
Navy:
Joined: Aug 2010, #41711
Location: WI
Gender: Male
Posts: 15
sourdough44's Tacoma Gallery
I had an ignition problem a while back on my 2.7 ltr 2000 Tacoma. The main issue was a bad plug wire.
  Reply With Quote
Old 05-15-2011, 10:20 AM   #10
Ditch Doctor
medic2230 is one of the sharper tools in the shedmedic2230 is one of the sharper tools in the shedmedic2230 is one of the sharper tools in the shedmedic2230 is one of the sharper tools in the shedmedic2230 is one of the sharper tools in the shedmedic2230 is one of the sharper tools in the shedmedic2230 is one of the sharper tools in the shedmedic2230 is one of the sharper tools in the shedmedic2230 is one of the sharper tools in the shedmedic2230 is one of the sharper tools in the shedmedic2230 is one of the sharper tools in the shed
 
medic2230's Avatar
EMS:
Name: Murph
Joined: Oct 2008, #9942
Location: Columbus, Ga
Age: 42
Gender: Male
Posts: 8,184
medic2230's Tacoma Gallery
If you put denso platinum plugs in it then that made mine misfire. I put the regular ngk's in it and presto all fixed. I got 196,xxx on mine. That engine doesn't like high dollar plugs. When I pulled the platinum plugs they looked fine too.

Murph
  Reply With Quote
Old 05-21-2011, 10:26 AM   #11
2toys [OP] 2toys is offline
Member
2toys is on a distinguished road
Joined: Mar 2009, #15424
Location: Los Angeles
Gender: Male
Posts: 59
2toys's Tacoma Gallery
(I've updated the first post to reflect my "progress" if you will.)

Yesterday I did the following:

Replaced the fuel injectors
Replaced spark plugs (denso oem, .043 gap)

All the above with no real noticeable improvement, though a bit more throttle response. A p0303 code will still come on, has been coming on at a cold startup. A flashing CEL will happen under load conditions such as climbing a grade. Engine still runs rough especially at idle. I can post vids if that would be of interest... The plugs and injectors looked ok, but the #3 plug was a lot more brown (plug read guides show "normal") then the others. This after the seafoam in the last 400 miles.

Also I pulled the plug on the #3 injector when running and it stumbles, so I know I'm getting fuel there. Also pulled the #3 spark wire and again stumbled and turned off, so apparently it's firing.

Also sprayed some carb cleaner to look for a vac leak, but found nothing.

I'm thinking of trying to clean the o2 sensors. Maybe their getting a bad reading to the ECU?
  Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
Want to move to California... 04LTtacoma Off-Topic Discussion 75 01-24-2011 10:46 AM
PS3 Move/Eye Toy/Move Controller/Sports Champion derekabraham Buy / Sell / Trade - Other 4 12-03-2010 03:28 PM
Made the move... NVR_QUIT 2nd Gen. Tacomas 14 10-31-2010 10:12 PM
To move or not to move! that is the question! fireturk41 Travel 15 02-18-2010 02:49 PM


Copyright © 2014 Tacoma Forum. Tacoma World is not owned by, or affiliated with Toyota Motor Corporation.