Mike "Wuzzy121". Rest in peace, brother

Go Back   Tacoma World Forums > Tacoma Discussion > 1st Gen. Tacomas

Notices

Engine won't high idle at start up

Reply
 
Thread Tools Search this Thread
Old 01-06-2012, 05:59 PM   #1
Member
96 tacomaPtown is on a distinguished road
Name: Bryan
Joined: Aug 2009, #21929
Location: Oregon
Gender: Male
Posts: 65
96 tacomaPtown's Tacoma Gallery
Exclamation Engine won't high idle at start up

4x4 2.7 liter tacoma. Everytime I Start my truck up warm or cold out it starts up lugs down like its gonna die then idles as if it is already warm. sometimes if i turn it off and start it up again it doesnt start up hesitates i give it gas and it starts up. it is acting like a cold blooded carbeurated ford in negative 10 weather. it does not go on high idle. I cleaned the air filter made sure whole intake was tight. cleaned vaccum valves and sensors. replace alot of vaccuum hoses and evap hoses. I have been fighting this for alon time it has a header a hollowed cat, intake, oxygen sensor simulator. i took the computer 15amp fuse out a week a go to see if it would relearn itself . no check engine light is or and noone can diagnose it with out a light. hesitates at accelloration a little and while speeding up to 50mph. i get 15miles per gallon... i used to get 20-21 it started doing this when i moved to 500 ft elevation from 1500. it didnt start till after a year or so of all the modifications. Been tempted to trade it off cause it is so agravating would like some insight please....
  Reply With Quote
Old 01-06-2012, 06:03 PM   #2
TW's Official anti body-lift pundit
TacoMX is one of the sharper tools in the shedTacoMX is one of the sharper tools in the shedTacoMX is one of the sharper tools in the shedTacoMX is one of the sharper tools in the shedTacoMX is one of the sharper tools in the shedTacoMX is one of the sharper tools in the shedTacoMX is one of the sharper tools in the shedTacoMX is one of the sharper tools in the shedTacoMX is one of the sharper tools in the shedTacoMX is one of the sharper tools in the shedTacoMX is one of the sharper tools in the shed
 
TacoMX's Avatar
EMS: Paramedic
Name: Jonathan
Joined: Aug 2011, #62240
Location: Deltona, Florida
Age: 24
Gender: Male
Posts: 4,838
TacoMX's Tacoma Gallery
clean the Throttle body and the idle air control valve.
  Reply With Quote
Old 01-06-2012, 06:04 PM   #3
Senior Member
TACOMABOSS is one of the sharper tools in the shedTACOMABOSS is one of the sharper tools in the shedTACOMABOSS is one of the sharper tools in the shedTACOMABOSS is one of the sharper tools in the shedTACOMABOSS is one of the sharper tools in the shedTACOMABOSS is one of the sharper tools in the shedTACOMABOSS is one of the sharper tools in the shedTACOMABOSS is one of the sharper tools in the shedTACOMABOSS is one of the sharper tools in the shedTACOMABOSS is one of the sharper tools in the shedTACOMABOSS is one of the sharper tools in the shed
Firefighter:
Joined: Jul 2011, #59499
Gender: Dude
Posts: 4,312
TACOMABOSS's Tacoma Gallery
im not positive on this but i dont think 4 bangers high idle when cold. i know they dont on an 04 4 banger
edit: unless it did it before
  Reply With Quote
Old 01-06-2012, 06:08 PM   #4
Member
96 tacomaPtown is on a distinguished road
Name: Bryan
Joined: Aug 2009, #21929
Location: Oregon
Gender: Male
Posts: 65
96 tacomaPtown's Tacoma Gallery
it usually brings it up to like 1000-1200 rpm but now it stays between 500-750 at start up. when its warm it brings it down of course. ill try cleaning my throttle body i know its difficult to tear everything down but might be best. i did just try spraying it with out taking it off but carbon kept comming out after each spray and never seemed very clean
  Reply With Quote
Old 01-06-2012, 06:10 PM   #5
Senior Member
TACOMABOSS is one of the sharper tools in the shedTACOMABOSS is one of the sharper tools in the shedTACOMABOSS is one of the sharper tools in the shedTACOMABOSS is one of the sharper tools in the shedTACOMABOSS is one of the sharper tools in the shedTACOMABOSS is one of the sharper tools in the shedTACOMABOSS is one of the sharper tools in the shedTACOMABOSS is one of the sharper tools in the shedTACOMABOSS is one of the sharper tools in the shedTACOMABOSS is one of the sharper tools in the shedTACOMABOSS is one of the sharper tools in the shed
Firefighter:
Joined: Jul 2011, #59499
Gender: Dude
Posts: 4,312
TACOMABOSS's Tacoma Gallery
Quote:
Originally Posted by 96 tacomaPtown View Post
it usually brings it up to like 1000-1200 rpm but now it stays between 500-750 at start up. when its warm it brings it down of course. ill try cleaning my throttle body i know its difficult to tear everything down but might be best. i did just try spraying it with out taking it off but carbon kept comming out after each spray and never seemed very clean
so it did idle high before. thats interesting. maybe check the cables going to the throttle body as well
  Reply With Quote
Old 01-06-2012, 06:13 PM   #7
Senior Member
TACOMABOSS is one of the sharper tools in the shedTACOMABOSS is one of the sharper tools in the shedTACOMABOSS is one of the sharper tools in the shedTACOMABOSS is one of the sharper tools in the shedTACOMABOSS is one of the sharper tools in the shedTACOMABOSS is one of the sharper tools in the shedTACOMABOSS is one of the sharper tools in the shedTACOMABOSS is one of the sharper tools in the shedTACOMABOSS is one of the sharper tools in the shedTACOMABOSS is one of the sharper tools in the shedTACOMABOSS is one of the sharper tools in the shed
Firefighter:
Joined: Jul 2011, #59499
Gender: Dude
Posts: 4,312
TACOMABOSS's Tacoma Gallery
Quote:
Originally Posted by 96 tacomaPtown View Post
throttle cables? or check vaccuum lines?
throttle cables
  Reply With Quote
Old 01-06-2012, 09:06 PM   #9
TW's Official anti body-lift pundit
TacoMX is one of the sharper tools in the shedTacoMX is one of the sharper tools in the shedTacoMX is one of the sharper tools in the shedTacoMX is one of the sharper tools in the shedTacoMX is one of the sharper tools in the shedTacoMX is one of the sharper tools in the shedTacoMX is one of the sharper tools in the shedTacoMX is one of the sharper tools in the shedTacoMX is one of the sharper tools in the shedTacoMX is one of the sharper tools in the shedTacoMX is one of the sharper tools in the shed
 
TacoMX's Avatar
EMS: Paramedic
Name: Jonathan
Joined: Aug 2011, #62240
Location: Deltona, Florida
Age: 24
Gender: Male
Posts: 4,838
TacoMX's Tacoma Gallery
Quote:
Originally Posted by 96 tacomaPtown View Post
it usually brings it up to like 1000-1200 rpm but now it stays between 500-750 at start up. when its warm it brings it down of course. ill try cleaning my throttle body i know its difficult to tear everything down but might be best. i did just try spraying it with out taking it off but carbon kept comming out after each spray and never seemed very clean
Its actually pretty easy. Go get another TB gasket from autozone before you do it though. The original one will fall apart.

The only real way to clean your TB is by taking it off the truck.
  Reply With Quote
Old 01-10-2012, 05:40 PM   #10
Member
96 tacomaPtown is on a distinguished road
Name: Bryan
Joined: Aug 2009, #21929
Location: Oregon
Gender: Male
Posts: 65
96 tacomaPtown's Tacoma Gallery
I went and bought the gasket today and found it was considerably cheap. only $1.76 and 3.99 for cleaner. i took intake off hoses and puled them out of the way. i would of taken it off completely but It is dark and i finally got cash to buy the supplies. I looked inside and found thick chunks of black gunk.my guess it is from the egr valve connected to the throttle body.. I couldnt just spray it away so I took a tooth brush to wipe it out and it was stuck on so I took a screw driver and hasd to scrape itout. It looked like it was blocking the EGR port and TBS port behind the butterfly. when I have the weekend. I am going to take it off all the way and do it right. I put it all back together started it up well turned the key till it started and gave it a lil gas to rid of all the cleaner and it purrred like a kitten. hesitated alil when I drove it but kept in second at 35mph to burn any excess crap pushed down the intake. at 249000 miles cant be that bad to just need a lil intake cleaning.
I will keep you updated if it rids of the problem entirely. should find out when I start it up in the morning if it idles fine.
  Reply With Quote
Old 01-12-2012, 05:28 PM   #11
Member
96 tacomaPtown is on a distinguished road
Name: Bryan
Joined: Aug 2009, #21929
Location: Oregon
Gender: Male
Posts: 65
96 tacomaPtown's Tacoma Gallery
well I went to start my truck this morning and it was 17 degrees I started my truck it died instantly, tried again died again, tried again and gave it gas it ran like crap but ran things that make you go hmmmm. ill try the whole thing this weekend see if things are clogged.
  Reply With Quote
Old 01-12-2012, 09:21 PM   #12
Member
Buggys3sgte is on a distinguished road
Name: !@$*
Joined: Mar 2011, #52274
Location: Psycho state of AZ
Gender: Male
Posts: 64
Buggys3sgte's Tacoma Gallery
Sounds like your CSI or your CSI switch isn't working properly.
  Reply With Quote
Old 01-12-2012, 09:35 PM   #13
Senior Member
Bosmob is a glorious beacon of lightBosmob is a glorious beacon of lightBosmob is a glorious beacon of lightBosmob is a glorious beacon of lightBosmob is a glorious beacon of light
 
Bosmob's Avatar
Name: Kevin
Joined: Jun 2011, #58017
Location: San Diego, CA
Gender: Male
Posts: 380
Bosmob's Tacoma Gallery
Quote:
Originally Posted by Buggys3sgte View Post
Sounds like your CSI or your CSI switch isn't working properly.
That's what I'm guessing too.

I had a 93 4Runner with that same issue and after replacing the CSI, it returned to normal.
  Reply With Quote
Old 01-13-2012, 01:50 PM   #14
Member
96 tacomaPtown is on a distinguished road
Name: Bryan
Joined: Aug 2009, #21929
Location: Oregon
Gender: Male
Posts: 65
96 tacomaPtown's Tacoma Gallery
what exactly is the csi? Ive been reading the Haynes repair manual and after looking at all the abbreviations my heads spinning.
  Reply With Quote
Old 01-13-2012, 10:39 PM   #15
Member
Buggys3sgte is on a distinguished road
Name: !@$*
Joined: Mar 2011, #52274
Location: Psycho state of AZ
Gender: Male
Posts: 64
Buggys3sgte's Tacoma Gallery
Cold Start Injector or the switch that triggers the injector.
  Reply With Quote
Old 01-20-2012, 07:55 PM   #16
Member
96 tacomaPtown is on a distinguished road
Name: Bryan
Joined: Aug 2009, #21929
Location: Oregon
Gender: Male
Posts: 65
96 tacomaPtown's Tacoma Gallery
posted some pics on my profile of befores and afters forgot to get after closeups of intake and throttle body but you can tell there was alot of gunk. it seemed to help a little bit in the morning but still has moments that it stumbles.
  Reply With Quote
Old 09-14-2012, 12:30 AM   #17
Member
96 tacomaPtown is on a distinguished road
Name: Bryan
Joined: Aug 2009, #21929
Location: Oregon
Gender: Male
Posts: 65
96 tacomaPtown's Tacoma Gallery
hopefully found the cure.

found out the exhaust gases comming to my egr valve had clogged the line to the diaphram. had tried previously to clean it but it was stubborn. had a chance to takeit off again and dissassemble it by running very hot water on it and using dishsoap to loosen the tube to pull it out. it was solid carbon and i had to use a drill to clean it out the run a piece of wire through it to clean any excess material out. ive prob only driven it 5 miles. but ive done that clean the filter oil change rear end seals bearings brakes, and new oxygen sensors. its running alot better now , im just waiting to see what the effects will be after running a few tanks through it and see the change in mileage.
  Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
High engine idle youngblood1856 2nd Gen. Tacomas 6 09-04-2011 12:16 PM
Changed alternator. High start idle won't fall 96Taco 1st Gen. Tacomas 14 04-08-2011 01:34 PM
High Idle and Check Engine Light? tacomarustingaway Technical Chat 4 03-13-2011 09:11 AM
engine won't idle j.r.217 Technical Chat 2 06-08-2009 02:34 PM
is a high idle speed normal for a cold engine start on auto trans. V6? wes 2nd Gen. Tacomas 8 12-30-2007 05:17 PM


Copyright © 2014 Tacoma Forum. Tacoma World is not owned by, or affiliated with Toyota Motor Corporation.