Mike "Wuzzy121". Rest in peace, brother

Go Back   Tacoma World Forums > Tacoma Discussion > 1st Gen. Tacomas

Notices

2 Probs: Have a POP when creeping and doing a Hard Steer, and Tie Rods/alignment

Reply
 
Thread Tools Search this Thread
Old 01-24-2012, 09:17 AM   #1
stucoma05 [OP] stucoma05 is offline
Junior Member
stucoma05 is on a distinguished road
Joined: Jun 2010, #39612
Gender: Male
Posts: 20
stucoma05's Tacoma Gallery
POP around left front when doing slow hard steering, also tie rods only lasted 3 yrs

Hey I wanted to first say I've been doing a lot of work on my Tacoma lately and yall are awesome: the community on this forum, extensive write-ups, geneoristy, NICE..... and thanks to everyone that is always trying to help others out anyway possible.

Heres my situation

I have a 99 Taco, Reg Cab, 2.7l 4x4 manual
-3" body lift
-All my suspension was upgraded last year
-My tie rods were replaced 3 years aho
-And recently removed: 2.5" coil spacers, AAL , and 35" tires (back to the 31's)

-----dont know if all this mattered

The problem is whenever i make a sharp turn at say 1 MPH to any direction there is this loud popping that you can hear and feel aswell in/around my Front Left Tire.

-- Add'l Info - My left IFS broke off last year at both ball joints and my cv axle. (But that has been all replaced) and an alignment was done so it was good to go. I mean i feel 100% confident in the work i did on it.

HTML Code:
line
The second problem.

I know my alignment is all jacked up, so i went ahead and put on my wheel spacers (1.5") and got an alignment done, the tech said he raised my truck and both inner and outer tie rods on the left side were, for lack of better words, bad.

So I'm wondering how they went that bad in 3 years, can there be another symptom to cause this? And would anybody like to share what they would do in this situation?

HTML Code:
line
Thanks in advance for the replies!
  Reply With Quote
Old 01-24-2012, 11:21 AM   #2
stucoma05 [OP] stucoma05 is offline
Junior Member
stucoma05 is on a distinguished road
Joined: Jun 2010, #39612
Gender: Male
Posts: 20
stucoma05's Tacoma Gallery
to early for bump?
  Reply With Quote
Old 01-24-2012, 12:22 PM   #3
Got Beer?
BeerHat will become famous soon enoughBeerHat will become famous soon enough
 
BeerHat's Avatar
Joined: Apr 2010, #36207
Location: TX
Gender: Male
Posts: 122
BeerHat's Tacoma Gallery
First Problem: Check you sway bar links; they tend to bind and pop when loose, especially when turning

Second Problem:
Confused by your question so I will try to answer as best I can, you said "Did an alignment and good to go" to "I Know my alignment is all jacked up..."
They can go bad after 3 years, especially if abused, larger wheels/tires, wheel spacers(increased scrub radius). Lift the front end of the truck and grab the tire at 3-9 o'clock and push on each side. If there is play, chances are your tie rod ends are toast. If you trust your Tech; have them replaced.
  Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
tie rods? colorado02taco Suspension 0 03-07-2011 05:34 PM
How to tie down rods? Bs 02 Taco Boating & Fishing 25 08-30-2010 09:22 AM
tie rods rab89 Suspension 12 01-18-2010 01:22 PM
Hard to Steer!!!! giantscalercguy 1st Gen. Tacomas 5 01-12-2010 02:07 PM
Tie Rods, Tie Rod End Question Toy4Life Technical Chat 11 02-20-2009 06:31 PM


Copyright © 2014 Tacoma Forum. Tacoma World is not owned by, or affiliated with Toyota Motor Corporation.