Mike "Wuzzy121". Rest in peace, brother

Go Back   Tacoma World Forums > Tacoma Discussion > 1st Gen. Tacomas

Notices

'Hiccup' problem with K&N cold air intake! fixable?

Reply
 
Thread Tools Search this Thread
Old 02-17-2012, 12:59 AM   #1
Senior Member
Soccerdallin is on a distinguished road
 
Soccerdallin's Avatar
Name: Dallin
Joined: Feb 2012, #72437
Location: Utah
Gender: Male
Posts: 159
Soccerdallin's Tacoma Gallery
'Hiccup' problem with K&N cold air intake! fixable?

Hello!

I installed a K&N cold air FIPK and a TB spacer as well like a week ago. I love the noise and extra power I've gained and better MPG, but sometimes when I'm floorin' it, the engine seems to studder. This doesn't happen often luckily. I might just take it in to the shop.. love the products but don't like the occasional 'hiccups' I get when I'm accelerating fast. Kind of seems to counteract the point of buying it....right? haha

Thanks!
Attached Thumbnails
'Hiccup' problem with K&N cold air intake! fixable?-imag0651.jpg  
  Reply With Quote
Old 02-17-2012, 01:28 AM   #2
LT Chase Truck
mikesdoublecab is one of the sharper tools in the shedmikesdoublecab is one of the sharper tools in the shedmikesdoublecab is one of the sharper tools in the shedmikesdoublecab is one of the sharper tools in the shedmikesdoublecab is one of the sharper tools in the shedmikesdoublecab is one of the sharper tools in the shedmikesdoublecab is one of the sharper tools in the shedmikesdoublecab is one of the sharper tools in the shedmikesdoublecab is one of the sharper tools in the shedmikesdoublecab is one of the sharper tools in the shedmikesdoublecab is one of the sharper tools in the shed
 
mikesdoublecab's Avatar
Name: Mohawk Mike
Joined: Jun 2008, #7334
Location: Glendale, CA
Age: 43
Gender: Male
Posts: 5,924
mikesdoublecab's Tacoma Gallery
maybe you are running too lean now?

with the intake and a throttle body, you get the increased air flow, but your injectors are still flowing at the same rate...

did you disconnect the battery when you installed the intake? i think the instructions tell you to... it resets your ECU and with the new air/fuel ratio, it will reset itself...

i had a similar issue when i first put my CAI and resetting the truck stopped the issues...
  Reply With Quote
Old 02-17-2012, 01:32 AM   #3
Senior Member
Soccerdallin is on a distinguished road
 
Soccerdallin's Avatar
Name: Dallin
Joined: Feb 2012, #72437
Location: Utah
Gender: Male
Posts: 159
Soccerdallin's Tacoma Gallery
Hmmm..pretty sure I disconnected the battery while I installed everything, but maybe I'm wrong.
I'll disconnect the battery for a while and then connect it and hope it helps.
I've read that the MAS could have something to do with it, but I made sure that it's secure.

I'll try that out and hope it works.
  Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
K&N COLD AIR INTAKE RJG1124 2nd Gen. Tacomas 2 01-05-2012 05:46 PM
K&N Cold Air Intake OCTaco Buy / Sell / Trade 8 05-20-2010 05:10 PM
K&N Cold Air Intake tacomathunder 2nd Gen. Tacomas 22 03-28-2010 04:53 PM
K&N cold air intake OCTaco New Members 4 01-18-2010 09:01 AM
K&N cold air intake 06BLUEDBLSPORT Performance and Tuning 11 05-13-2008 08:34 PM


Copyright © 2014 Tacoma Forum. Tacoma World is not owned by, or affiliated with Toyota Motor Corporation.