Mike "Wuzzy121". Rest in peace, brother

Go Back   Tacoma World Forums > Tacoma Discussion > 1st Gen. Tacomas

Notices

TPS SENSOR OR IAC VALVE

Reply
 
Thread Tools Search this Thread
Old 03-01-2012, 07:06 PM   #1
Senior Member
fouillard13 is one of the sharper tools in the shedfouillard13 is one of the sharper tools in the shedfouillard13 is one of the sharper tools in the shedfouillard13 is one of the sharper tools in the shedfouillard13 is one of the sharper tools in the shedfouillard13 is one of the sharper tools in the shedfouillard13 is one of the sharper tools in the shedfouillard13 is one of the sharper tools in the shedfouillard13 is one of the sharper tools in the shedfouillard13 is one of the sharper tools in the shedfouillard13 is one of the sharper tools in the shed
 
fouillard13's Avatar
Name: Riley
Joined: Jan 2009, #12619
Location: Canadia
Gender: Male
Posts: 987
fouillard13's Tacoma Gallery
TPS SENSOR OR IAC VALVE

My Tacoma has been acting weird. Its starts and idles at around 800 most times. When i rev it up and drive it and clutch in it stays at around 1200 or 1000. Sometimes when i start it it will idle at 1000. I completely cleaned Throttle body and iac and did deck plate mod and new K and N filter I also tried resetting the computer by unplugging negative post for half hour i also unplugged efi fuse. The OHM reading for the TPS is around .94 ohms and it should be around 1.0 to 2.0 ohms. If i rev my truck up to 4500 and let it drop it will almost always go back to 800 rmp but if i rev to 2000 it stays around 1200. I am thinking its either TPS or IAC.

Any help would be greatly appreciated
  Reply With Quote
Old 03-01-2012, 07:43 PM   #2
Senior Member
fouillard13 is one of the sharper tools in the shedfouillard13 is one of the sharper tools in the shedfouillard13 is one of the sharper tools in the shedfouillard13 is one of the sharper tools in the shedfouillard13 is one of the sharper tools in the shedfouillard13 is one of the sharper tools in the shedfouillard13 is one of the sharper tools in the shedfouillard13 is one of the sharper tools in the shedfouillard13 is one of the sharper tools in the shedfouillard13 is one of the sharper tools in the shedfouillard13 is one of the sharper tools in the shed
 
fouillard13's Avatar
Name: Riley
Joined: Jan 2009, #12619
Location: Canadia
Gender: Male
Posts: 987
fouillard13's Tacoma Gallery
anyone?
  Reply With Quote
Old 03-01-2012, 07:45 PM   #3
pavement is boring....
lotsoftoys is one of the sharper tools in the shedlotsoftoys is one of the sharper tools in the shedlotsoftoys is one of the sharper tools in the shedlotsoftoys is one of the sharper tools in the shedlotsoftoys is one of the sharper tools in the shedlotsoftoys is one of the sharper tools in the shedlotsoftoys is one of the sharper tools in the shedlotsoftoys is one of the sharper tools in the shedlotsoftoys is one of the sharper tools in the shedlotsoftoys is one of the sharper tools in the shedlotsoftoys is one of the sharper tools in the shed
 
lotsoftoys's Avatar
Name: Jace
Joined: Apr 2010, #35790
Location: Denver
Gender: Male
Posts: 5,178
lotsoftoys's Tacoma Gallery
3.4? Tps go bad all the time brotha
  Reply With Quote
Old 03-01-2012, 09:03 PM   #4
Senior Member
fouillard13 is one of the sharper tools in the shedfouillard13 is one of the sharper tools in the shedfouillard13 is one of the sharper tools in the shedfouillard13 is one of the sharper tools in the shedfouillard13 is one of the sharper tools in the shedfouillard13 is one of the sharper tools in the shedfouillard13 is one of the sharper tools in the shedfouillard13 is one of the sharper tools in the shedfouillard13 is one of the sharper tools in the shedfouillard13 is one of the sharper tools in the shedfouillard13 is one of the sharper tools in the shed
 
fouillard13's Avatar
Name: Riley
Joined: Jan 2009, #12619
Location: Canadia
Gender: Male
Posts: 987
fouillard13's Tacoma Gallery
yup 3.4! REALLY!??
  Reply With Quote
Old 03-02-2012, 08:14 AM   #5
Senior Member
Robertgeejr1 is one of the sharper tools in the shedRobertgeejr1 is one of the sharper tools in the shedRobertgeejr1 is one of the sharper tools in the shedRobertgeejr1 is one of the sharper tools in the shedRobertgeejr1 is one of the sharper tools in the shedRobertgeejr1 is one of the sharper tools in the shedRobertgeejr1 is one of the sharper tools in the shedRobertgeejr1 is one of the sharper tools in the shedRobertgeejr1 is one of the sharper tools in the shedRobertgeejr1 is one of the sharper tools in the shedRobertgeejr1 is one of the sharper tools in the shed
 
Robertgeejr1's Avatar
Name: Robert
Joined: Dec 2011, #69167
Location: Aorora, Ill, yeah!
Gender: Male
Posts: 771
Robertgeejr1's Tacoma Gallery
well not trying to be a smart-ass, but I have a file now of potential problems to look out for, and I found this.
http://www.yotatech.com/f123/do-not-...-sensor-91567/
  Reply With Quote
Old 03-02-2012, 11:31 AM   #6
TW's Official anti body-lift pundit
TacoMX is one of the sharper tools in the shedTacoMX is one of the sharper tools in the shedTacoMX is one of the sharper tools in the shedTacoMX is one of the sharper tools in the shedTacoMX is one of the sharper tools in the shedTacoMX is one of the sharper tools in the shedTacoMX is one of the sharper tools in the shedTacoMX is one of the sharper tools in the shedTacoMX is one of the sharper tools in the shedTacoMX is one of the sharper tools in the shedTacoMX is one of the sharper tools in the shed
 
TacoMX's Avatar
EMS: Paramedic
Name: Jonathan
Joined: Aug 2011, #62240
Location: Deltona, Florida
Age: 23
Gender: Male
Posts: 4,835
TacoMX's Tacoma Gallery
subbed, because My truck idles just like you are describing. But it only does it once in a while. But it runs fine other than the occasional idle irregularity.

Mine is a 2.7 though.
  Reply With Quote
Old 03-02-2012, 11:47 AM   #7
Senior Member
fouillard13 is one of the sharper tools in the shedfouillard13 is one of the sharper tools in the shedfouillard13 is one of the sharper tools in the shedfouillard13 is one of the sharper tools in the shedfouillard13 is one of the sharper tools in the shedfouillard13 is one of the sharper tools in the shedfouillard13 is one of the sharper tools in the shedfouillard13 is one of the sharper tools in the shedfouillard13 is one of the sharper tools in the shedfouillard13 is one of the sharper tools in the shedfouillard13 is one of the sharper tools in the shed
 
fouillard13's Avatar
Name: Riley
Joined: Jan 2009, #12619
Location: Canadia
Gender: Male
Posts: 987
fouillard13's Tacoma Gallery
I will be replacing the sensor tomrorow with a used one from wreckers just to see if it does anything before I order a new one.
  Reply With Quote
Old 03-03-2012, 06:02 PM   #8
Senior Member
fouillard13 is one of the sharper tools in the shedfouillard13 is one of the sharper tools in the shedfouillard13 is one of the sharper tools in the shedfouillard13 is one of the sharper tools in the shedfouillard13 is one of the sharper tools in the shedfouillard13 is one of the sharper tools in the shedfouillard13 is one of the sharper tools in the shedfouillard13 is one of the sharper tools in the shedfouillard13 is one of the sharper tools in the shedfouillard13 is one of the sharper tools in the shedfouillard13 is one of the sharper tools in the shed
 
fouillard13's Avatar
Name: Riley
Joined: Jan 2009, #12619
Location: Canadia
Gender: Male
Posts: 987
fouillard13's Tacoma Gallery
well spent the whole day screwing around with it. swapped a different tps and iac and still nothing. If i push down on the little arm that is connected to the butterfly valve it will idle down. I took it off for the 10nth time and the butter fly valve is seated nicely and closed all the way. On one side on the valve it is flush with the wall the other side you can see light. I don't know what else to try. I may go try another throttle body but i am almost at the point of giving up. I have cleaned. reset adjusted swapped 100 times now. Any ideas. Like i said i push that little arm in and it will idle down. I have tried to oil it up. and when i take the throttle body off and open and close the valve it seats nicely but when its on and running it doesn't?
  Reply With Quote
Old 03-03-2012, 06:16 PM   #9
Senior Member
fouillard13 is one of the sharper tools in the shedfouillard13 is one of the sharper tools in the shedfouillard13 is one of the sharper tools in the shedfouillard13 is one of the sharper tools in the shedfouillard13 is one of the sharper tools in the shedfouillard13 is one of the sharper tools in the shedfouillard13 is one of the sharper tools in the shedfouillard13 is one of the sharper tools in the shedfouillard13 is one of the sharper tools in the shedfouillard13 is one of the sharper tools in the shedfouillard13 is one of the sharper tools in the shed
 
fouillard13's Avatar
Name: Riley
Joined: Jan 2009, #12619
Location: Canadia
Gender: Male
Posts: 987
fouillard13's Tacoma Gallery
i am thinking maybe the vacume throttle opener is not working correctly?
  Reply With Quote
Old 03-03-2012, 06:16 PM   #10
Senior Member
fouillard13 is one of the sharper tools in the shedfouillard13 is one of the sharper tools in the shedfouillard13 is one of the sharper tools in the shedfouillard13 is one of the sharper tools in the shedfouillard13 is one of the sharper tools in the shedfouillard13 is one of the sharper tools in the shedfouillard13 is one of the sharper tools in the shedfouillard13 is one of the sharper tools in the shedfouillard13 is one of the sharper tools in the shedfouillard13 is one of the sharper tools in the shedfouillard13 is one of the sharper tools in the shed
 
fouillard13's Avatar
Name: Riley
Joined: Jan 2009, #12619
Location: Canadia
Gender: Male
Posts: 987
fouillard13's Tacoma Gallery
i know the vacume line is hooked up and sucking but maybe its the mechanism?
  Reply With Quote
Old 03-03-2012, 06:33 PM   #11
Senior Member
fouillard13 is one of the sharper tools in the shedfouillard13 is one of the sharper tools in the shedfouillard13 is one of the sharper tools in the shedfouillard13 is one of the sharper tools in the shedfouillard13 is one of the sharper tools in the shedfouillard13 is one of the sharper tools in the shedfouillard13 is one of the sharper tools in the shedfouillard13 is one of the sharper tools in the shedfouillard13 is one of the sharper tools in the shedfouillard13 is one of the sharper tools in the shedfouillard13 is one of the sharper tools in the shed
 
fouillard13's Avatar
Name: Riley
Joined: Jan 2009, #12619
Location: Canadia
Gender: Male
Posts: 987
fouillard13's Tacoma Gallery
i think this may solve it

http://www.yotatech.com/f2/throttle-...ck-off-242839/
  Reply With Quote
Old 03-04-2012, 03:20 PM   #12
Junior Member
nofx230 is on a distinguished road
 
nofx230's Avatar
Army:
Name: Matthew
Joined: Jan 2012, #70827
Location: Colorado Springs,CO
Gender: Male
Posts: 19
nofx230's Tacoma Gallery
yes i too been having idle issues with my 3.4l tacoma, was idling fine but noticed one day that throttle body was dirty so i cleaned it and the maf with electrical cleaner, after i did that the idle started being all wacky, stays at 1100-1200rpm but the weird part is when i slow down from say 60mph and push the clutch in the idle will drop to 1000rpm and keep bouncing up and down to 1500-1800rpm to 1000rmp and back up until I'm at a dead stop then i sits back down at 1100rpm??? wtf i clean the heck outta the throttle body,iac,maf and used starter fluid and checked for any vacuum leaks but nothing.
the weird idle is the only problem i see with the truck, drives good,cold starts fine,never stalls, its just really irritating because when in between shifts or every time i push the clutch in the idle goes up to 1500-1800rpm
  Reply With Quote
Old 03-04-2012, 04:57 PM   #13
Junior Member
nofx230 is on a distinguished road
 
nofx230's Avatar
Army:
Name: Matthew
Joined: Jan 2012, #70827
Location: Colorado Springs,CO
Gender: Male
Posts: 19
nofx230's Tacoma Gallery
yeah can't really use that spring trick either as every angle i try it binds up,
linkage is diff
  Reply With Quote
Old 03-05-2012, 11:06 AM   #14
Senior Member
fouillard13 is one of the sharper tools in the shedfouillard13 is one of the sharper tools in the shedfouillard13 is one of the sharper tools in the shedfouillard13 is one of the sharper tools in the shedfouillard13 is one of the sharper tools in the shedfouillard13 is one of the sharper tools in the shedfouillard13 is one of the sharper tools in the shedfouillard13 is one of the sharper tools in the shedfouillard13 is one of the sharper tools in the shedfouillard13 is one of the sharper tools in the shedfouillard13 is one of the sharper tools in the shed
 
fouillard13's Avatar
Name: Riley
Joined: Jan 2009, #12619
Location: Canadia
Gender: Male
Posts: 987
fouillard13's Tacoma Gallery
ya. What i did was i swapped both iac and tps. reset computer cleaned the throttle body spotless and still nothing. tried spring and worked ok. Got pissed off and took a hammer to the linkage and now it honestly works. It idles down to 800 everytime. it idles at 1000 when i start it but when i get going after about 5 min it drops fso it might be a bad tps. I tried everything in the book. I took the end of my hammer the rubber part and hit a linkage an forced it to close better and it did ahaha
  Reply With Quote
Old 03-13-2012, 06:22 AM   #15
Junior Member
nofx230 is on a distinguished road
 
nofx230's Avatar
Army:
Name: Matthew
Joined: Jan 2012, #70827
Location: Colorado Springs,CO
Gender: Male
Posts: 19
nofx230's Tacoma Gallery
Quote:
Originally Posted by fouillard13 View Post
ya. What i did was i swapped both iac and tps. reset computer cleaned the throttle body spotless and still nothing. tried spring and worked ok. Got pissed off and took a hammer to the linkage and now it honestly works. It idles down to 800 everytime. it idles at 1000 when i start it but when i get going after about 5 min it drops fso it might be a bad tps. I tried everything in the book. I took the end of my hammer the rubber part and hit a linkage an forced it to close better and it did ahaha

what about when your coasting,because i can deal with a high idle of 1100 but what pisses me off is when I'm coasting and i push in the clutch my idle will bounce from 1100-1800rpm or just sit at 2000rpm until the truck slows down to less than 5 mph and then the idle drops down to 1100????
problem didn't start till i cleaned the TB and maf, i reclined the TB,MAF,IAC checked for vacuum leaks with starter fluid reset the computer by pulling efi fuse and disconnecting battery nothing????
  Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
IAC VALVE dustinclm Technical Chat 1 03-07-2011 07:26 PM
tps sensor pinktaco808 2nd Gen. Tacomas 15 08-03-2010 10:03 PM
Bad IAC Valve 99GreenYota 1st Gen. Tacomas 8 05-10-2010 12:32 PM
02 Complete tacoma throttle body w/ TPS & IAC lightning78 Buy / Sell / Trade 5 02-09-2009 07:28 AM
IAC valve question.... ETaco23 1st Gen. Tacomas 2 04-24-2008 09:08 PM


Copyright © 2014 Tacoma Forum. Tacoma World is not owned by, or affiliated with Toyota Motor Corporation.