Mike "Wuzzy121". Rest in peace, brother

Go Back   Tacoma World Forums > Tacoma Discussion > 1st Gen. Tacomas

Notices

The p0420 code few questions

Reply
 
Thread Tools Search this Thread
Old 05-14-2012, 06:58 AM   #1
rll131 [OP] rll131 is offline
rll131
rll131 is on a distinguished road
Name: raymond
Joined: Oct 2011, #66030
Location: elkton md 21921
Age: 29
Gender: Male
Posts: 94
rll131's Tacoma Gallery
The p0420 code few questions

I have a 2000 2.4 Tacoma code just came one. There are no exhaust leaks and the truck still runs great and I'm getting around 26-27 mpg so no loss in gas mileage. What should I start with what should I replace first I tried resetting and putting different gas popped back on about 70 miles later.

Also I looked at the o2 sensor it was pretty dirty old looking but there was no plug I've changedno2 sensors before but there was always a plug that you just unplug this one has no plug so how would I change it and which o2'sensor do I change for this cod ethe one before the cat and after the manifold or the one after the cat and before the muffler.
  Reply With Quote
Old 05-14-2012, 10:11 AM   #2
Senior Member
tan4x4 is one of the sharper tools in the shedtan4x4 is one of the sharper tools in the shedtan4x4 is one of the sharper tools in the shedtan4x4 is one of the sharper tools in the shedtan4x4 is one of the sharper tools in the shedtan4x4 is one of the sharper tools in the shedtan4x4 is one of the sharper tools in the shedtan4x4 is one of the sharper tools in the shedtan4x4 is one of the sharper tools in the shedtan4x4 is one of the sharper tools in the shedtan4x4 is one of the sharper tools in the shed
 
tan4x4's Avatar
Name: Rick
Joined: Nov 2011, #67982
Location: Folsom, CA
Age: 59
Gender: Male
Posts: 1,334
tan4x4's Tacoma Gallery
Either bad sensor or bad cat. Just have to narrow it down.
What do you mean by 'no plug'? Not connected to the harness?

I think you can test the sensors with a resistance check.
If either one fails that, then replace it.
  Reply With Quote
Old 05-14-2012, 10:59 AM   #3
rll131 [OP] rll131 is offline
rll131
rll131 is on a distinguished road
Name: raymond
Joined: Oct 2011, #66030
Location: elkton md 21921
Age: 29
Gender: Male
Posts: 94
rll131's Tacoma Gallery
Yea there is no connecting harness on the o2 sensor behind the cat only on the one before the cat
  Reply With Quote
Old 05-15-2012, 07:48 AM   #4
Senior Member
tan4x4 is one of the sharper tools in the shedtan4x4 is one of the sharper tools in the shedtan4x4 is one of the sharper tools in the shedtan4x4 is one of the sharper tools in the shedtan4x4 is one of the sharper tools in the shedtan4x4 is one of the sharper tools in the shedtan4x4 is one of the sharper tools in the shedtan4x4 is one of the sharper tools in the shedtan4x4 is one of the sharper tools in the shedtan4x4 is one of the sharper tools in the shedtan4x4 is one of the sharper tools in the shed
 
tan4x4's Avatar
Name: Rick
Joined: Nov 2011, #67982
Location: Folsom, CA
Age: 59
Gender: Male
Posts: 1,334
tan4x4's Tacoma Gallery
Quote:
Originally Posted by rll131 View Post
Yea there is no connecting harness on the o2 sensor behind the cat only on the one before the cat
Well, that has got to be the problem, then.
Is it possible that someone tried to steal your cat, and cut off
that wire, before giving up or being scared off?

If so, you need to re-establish the connection. There should be dangling
wires (one from the sensor, and one from the harness nearby).
  Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
P0420 code trmarshall1 1st Gen. Tacomas 3 04-13-2012 08:53 AM
P0420 Code flesheatingvirus 1st Gen. Tacomas 7 05-08-2011 09:27 PM
p0420 code wildjerseyfirefighter 1st Gen. Tacomas 2 11-27-2010 08:40 AM
p0420 code tacoma20021964 Performance and Tuning 6 01-28-2010 04:24 PM
Code P0420 CoreyF 1st Gen. Tacomas 1 01-26-2010 05:02 PM


Copyright © 2014 Tacoma Forum. Tacoma World is not owned by, or affiliated with Toyota Motor Corporation.