Mike "Wuzzy121". Rest in peace, brother

Go Back   Tacoma World Forums > Tacoma Discussion > 1st Gen. Tacomas

Notices

help with MAF sensor

Reply
 
Thread Tools Search this Thread
Old 06-03-2012, 11:40 AM   #1
je99tacoma [OP] je99tacoma is offline
new member
je99tacoma is on a distinguished road
Name: Jonette
Joined: Jun 2012, #79990
Location: Olympia, Washington
Gender: Female
Posts: 3
je99tacoma's Tacoma Gallery
help with MAF sensor

I'd like to know how to replace an MAF sensor? Does it require just unplugging? Or a new wiring harness? I've already cleaned it with the spray from CRC, but it still shows that it as running too lean. I realize this sensor measures the air density. It's been very humid here the past week or so, if the sensor was not completely dry before I put it back in, could that have anything to do with it? Changed out the fuel filter yesterday, runs great after driving for awhile CEL popped back on. Any ideas?
  Reply With Quote
Old 06-03-2012, 12:58 PM   #2
The Rembrandt of Rattle Can
Madjik_Man is one of the sharper tools in the shedMadjik_Man is one of the sharper tools in the shedMadjik_Man is one of the sharper tools in the shedMadjik_Man is one of the sharper tools in the shedMadjik_Man is one of the sharper tools in the shedMadjik_Man is one of the sharper tools in the shedMadjik_Man is one of the sharper tools in the shedMadjik_Man is one of the sharper tools in the shedMadjik_Man is one of the sharper tools in the shedMadjik_Man is one of the sharper tools in the shedMadjik_Man is one of the sharper tools in the shed
 
Madjik_Man's Avatar
Joined: Dec 2009, #26893
Location: Boulder, CO
Gender: Male
Posts: 9,132
Madjik_Man's Tacoma Gallery
Quote:
Originally Posted by je99tacoma View Post
I'd like to know how to change replace an MAF sensor? Does it require just unplugging? Or a new wiring harness? I've already cleaned it with the spray from CRC, but it still shows that it as running too lean. Changed out the fuel filter yesterday, runs great after driving for awhile CEL popped on. Any ideas?
Don't quote me on this, but I think I've read here that after you do that (and/or clean the throttle body, etc) you need to reset the ECU.

I think you do that by disconnecting the battery for a while.

But I'd let others chime in for more experienced advice.
  Reply With Quote
Old 06-04-2012, 05:57 AM   #3
Senior Member
PolishAndWax.com is one of the sharper tools in the shedPolishAndWax.com is one of the sharper tools in the shedPolishAndWax.com is one of the sharper tools in the shedPolishAndWax.com is one of the sharper tools in the shedPolishAndWax.com is one of the sharper tools in the shedPolishAndWax.com is one of the sharper tools in the shedPolishAndWax.com is one of the sharper tools in the shedPolishAndWax.com is one of the sharper tools in the shedPolishAndWax.com is one of the sharper tools in the shedPolishAndWax.com is one of the sharper tools in the shedPolishAndWax.com is one of the sharper tools in the shed
 
PolishAndWax.com's Avatar
Joined: May 2009, #16962
Location: Orange County CA
Gender: Male
Posts: 603
PolishAndWax.com's Tacoma Gallery
I've cleaned mine twice and didn't have to reset anything.

What code is it throwing? Mine was throwing P0171.
  Reply With Quote
Old 06-04-2012, 09:52 AM   #4
je99tacoma [OP] je99tacoma is offline
new member
je99tacoma is on a distinguished road
Name: Jonette
Joined: Jun 2012, #79990
Location: Olympia, Washington
Gender: Female
Posts: 3
je99tacoma's Tacoma Gallery
Yep.... Same code

Even after changing out the fuel filter. So I just opted to pick up another MAF sensor for about $80 with core. Popped it in.... Easy. Drove to work this AM; no problems. My truck has about 130,000 miles on it. Hope this does the trick; sounds as good as the day I bought it.
  Reply With Quote
Old 06-04-2012, 04:01 PM   #5
Senior Member
PolishAndWax.com is one of the sharper tools in the shedPolishAndWax.com is one of the sharper tools in the shedPolishAndWax.com is one of the sharper tools in the shedPolishAndWax.com is one of the sharper tools in the shedPolishAndWax.com is one of the sharper tools in the shedPolishAndWax.com is one of the sharper tools in the shedPolishAndWax.com is one of the sharper tools in the shedPolishAndWax.com is one of the sharper tools in the shedPolishAndWax.com is one of the sharper tools in the shedPolishAndWax.com is one of the sharper tools in the shedPolishAndWax.com is one of the sharper tools in the shed
 
PolishAndWax.com's Avatar
Joined: May 2009, #16962
Location: Orange County CA
Gender: Male
Posts: 603
PolishAndWax.com's Tacoma Gallery
Quote:
Originally Posted by je99tacoma View Post
Even after changing out the fuel filter. So I just opted to pick up another MAF sensor for about $80 with core. Popped it in.... Easy. Drove to work this AM; no problems. My truck has about 130,000 miles on it. Hope this does the trick; sounds as good as the day I bought it.
Awesome.

BTW, what air filter are you running? I had the TRD for years and it seemed to dirty up the MAF sensor. I heard the same thing about the K&N.

I'm back to the OEM style now and am perfectly happy with it.
  Reply With Quote
Old 06-07-2012, 12:31 PM   #6
Senior Member
tacoma guy is one of the sharper tools in the shedtacoma guy is one of the sharper tools in the shedtacoma guy is one of the sharper tools in the shedtacoma guy is one of the sharper tools in the shedtacoma guy is one of the sharper tools in the shedtacoma guy is one of the sharper tools in the shedtacoma guy is one of the sharper tools in the shedtacoma guy is one of the sharper tools in the shedtacoma guy is one of the sharper tools in the shedtacoma guy is one of the sharper tools in the shedtacoma guy is one of the sharper tools in the shed
 
tacoma guy's Avatar
Joined: Jul 2010, #39944
Location: Phoenix Az.
Gender: Male
Posts: 679
tacoma guy's Tacoma Gallery
X2 I ran the K&N and it dirtyed up mine also. I have gone back to the OEM aswell. I have cleaned my MAF about 3or4 times now and all I do is unplug it and remove the two screws and spray it with CRC MAF cleaner let it air dry and reinstall it. I have never reset the ECU. I also clean my T.B. at the same time.
  Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
MAF Sensor Cleaning.. eric70412 1st Gen. Tacomas 25 05-26-2014 04:00 PM
Where the hell is the maf sensor? saugus 2nd Gen. Tacomas 4 10-08-2011 05:27 PM
MAF Sensor for V6 Viet2100 2nd Gen Tacoma Marketplace 2 05-09-2011 08:15 PM
URD MAF Sensor BiggWooD 1st Gen. Tacomas 0 03-30-2009 06:58 PM
MAF Sensor flesheatingvirus 1st Gen. Tacomas 3 07-03-2008 02:08 PM


Copyright © 2014 Tacoma Forum. Tacoma World is not owned by, or affiliated with Toyota Motor Corporation.