LSC15's 95 Tacoma 4x4

Go Back   Tacoma World Forums > Tacoma Discussion > 1st Gen. Tacomas

Notices

bad o2 sensor- is this a symtom?

Reply
 
Thread Tools Search this Thread Display Modes
Old 06-19-2012, 07:33 PM   #1
hgufrin [OP] hgufrin is offline
Junior Member
hgufrin is on a distinguished road
Joined: Jun 2012, #80973
Gender: Male
Posts: 8
hgufrin's Tacoma Gallery
bad o2 sensor- is this a symtom?

My 2003 3.4 auto will simply turn off while i am driving.. it does it at 60mph... it does it going around a corner... sometimes at a stop sign but then i just put it in neutral and it starts right back up. Can this be the o2 sensors?

I must say that my check engine light is callin for a new sensor but that is before this stalling issue even started.....

Any ideas on if the o2 sensors would cause stalling? I appreciate any help.
  Reply With Quote
Old 06-19-2012, 09:42 PM   #2
Senior Member
tan4x4 is one of the sharper tools in the shedtan4x4 is one of the sharper tools in the shedtan4x4 is one of the sharper tools in the shedtan4x4 is one of the sharper tools in the shedtan4x4 is one of the sharper tools in the shedtan4x4 is one of the sharper tools in the shedtan4x4 is one of the sharper tools in the shedtan4x4 is one of the sharper tools in the shedtan4x4 is one of the sharper tools in the shedtan4x4 is one of the sharper tools in the shedtan4x4 is one of the sharper tools in the shed
 
tan4x4's Avatar
Name: Rick
Joined: Nov 2011, #67982
Location: Folsom, CA
Age: 59
Gender: Male
Posts: 1,213
tan4x4's Tacoma Gallery
Quote:
Originally Posted by hgufrin View Post
My 2003 3.4 auto will simply turn off while i am driving.. it does it at 60mph... it does it going around a corner... sometimes at a stop sign but then i just put it in neutral and it starts right back up. Can this be the o2 sensors?

I must say that my check engine light is callin for a new sensor but that is before this stalling issue even started.....

Any ideas on if the o2 sensors would cause stalling? I appreciate any help.
The actual trouble code number would help.
  Reply With Quote
Old 06-20-2012, 07:50 AM   #3
hgufrin [OP] hgufrin is offline
Junior Member
hgufrin is on a distinguished road
Joined: Jun 2012, #80973
Gender: Male
Posts: 8
hgufrin's Tacoma Gallery
P0031 is the code.

Do you think this is what is causing the car to randomly just "turn off". Or do you think it would be an IAC or something like that?

Thanks for your help.
  Reply With Quote
Old 06-20-2012, 10:11 PM   #4
Senior Member
tan4x4 is one of the sharper tools in the shedtan4x4 is one of the sharper tools in the shedtan4x4 is one of the sharper tools in the shedtan4x4 is one of the sharper tools in the shedtan4x4 is one of the sharper tools in the shedtan4x4 is one of the sharper tools in the shedtan4x4 is one of the sharper tools in the shedtan4x4 is one of the sharper tools in the shedtan4x4 is one of the sharper tools in the shedtan4x4 is one of the sharper tools in the shedtan4x4 is one of the sharper tools in the shed
 
tan4x4's Avatar
Name: Rick
Joined: Nov 2011, #67982
Location: Folsom, CA
Age: 59
Gender: Male
Posts: 1,213
tan4x4's Tacoma Gallery
Quote:
Originally Posted by hgufrin View Post
P0031 is the code.

Do you think this is what is causing the car to randomly just "turn off". Or do you think it would be an IAC or something like that?

Thanks for your help.
That code means that the heater circuit for the sensor has too low of a voltage. Possibly a fuse or relay that supplies power to the heated sensor.

I don't know why this issue would cause a stall. No experience here with heated sensors. You might have another issue causing the stall.
  Reply With Quote
Old 06-20-2012, 11:32 PM   #5
Old & Forgetful
Janster is one of the sharper tools in the shedJanster is one of the sharper tools in the shedJanster is one of the sharper tools in the shedJanster is one of the sharper tools in the shedJanster is one of the sharper tools in the shedJanster is one of the sharper tools in the shedJanster is one of the sharper tools in the shedJanster is one of the sharper tools in the shedJanster is one of the sharper tools in the shedJanster is one of the sharper tools in the shedJanster is one of the sharper tools in the shed
 
Janster's Avatar
Name: Jandy
Joined: Mar 2007, #1138
Location: Lancaster, PA
Age: 46
Gender: Female
Posts: 12,686
Janster's Tacoma Gallery
Fix the O2 sensor first and foremost. O2 sensors have to do with emissions. Emissions has to do with your truck running clean & efficient (and that includes timing, fuel delivery, etc)

I can't say replacing it will fix your stalling problem..... but you'll have eliminated an issue that you otherwise 'don't know for sure' if it was a contributing factor or not.
  Reply With Quote
Old 06-28-2012, 12:34 PM   #6
hgufrin [OP] hgufrin is offline
Junior Member
hgufrin is on a distinguished road
Joined: Jun 2012, #80973
Gender: Male
Posts: 8
hgufrin's Tacoma Gallery
All,

Okay - so before I replaced the sensor - I cleaned the MAF, Throttle Body, Fuel Filter, and air filter.

I also replaced both sensors now... upstream and downstream... the car still stalls when i put it in drive or reverse... A new code has pulled up. The P0031 went away and now P0351 comes up.

Can you tell me what Ignition Coil A is? Which of the three? The autoparts store was not able to tell me

Sure appreciate your help.
  Reply With Quote
Old 06-28-2012, 12:46 PM   #7
:POOPCORN:
98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed
 
98tacoma27's Avatar
Marines:
Name: Ben
Joined: Dec 2008, #11714
Location: Beech Creek
Gender: Dude
Posts: 52,624
98tacoma27's Tacoma Gallery
http://ncttora.com/fsm/2003/Repair_M...fe/cip0351.pdf

It isn't a specific coil.

Do you have another code?
  Reply With Quote
Old 06-28-2012, 12:54 PM   #8
hgufrin [OP] hgufrin is offline
Junior Member
hgufrin is on a distinguished road
Joined: Jun 2012, #80973
Gender: Male
Posts: 8
hgufrin's Tacoma Gallery
uh oh. I knew there was something wrong.

I had the auto parts store guy clear the code and re do it because i didnt believe he knew what he was doing. It pulled P0351 two times and he said there was NO OTHER code...

I sure don't want to replace all three of them... Any ideas?
  Reply With Quote
Old 06-28-2012, 01:00 PM   #9
:POOPCORN:
98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed
 
98tacoma27's Avatar
Marines:
Name: Ben
Joined: Dec 2008, #11714
Location: Beech Creek
Gender: Dude
Posts: 52,624
98tacoma27's Tacoma Gallery
Quote:
Originally Posted by hgufrin View Post
uh oh. I knew there was something wrong.

I had the auto parts store guy clear the code and re do it because i didnt believe he knew what he was doing. It pulled P0351 two times and he said there was NO OTHER code...

I sure don't want to replace all three of them... Any ideas?
Yes, it's more than likely the ignitor, not a coil.
  Reply With Quote
Old 06-28-2012, 01:23 PM   #10
hgufrin [OP] hgufrin is offline
Junior Member
hgufrin is on a distinguished road
Joined: Jun 2012, #80973
Gender: Male
Posts: 8
hgufrin's Tacoma Gallery
Ignitor? Don't suppose you can tell me what that is? Im good with old cars just not my father n laws Tacoma...
  Reply With Quote
Old 06-28-2012, 01:55 PM   #11
hgufrin [OP] hgufrin is offline
Junior Member
hgufrin is on a distinguished road
Joined: Jun 2012, #80973
Gender: Male
Posts: 8
hgufrin's Tacoma Gallery
Oh yes - as it stands right now... I am driving... the car will only sputter and die when i put it in reverse and try to back up....any ideas?

I guess with P0351 I will replace the #1 coil and the ignitor??? just going to get pricey. Two oxygen sensors themselves were expensive
  Reply With Quote
Old 06-29-2012, 02:22 PM   #12
hgufrin [OP] hgufrin is offline
Junior Member
hgufrin is on a distinguished road
Joined: Jun 2012, #80973
Gender: Male
Posts: 8
hgufrin's Tacoma Gallery
Problem Solved.

P0351 - on my car meant the coil on cylinder #5. I looked at it this morning and it was not fully fastened/clipped in.

Wondering if someone at the dealership sabotaged it when they were running the 02 sensor codes and changing my oil... Hey- I have to blame someone because those things just dont pop off...

The stalling was caused by a loose coil wire and the P0031 was the 02 sensor.

So, two 02 sensors, fuel filter, MAF cleaning, Throttle Body cleaning, Air filter, and wire connection checking finally paid off!!!!!!!!!! All it was was a loose coil wire.
  Reply With Quote
Old 06-29-2012, 07:50 PM   #13
:POOPCORN:
98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed
 
98tacoma27's Avatar
Marines:
Name: Ben
Joined: Dec 2008, #11714
Location: Beech Creek
Gender: Dude
Posts: 52,624
98tacoma27's Tacoma Gallery
Interesting. I'm still surprised you didn't throw a 300 series code (cylinder misfire). Glad it was simple and cheap fix.
  Reply With Quote
Old 07-02-2012, 05:48 AM   #14
hgufrin [OP] hgufrin is offline
Junior Member
hgufrin is on a distinguished road
Joined: Jun 2012, #80973
Gender: Male
Posts: 8
hgufrin's Tacoma Gallery
I definitely didnt have a 300 cylinder misfire code. That was interesting to me too.

P.S. - called the dealership and asked them what P0351 code meant... The tech there told me to put it on the #1 Cylinder ! Glad I didnt listen to her.
  Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
Help needed for a live reading of rear o2 sensor (bank 1 sensor 2) geoff06 Technical Chat 7 11-30-2011 04:57 AM
O2 sensor replaced and now truck runs bad Thelumberwagon 1st Gen. Tacomas 43 08-31-2011 09:48 AM
99 Tacoma 4x4 O2 Sensor Bank1 Sensor 2 GASKET?? vapovick 4 Cylinder 2 08-17-2010 05:04 PM
K&N Box filter + Deck plate mod = bad O2 sensor StAndrew 1st Gen. Tacomas 11 07-14-2010 06:55 PM
3.4 coil packs, rear O2 sensor, water temp sensor glassdoc Buy / Sell / Trade 6 01-28-2009 06:51 AM


Copyright © 2014 Tacoma Forum. Tacoma World is not owned by, or affiliated with Toyota Motor Corporation.