Mike "Wuzzy121". Rest in peace, brother

Go Back   Tacoma World Forums > Tacoma Discussion > 1st Gen. Tacomas

Notices

Surging/Rough Idle/Poor Acceleration/Starting Problems

Reply
 
Thread Tools Search this Thread
Old 08-31-2012, 11:21 AM   #1
brunit [OP] brunit is offline
Junior Member
brunit is on a distinguished road
Joined: May 2010, #37977
Gender: Male
Posts: 3
brunit's Tacoma Gallery
Surging/Rough Idle/Poor Acceleration/Starting Problems

Alright guys I have a 98 2.4l 5 lugger 2wd, about 108,000 miles on it. It's had a rough idle for awhile now, it didnt have it when I first got it with 72000 miles on it. I could live with that, but lately its been having more problems specifically surging/hesitating while just coasting or cruising and during low end acceleration. It also sometimes has a delay when I try to accelerate especially at lower speeds. Sometimes it surges and bucks like crazy. Also in the mornings and sometimes during the day when I try to start it up it cranks then dies. I have to rev it while cranking it to get it going. Now in the mornings I dont even bother with trying to start it without the revving, its that bad. Here's what I've tried, Changed spark plugs and Seafoamed, both through the vacumn line and just dropping it in the tank. Seamfoam seems to help slightly at first, but then I quickly start to have the same problem. What I wanted to see from anyone on here is what are the cheaper/more low cost things I can try to do before going in and having a mechanic charge to look at it and then pay a chunk for whatever they diagnose. Like what simple cleaning and maintenence should I try first, like cleaning maf, seafoam, etc. Any thoughts would be appreciated.
  Reply With Quote
Old 08-31-2012, 11:25 AM   #2
Wait for it...
StAndrew is one of the sharper tools in the shedStAndrew is one of the sharper tools in the shedStAndrew is one of the sharper tools in the shedStAndrew is one of the sharper tools in the shedStAndrew is one of the sharper tools in the shedStAndrew is one of the sharper tools in the shedStAndrew is one of the sharper tools in the shedStAndrew is one of the sharper tools in the shedStAndrew is one of the sharper tools in the shedStAndrew is one of the sharper tools in the shedStAndrew is one of the sharper tools in the shed
 
StAndrew's Avatar
Navy: SWO
Name: Chris
Joined: Feb 2010, #30950
Location: Hampton Roads, Va
Gender: Male
Posts: 4,355
StAndrew's Tacoma Gallery
Can't hurt to clean your MAF and throttle body but I dont think that will help. Sounds like your not getting a good flow of gas. The Seafoam in your tank should clean up the injectors but when was the last time you changed your fuel filter?
  Reply With Quote
Old 09-01-2012, 09:25 AM   #3
brunit [OP] brunit is offline
Junior Member
brunit is on a distinguished road
Joined: May 2010, #37977
Gender: Male
Posts: 3
brunit's Tacoma Gallery
I took it into a Toyota dealership a few months ago and they recommended replacing it, the part was only like 40$ but they wanted to charge 400-500$ to install it because its apparently very difficult to get to on my truck. I'm ok with doing basic maintenance but bigger things I don't have experience doing.
  Reply With Quote
Old 09-01-2012, 05:14 PM   #4
Wait for it...
StAndrew is one of the sharper tools in the shedStAndrew is one of the sharper tools in the shedStAndrew is one of the sharper tools in the shedStAndrew is one of the sharper tools in the shedStAndrew is one of the sharper tools in the shedStAndrew is one of the sharper tools in the shedStAndrew is one of the sharper tools in the shedStAndrew is one of the sharper tools in the shedStAndrew is one of the sharper tools in the shedStAndrew is one of the sharper tools in the shedStAndrew is one of the sharper tools in the shed
 
StAndrew's Avatar
Navy: SWO
Name: Chris
Joined: Feb 2010, #30950
Location: Hampton Roads, Va
Gender: Male
Posts: 4,355
StAndrew's Tacoma Gallery
Here's a "how to" (just scroll to the bottom of the page):

http://www.4x4wire.com/toyota/mainte...tenancep5.html
  Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
Surging high idle with a P1135 code. Demented1 1st Gen. Tacomas 0 03-16-2012 08:55 AM
Rough idle and poor acceleration justeven03 1st Gen. Tacomas 5 03-15-2011 11:24 AM
high idle/surging amenard 1st Gen. Tacomas 0 01-11-2011 10:39 AM
Poor Acceleration NCSU-Cohiba Performance and Tuning 12 08-24-2009 04:18 PM
Idle RPM surging...... RelentlessTaco 2nd Gen. Tacomas 13 01-31-2009 10:16 PM


Copyright © 2014 Tacoma Forum. Tacoma World is not owned by, or affiliated with Toyota Motor Corporation.