Mike "Wuzzy121". Rest in peace, brother

Go Back   Tacoma World Forums > Tacoma Discussion > 1st Gen. Tacomas

Notices

Truck Will not Idle

Reply
 
Thread Tools Search this Thread
Old 01-06-2013, 10:02 AM   #1
shaggie [OP] shaggie is offline
Junior Member
shaggie is on a distinguished road
Name: sean
Joined: Jan 2013, #94565
Location: CA
Gender: Male
Posts: 3
shaggie's Tacoma Gallery
Truck Will not Idle

I own a 2001Tacoma 4WD with a 2.7L engine. With 245k on the truck, it still runs strong; however, the truck has developed a problem. Yesterday, I tried starting the truck from a cold start and it did not want to idle. The truck would run only if I kept my foot on the gas and the engine revved up; however, when I removed my foot from the accelerator, the engine would die. Could this be an O2 or mass air flow sensor? I just cleaned the mass air flow sensor about six months ago with a cleaner designed for that purpose. I have not seen an error code or a check-engine light on the dashboard, and the truck runs great as long as I keep the engine revved up. This problem happened overnight Any suggestions? Would appreciate the help.

Thanks,
Shaggie
  Reply With Quote
Old 01-06-2013, 10:08 AM   #2
41 Year Toyota/Chrysler Tech/ASE Master
Tacoma Mike is one of the sharper tools in the shedTacoma Mike is one of the sharper tools in the shedTacoma Mike is one of the sharper tools in the shedTacoma Mike is one of the sharper tools in the shedTacoma Mike is one of the sharper tools in the shedTacoma Mike is one of the sharper tools in the shedTacoma Mike is one of the sharper tools in the shedTacoma Mike is one of the sharper tools in the shedTacoma Mike is one of the sharper tools in the shedTacoma Mike is one of the sharper tools in the shedTacoma Mike is one of the sharper tools in the shed
 
Tacoma Mike's Avatar
Name: Mike
Joined: Aug 2011, #61230
Location: Southern Maine
Gender: Male
Posts: 2,915
Tacoma Mike's Tacoma Gallery
I would start with cleaning the throttle body..
  Reply With Quote
Old 01-06-2013, 10:10 AM   #3
UBIQUE
Highland Logan is one of the sharper tools in the shedHighland Logan is one of the sharper tools in the shedHighland Logan is one of the sharper tools in the shedHighland Logan is one of the sharper tools in the shedHighland Logan is one of the sharper tools in the shedHighland Logan is one of the sharper tools in the shedHighland Logan is one of the sharper tools in the shedHighland Logan is one of the sharper tools in the shedHighland Logan is one of the sharper tools in the shedHighland Logan is one of the sharper tools in the shedHighland Logan is one of the sharper tools in the shed
 
Highland Logan's Avatar
Canadian Army: Royal Canadian Artillery (Sgt, Ret.)
Name: Frank
Joined: Apr 2011, #54752
Location: Nova Scotia, Canada
Gender: Male
Posts: 2,748
Highland Logan's Tacoma Gallery
Maybe a Mod could also move this to the 1st Gen section, where the OP may get more advice.

Best of luck.

Frank
  Reply With Quote
Old 01-06-2013, 10:20 AM   #4
Senior Member
2000GTacoma is one of the sharper tools in the shed2000GTacoma is one of the sharper tools in the shed2000GTacoma is one of the sharper tools in the shed2000GTacoma is one of the sharper tools in the shed2000GTacoma is one of the sharper tools in the shed2000GTacoma is one of the sharper tools in the shed2000GTacoma is one of the sharper tools in the shed2000GTacoma is one of the sharper tools in the shed2000GTacoma is one of the sharper tools in the shed2000GTacoma is one of the sharper tools in the shed2000GTacoma is one of the sharper tools in the shed
 
2000GTacoma's Avatar
Joined: Jan 2011, #50183
Location: Snow Hill NC
Gender: Male
Posts: 2,111
2000GTacoma's Tacoma Gallery
Idle air control valve would be my first guess. I would clean throttle body and iac and then try it. Mine 1st gen v6 3.4 and my fathers 3.4 both developed idle issues. Cleaned the throttle body and iac and no more problems.
  Reply With Quote
Old 01-06-2013, 11:38 AM   #5
The Rembrandt of Rattle Can
Madjik_Man is one of the sharper tools in the shedMadjik_Man is one of the sharper tools in the shedMadjik_Man is one of the sharper tools in the shedMadjik_Man is one of the sharper tools in the shedMadjik_Man is one of the sharper tools in the shedMadjik_Man is one of the sharper tools in the shedMadjik_Man is one of the sharper tools in the shedMadjik_Man is one of the sharper tools in the shedMadjik_Man is one of the sharper tools in the shedMadjik_Man is one of the sharper tools in the shedMadjik_Man is one of the sharper tools in the shed
 
Madjik_Man's Avatar
Joined: Dec 2009, #26893
Location: Boulder, CO
Gender: Male
Posts: 9,132
Madjik_Man's Tacoma Gallery
Quote:
Originally Posted by 2000GTacoma View Post
Idle air control valve would be my first guess. I would clean throttle body and iac and then try it. Mine 1st gen v6 3.4 and my fathers 3.4 both developed idle issues. Cleaned the throttle body and iac and no more problems.
This. And if it persists after that, maybe the throttle position sensor is bad?
  Reply With Quote
Old 01-06-2013, 02:57 PM   #6
luv gettin in the Taco
Tacomaniacal is on a distinguished road
Name: Matt
Joined: May 2012, #79261
Location: South Florida
Age: 32
Gender: Male
Posts: 82
Tacomaniacal's Tacoma Gallery
Clean the throttle body first. If persists check the idle control valve
  Reply With Quote
Old 01-06-2013, 03:06 PM   #7
Senior Member
2000GTacoma is one of the sharper tools in the shed2000GTacoma is one of the sharper tools in the shed2000GTacoma is one of the sharper tools in the shed2000GTacoma is one of the sharper tools in the shed2000GTacoma is one of the sharper tools in the shed2000GTacoma is one of the sharper tools in the shed2000GTacoma is one of the sharper tools in the shed2000GTacoma is one of the sharper tools in the shed2000GTacoma is one of the sharper tools in the shed2000GTacoma is one of the sharper tools in the shed2000GTacoma is one of the sharper tools in the shed
 
2000GTacoma's Avatar
Joined: Jan 2011, #50183
Location: Snow Hill NC
Gender: Male
Posts: 2,111
2000GTacoma's Tacoma Gallery
Quote:
Originally Posted by Tacomaniacal View Post
Clean the throttle body first. If persists check the idle control valve
In order to throughly clean the tb it should be removed imo. only takes about 10-15mins. I would clean the iac as well since it is easily accessed.
  Reply With Quote
Old 01-06-2013, 04:11 PM   #8
ASE Master Tech
BamaToy1997 is one of the sharper tools in the shedBamaToy1997 is one of the sharper tools in the shedBamaToy1997 is one of the sharper tools in the shedBamaToy1997 is one of the sharper tools in the shedBamaToy1997 is one of the sharper tools in the shedBamaToy1997 is one of the sharper tools in the shedBamaToy1997 is one of the sharper tools in the shedBamaToy1997 is one of the sharper tools in the shedBamaToy1997 is one of the sharper tools in the shedBamaToy1997 is one of the sharper tools in the shedBamaToy1997 is one of the sharper tools in the shed
 
BamaToy1997's Avatar
Marines: M1A2 hull/turret technician, 4th Maint Btn. 4th FSSG.
Name: Bill
Joined: Jan 2012, #71846
Location: Marion, AL
Age: 45
Gender: Male
Posts: 7,843
BamaToy1997's Tacoma Gallery
I suggest finding the problem before tearing into things. See if you have a friend who has a scan tool or talk to a local parts store. Many have them for rent for cheap or sometimes free. Look at the data and see what is not within range. THEN look at taking something apart. Did this happen suddenly, or is it something that looking back you can see it was getting worse until now?
  Reply With Quote
Old 01-13-2013, 07:16 PM   #9
shaggie [OP] shaggie is offline
Junior Member
shaggie is on a distinguished road
Name: sean
Joined: Jan 2013, #94565
Location: CA
Gender: Male
Posts: 3
shaggie's Tacoma Gallery
Thank you everybody for all of your suggestions! The idle problem that my truck was experiencing was caused by a dirty IAC valve. I used some CRC throttle body cleamer that I had laying around to clean the IAC; and now, my Tacoma runs perfect! I appreciate the help.

Shaggie
  Reply With Quote
Old 01-13-2013, 07:29 PM   #10
Senior Member
2000GTacoma is one of the sharper tools in the shed2000GTacoma is one of the sharper tools in the shed2000GTacoma is one of the sharper tools in the shed2000GTacoma is one of the sharper tools in the shed2000GTacoma is one of the sharper tools in the shed2000GTacoma is one of the sharper tools in the shed2000GTacoma is one of the sharper tools in the shed2000GTacoma is one of the sharper tools in the shed2000GTacoma is one of the sharper tools in the shed2000GTacoma is one of the sharper tools in the shed2000GTacoma is one of the sharper tools in the shed
 
2000GTacoma's Avatar
Joined: Jan 2011, #50183
Location: Snow Hill NC
Gender: Male
Posts: 2,111
2000GTacoma's Tacoma Gallery
Not a problem glad you found the problem for cheap.
  Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
truck idle high jayjayralph 1st Gen. Tacomas 18 07-18-2012 10:34 AM
1994 Toyota truck Idle Help Beyea Performance and Tuning 0 12-14-2010 05:23 PM
how to make my truck idle at 1 rpm.. cwitters86 1st Gen. Tacomas 20 02-10-2010 06:34 PM
How long would you let your truck idle? yotarob2005 2nd Gen. Tacomas 32 11-29-2009 12:35 PM
Does your truck idle like this Auto Technical Chat 5 11-23-2009 08:15 AM


Copyright © 2014 Tacoma Forum. Tacoma World is not owned by, or affiliated with Toyota Motor Corporation.