LSC15's 95 Tacoma 4x4

Go Back   Tacoma World Forums > Tacoma Discussion > 1st Gen. Tacomas

Notices

Power issues - hesitant performance

Reply
 
Thread Tools Search this Thread Display Modes
Old 04-23-2013, 11:09 AM   #1
vantaco [OP] vantaco is offline
Senior Member
vantaco is just really nicevantaco is just really nicevantaco is just really nicevantaco is just really nice
Joined: Jul 2010, #40631
Gender: Male
Posts: 503
vantaco's Tacoma Gallery
Power issues - hesitant performance

my sister has a 97 4runner, 3.6L and has been having running issues for some time now

over the past year the following has been replaced:

- cat
- plugs
- all coils (was throwing codes)
- MAF has been cleaned (this weekend)
- fuel filter (this weekend)

originally the car was just seeming gutless...going up a steep hill on the highway the truck would accelerate to about 80 then stop accelerating but the rpm's would continue to climb

after this weekends work, it how does it a 90, but the tranny downshift pretty violently and continues to speed up then upshift

any ideas what could be causing this? bad 02? TPS?

the plugs were changed last year so they could have been fouled out again

any help would be great.....she'd getting terrible fuel mileage in the process and she drives quite a bit

thanks
  Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
Hesitant about New Toyota Purchase creedler 2nd Gen. Tacomas 25 11-23-2012 08:20 PM
Intermittent Power and Brake performance ? rockiemtnlvr 2nd Gen. Tacomas 0 02-25-2011 08:25 AM
power issues? m12taco85 1st Gen. Tacomas 9 10-14-2009 02:29 PM
Boost performance and power JimmyIvine 1st Gen. Tacomas 2 08-25-2009 04:16 AM
2.4L performance issues... deadazleep 1st Gen. Tacomas 16 04-30-2009 07:46 AM


Copyright © 2014 Tacoma Forum. Tacoma World is not owned by, or affiliated with Toyota Motor Corporation.