Mike "Wuzzy121". Rest in peace, brother

Go Back   Tacoma World Forums > Tacoma Discussion > 1st Gen. Tacomas

Notices

p0303, p0300

Reply
 
Thread Tools Search this Thread
Old 04-26-2013, 05:47 PM   #1
peow130 [OP] peow130 is offline
Junior Member
peow130 is on a distinguished road
Name: Bryan
Joined: Apr 2013, #102922
Location: Spokane, WA
Age: 22
Gender: Male
Posts: 26
peow130's Tacoma Gallery
p0303, p0300

Hey there, new member here. I've posted on ttora and PBB and Yotatech about these problems. Nobody has any ideas and i'm at a loss, so maybe you guys can chime in too.

My truck is a 1998 Tacoma w/ 2.7L 3RZ-FE, and a 5-speed.


Here's a re-cap of the things that have happened to this point with this truck.

The headgasket blew/was leaking. The truck DID NOT OVERHEAT.
I replaced the headgasket, then had to replace the fuel pump, the injector at 3, and some other stuff.

Then, i found i had shit compression on 3, pulled the head again and found some pretty crusty valves.

So, after replacing the valves, i put all the valve lash to spec for ALL the valves (between .012 and .016 exhaust, .006 and .010 intake)

So, here we are, a new fuel pump, new headgasket, new injector at 3, new ECT, and a bunch of work.

I still have a P0303, and a P0300.
I've swapped the 2-3 coil with the 1-4 coil and no change. I checked the plugs, and they even LOOK normal (sort of tan on the tip).

I haven't got a clue what to do next.
My LTFT on the last check was only 1.5%, which is in range of what it should be, and actually shows an excess in fuel, but not what i would say is worthy of an actual misfire.

I have NO vacuum leaks, and i have NO other codes. No codes for O2's, or Catalytics..

Anybody have any ideas?
  Reply With Quote
Old 04-26-2013, 06:03 PM   #2
Senior Member
beaver_scott is one of the sharper tools in the shedbeaver_scott is one of the sharper tools in the shedbeaver_scott is one of the sharper tools in the shedbeaver_scott is one of the sharper tools in the shedbeaver_scott is one of the sharper tools in the shedbeaver_scott is one of the sharper tools in the shedbeaver_scott is one of the sharper tools in the shedbeaver_scott is one of the sharper tools in the shedbeaver_scott is one of the sharper tools in the shedbeaver_scott is one of the sharper tools in the shedbeaver_scott is one of the sharper tools in the shed
 
beaver_scott's Avatar
Name: scott
Joined: Jun 2010, #38609
Location: renton, wa
Age: 38
Gender: Male
Posts: 199
beaver_scott's Tacoma Gallery
after you did the head gasket and valve work on #3 did you retest the compression? check the plug wires...you already checked the coil...I had a spark plug go bad after less than 1000 miles and it was giving me a misfire and #6 cylinder miss codes (ive got the 4L motor). the spark plug looked good but there was an internal defect undetectable by looking at it. maybe the computer has a problem?
  Reply With Quote
Old 04-26-2013, 06:12 PM   #3
peow130 [OP] peow130 is offline
Junior Member
peow130 is on a distinguished road
Name: Bryan
Joined: Apr 2013, #102922
Location: Spokane, WA
Age: 22
Gender: Male
Posts: 26
peow130's Tacoma Gallery
Quote:
Originally Posted by beaver_scott View Post
after you did the head gasket and valve work on #3 did you retest the compression? check the plug wires...you already checked the coil...I had a spark plug go bad after less than 1000 miles and it was giving me a misfire and #6 cylinder miss codes (ive got the 4L motor). the spark plug looked good but there was an internal defect undetectable by looking at it. maybe the computer has a problem?
I'll re-check compression but i don't think it's the problem. The truck runs fine when it's warm. In fact, it took 62 miles for the misfire to even show up the first time after i had the head back on.

I re-checked the plugs, all of them looked the same. However, the gapping wasn't to spec. I put them all at ~.045 (just at spec)

I noticed that there was oil at the base of the #3 spark plug, where the nut part of the plug is. My valvecover might be leaking oil at the spark plug tube. Would this cause a short at the plug?
  Reply With Quote
Old 04-27-2013, 02:05 PM   #4
Member
camt10 is on a distinguished road
Joined: Dec 2007, #3706
Posts: 60
camt10's Tacoma Gallery
When is dtc setting have you reviewed freeze frame data
  Reply With Quote
Old 04-28-2013, 10:34 AM   #5
peow130 [OP] peow130 is offline
Junior Member
peow130 is on a distinguished road
Name: Bryan
Joined: Apr 2013, #102922
Location: Spokane, WA
Age: 22
Gender: Male
Posts: 26
peow130's Tacoma Gallery
I pulled the codes and check the freeze frame data.

~-1.5% LTFT, 0%STFT, and the ect and iat were correct
iat read ~68*, ect at like 195

I pulled the EGR and cleaned it yesterday. It was leaking a little bit. Then i pulled the valve cover and replaced those gaskets.

Seemed to run a fair bit better after the EGR cleaning. I drove like ~35 miles without an MIL coming on

EDIT: I started it this morning, it was misfiring but only when it was cold. It won't do it when it's warm.
  Reply With Quote
Old 04-28-2013, 01:24 PM   #6
Member
Bmack04 is on a distinguished road
 
Bmack04's Avatar
Joined: Apr 2013, #102860
Location: Ohio
Gender: Male
Posts: 41
Bmack04's Tacoma Gallery
When you had the cylinder head off did you have the head and block checked for flatness?
  Reply With Quote
Old 04-28-2013, 01:38 PM   #7
ASE Master Tech
BamaToy1997 is one of the sharper tools in the shedBamaToy1997 is one of the sharper tools in the shedBamaToy1997 is one of the sharper tools in the shedBamaToy1997 is one of the sharper tools in the shedBamaToy1997 is one of the sharper tools in the shedBamaToy1997 is one of the sharper tools in the shedBamaToy1997 is one of the sharper tools in the shedBamaToy1997 is one of the sharper tools in the shedBamaToy1997 is one of the sharper tools in the shedBamaToy1997 is one of the sharper tools in the shedBamaToy1997 is one of the sharper tools in the shed
 
BamaToy1997's Avatar
Marines: M1A2 hull/turret technician, 4th Maint Btn. 4th FSSG.
Name: Bill
Joined: Jan 2012, #71846
Location: Marion, AL
Age: 45
Gender: Male
Posts: 7,573
BamaToy1997's Tacoma Gallery
I had a similar issue with mine on #2 cylinder. would misfire cold, but run fine after it started. I ended up having a crack in the cylinder wall which allowed a small amount of coolant enter the engine while it cooled. Then it would miss for a bit when it first started, and run like a champ after that. I agree with Bmack, did you look at the cylinder walls when you had the head off?

When you took the head off the second time, did you use new head bolts again? You can't reuse these head bolts once they are torqued.
  Reply With Quote
Old 04-28-2013, 02:04 PM   #8
peow130 [OP] peow130 is offline
Junior Member
peow130 is on a distinguished road
Name: Bryan
Joined: Apr 2013, #102922
Location: Spokane, WA
Age: 22
Gender: Male
Posts: 26
peow130's Tacoma Gallery
Quote:
Originally Posted by Bmack04 View Post
When you had the cylinder head off did you have the head and block checked for flatness?
I checked the head with a machinists ruler, it wasn't warped.
I also checked the deck, it was true as well.

I did re-use the headbolts

I'm not losing any coolant at all, but i'll go out and triple check.

The second time i had the head off, i pretty much didn't turn the crank, cyl 3 and 2 were at the top of the stroke so i couldn't see the cylinder walls.

I've about had it with this truck. It never did this crap before i had to replace the HG the first time.

EDIT: I checked the coolant again. Not low at all, still full. And there isn't any excessive steam on cold start up. Just runs like dog shit when cold, then smooths out after a minute of driving.
  Reply With Quote
Old 04-29-2013, 09:15 AM   #9
ASE Master Tech
BamaToy1997 is one of the sharper tools in the shedBamaToy1997 is one of the sharper tools in the shedBamaToy1997 is one of the sharper tools in the shedBamaToy1997 is one of the sharper tools in the shedBamaToy1997 is one of the sharper tools in the shedBamaToy1997 is one of the sharper tools in the shedBamaToy1997 is one of the sharper tools in the shedBamaToy1997 is one of the sharper tools in the shedBamaToy1997 is one of the sharper tools in the shedBamaToy1997 is one of the sharper tools in the shedBamaToy1997 is one of the sharper tools in the shed
 
BamaToy1997's Avatar
Marines: M1A2 hull/turret technician, 4th Maint Btn. 4th FSSG.
Name: Bill
Joined: Jan 2012, #71846
Location: Marion, AL
Age: 45
Gender: Male
Posts: 7,573
BamaToy1997's Tacoma Gallery
Well don't give up on it yet. More than likely there is something that was simply missed/overlooked when you did the head gasket the first time. My biggest issue at this point is the re-use of the head bolts. Those head bolts are single-use because they are torque-to-yield bolts that microscopically stretch when installed. This stretching causes issues if you ever try to reinstall the bolt.

As for your misfire condition. You may have done this before, but let's go over a few quick checks. Since 2 and 3 are companion cylinders, you should never swap out components for testing. So if the miss is on #3, move the spark plug from #3 to #1. Clear codes and test drive. If miss is still at #3 then swap the two coils (1-4 and 2-3 coils) If miss is still there, then recheck compression on ALL cylinders. Post the results when you have that done.
  Reply With Quote
Old 04-29-2013, 10:29 AM   #10
peow130 [OP] peow130 is offline
Junior Member
peow130 is on a distinguished road
Name: Bryan
Joined: Apr 2013, #102922
Location: Spokane, WA
Age: 22
Gender: Male
Posts: 26
peow130's Tacoma Gallery
Quote:
Originally Posted by BamaToy1997 View Post
Well don't give up on it yet. More than likely there is something that was simply missed/overlooked when you did the head gasket the first time. My biggest issue at this point is the re-use of the head bolts. Those head bolts are single-use because they are torque-to-yield bolts that microscopically stretch when installed. This stretching causes issues if you ever try to reinstall the bolt.

As for your misfire condition. You may have done this before, but let's go over a few quick checks. Since 2 and 3 are companion cylinders, you should never swap out components for testing. So if the miss is on #3, move the spark plug from #3 to #1. Clear codes and test drive. If miss is still at #3 then swap the two coils (1-4 and 2-3 coils) If miss is still there, then recheck compression on ALL cylinders. Post the results when you have that done.
I'll do a compression check this evening. I did already swap the 1-4 coil and the 2-3 coil, but i didn't try swapping the plugs. I'll do that in part with the compression check this evening.

Is there any particular way to get a good reading when i do the check? Should i spin the engine by hand or should i turn it over with the starter.
  Reply With Quote
Old 04-29-2013, 11:30 AM   #11
ASE Master Tech
BamaToy1997 is one of the sharper tools in the shedBamaToy1997 is one of the sharper tools in the shedBamaToy1997 is one of the sharper tools in the shedBamaToy1997 is one of the sharper tools in the shedBamaToy1997 is one of the sharper tools in the shedBamaToy1997 is one of the sharper tools in the shedBamaToy1997 is one of the sharper tools in the shedBamaToy1997 is one of the sharper tools in the shedBamaToy1997 is one of the sharper tools in the shedBamaToy1997 is one of the sharper tools in the shedBamaToy1997 is one of the sharper tools in the shed
 
BamaToy1997's Avatar
Marines: M1A2 hull/turret technician, 4th Maint Btn. 4th FSSG.
Name: Bill
Joined: Jan 2012, #71846
Location: Marion, AL
Age: 45
Gender: Male
Posts: 7,573
BamaToy1997's Tacoma Gallery
The only way to get a compression reading that is accurate is to remove all of the plugs, and spin the engine over by the starter. Allow the engine several revolutions. Then, since it is easy to do so, after testing each cylinder dry, do a wet test by adding about a teaspoon or less of oil into the spark plug hole, then reinstall the gauge and retest. This will help check the condition of the rings.
  Reply With Quote
Old 04-29-2013, 12:03 PM   #12
peow130 [OP] peow130 is offline
Junior Member
peow130 is on a distinguished road
Name: Bryan
Joined: Apr 2013, #102922
Location: Spokane, WA
Age: 22
Gender: Male
Posts: 26
peow130's Tacoma Gallery
I'll get back to you in a few hours with the results. Gotta do some HW first.
  Reply With Quote
Old 04-29-2013, 07:23 PM   #13
peow130 [OP] peow130 is offline
Junior Member
peow130 is on a distinguished road
Name: Bryan
Joined: Apr 2013, #102922
Location: Spokane, WA
Age: 22
Gender: Male
Posts: 26
peow130's Tacoma Gallery
I'll update.

Since i've already swapped the 2-3 coil and the 1-4 coil, i decided to swap the #3 spark plug with the #1 plug.
The engine was "cold". When i re-started it didn't misfire or start a CEL after i'd started it.
I'll have to wait until tomorrow morning when it's completely cold for it to throw a code for me, and i'll update then.

I won't get the chance to go rent a compression checker until thursday, and i won't be able to check compression til friday. Hopefully by tomorrow i'll know if my misfire has moved.

I will say this, i couldn't even tell the engine was running when i started it about 1/2 hour after the first start. Idled perfect at 750, no misfires, etc. But it was already hot.

Edit: started up perfectly at 330am with plugs swapped. Littke bit of a choppy idle but cleared up in a second and dropped down to 750. Smooth throughout the rpm range with plenty of power. And no MIL/CEL
  Reply With Quote
Old 04-30-2013, 05:39 AM   #14
ASE Master Tech
BamaToy1997 is one of the sharper tools in the shedBamaToy1997 is one of the sharper tools in the shedBamaToy1997 is one of the sharper tools in the shedBamaToy1997 is one of the sharper tools in the shedBamaToy1997 is one of the sharper tools in the shedBamaToy1997 is one of the sharper tools in the shedBamaToy1997 is one of the sharper tools in the shedBamaToy1997 is one of the sharper tools in the shedBamaToy1997 is one of the sharper tools in the shedBamaToy1997 is one of the sharper tools in the shedBamaToy1997 is one of the sharper tools in the shed
 
BamaToy1997's Avatar
Marines: M1A2 hull/turret technician, 4th Maint Btn. 4th FSSG.
Name: Bill
Joined: Jan 2012, #71846
Location: Marion, AL
Age: 45
Gender: Male
Posts: 7,573
BamaToy1997's Tacoma Gallery
We will cross our fingers. Perhaps a poor connection for the plug? Will be waiting to help out if it reoccurs. It may be a while before I get back on though. Mom is in the hospital on 24 hour watch, and my 12 hour shift starts again today at 11am.
  Reply With Quote
Old 04-30-2013, 06:16 AM   #15
peow130 [OP] peow130 is offline
Junior Member
peow130 is on a distinguished road
Name: Bryan
Joined: Apr 2013, #102922
Location: Spokane, WA
Age: 22
Gender: Male
Posts: 26
peow130's Tacoma Gallery
No worries man. I really appreciate the help as it is.

I most likely wont be able to do anything until friday like i said, school and work consume most of my time.

4 cold restarts, no check engine light ~45 miles driven today.
  Reply With Quote
Old 05-02-2013, 11:09 AM   #16
peow130 [OP] peow130 is offline
Junior Member
peow130 is on a distinguished road
Name: Bryan
Joined: Apr 2013, #102922
Location: Spokane, WA
Age: 22
Gender: Male
Posts: 26
peow130's Tacoma Gallery
Started misfiring again this morning, actually gave me a CEL to work with.. Still p0303.. :/

I'll be renting a compression tester tomorrow.
  Reply With Quote
Old 05-07-2013, 05:23 PM   #17
peow130 [OP] peow130 is offline
Junior Member
peow130 is on a distinguished road
Name: Bryan
Joined: Apr 2013, #102922
Location: Spokane, WA
Age: 22
Gender: Male
Posts: 26
peow130's Tacoma Gallery
I'll update this for anybody searching.

The good news: We figured out the problem! I took it to a mechanic, i haven't had time to do jack with school and work, so i just dropped it off at a shop.

The bad news: 50psi on cylinder 3.
He didn't pour oil in the cyl to check if it was rings, or valves. My guess is just a cracked or warped head, since the cylinder walls all looked good.

So, since i haven't got the cash to fix it, or the interest anymore, i'm going to sell it. Thanks for all the help everyone!
  Reply With Quote
Old 05-07-2013, 05:40 PM   #18
ASE Master Tech
BamaToy1997 is one of the sharper tools in the shedBamaToy1997 is one of the sharper tools in the shedBamaToy1997 is one of the sharper tools in the shedBamaToy1997 is one of the sharper tools in the shedBamaToy1997 is one of the sharper tools in the shedBamaToy1997 is one of the sharper tools in the shedBamaToy1997 is one of the sharper tools in the shedBamaToy1997 is one of the sharper tools in the shedBamaToy1997 is one of the sharper tools in the shedBamaToy1997 is one of the sharper tools in the shedBamaToy1997 is one of the sharper tools in the shed
 
BamaToy1997's Avatar
Marines: M1A2 hull/turret technician, 4th Maint Btn. 4th FSSG.
Name: Bill
Joined: Jan 2012, #71846
Location: Marion, AL
Age: 45
Gender: Male
Posts: 7,573
BamaToy1997's Tacoma Gallery
Dang, if I had the money I would pick that up from you. Sorry to hear the bad news man. What are you going to be asking for it?
  Reply With Quote
Old 05-08-2013, 10:24 AM   #19
peow130 [OP] peow130 is offline
Junior Member
peow130 is on a distinguished road
Name: Bryan
Joined: Apr 2013, #102922
Location: Spokane, WA
Age: 22
Gender: Male
Posts: 26
peow130's Tacoma Gallery
Quote:
Originally Posted by BamaToy1997 View Post
Dang, if I had the money I would pick that up from you. Sorry to hear the bad news man. What are you going to be asking for it?
I have it on craigslist for 2000 obo.
  Reply With Quote
Old 05-08-2013, 01:51 PM   #20
ASE Master Tech
BamaToy1997 is one of the sharper tools in the shedBamaToy1997 is one of the sharper tools in the shedBamaToy1997 is one of the sharper tools in the shedBamaToy1997 is one of the sharper tools in the shedBamaToy1997 is one of the sharper tools in the shedBamaToy1997 is one of the sharper tools in the shedBamaToy1997 is one of the sharper tools in the shedBamaToy1997 is one of the sharper tools in the shedBamaToy1997 is one of the sharper tools in the shedBamaToy1997 is one of the sharper tools in the shedBamaToy1997 is one of the sharper tools in the shed
 
BamaToy1997's Avatar
Marines: M1A2 hull/turret technician, 4th Maint Btn. 4th FSSG.
Name: Bill
Joined: Jan 2012, #71846
Location: Marion, AL
Age: 45
Gender: Male
Posts: 7,573
BamaToy1997's Tacoma Gallery
Dang I wish I had the $$. I would snatch that up in a second!
  Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
p0303 code wtf! mixaro 1st Gen. Tacomas 2 09-29-2012 11:30 AM
3rz p0300,p0302 r3sistance 4 Cylinder 2 08-01-2012 07:04 PM
getting p0300 code MrMackey89 2nd Gen. Tacomas 3 11-02-2011 09:06 PM
2001 with P0303 and P0306 Scout1 1st Gen. Tacomas 3 01-20-2011 08:20 AM
p0300 and p0051 codes... HOSS454 2nd Gen. Tacomas 3 11-30-2008 09:36 PM


Copyright © 2014 Tacoma Forum. Tacoma World is not owned by, or affiliated with Toyota Motor Corporation.