Mike "Wuzzy121". Rest in peace, brother

Go Back   Tacoma World Forums > Tacoma Discussion > 1st Gen. Tacomas

Notices

Please Help- must travel far- 14 mpg!!

Reply
 
Thread Tools Search this Thread
Old 02-28-2009, 05:02 PM   #1
sbvaughn88 [OP] sbvaughn88 is offline
Junior Member
sbvaughn88 is on a distinguished road
Joined: Feb 2009, #13291
Location: Grove City, OH
Gender: Male
Posts: 9
sbvaughn88's Tacoma Gallery
Please Help- must travel far- 14 mpg!!

Okay guys here it is- I am looking for any advice about my issue before I suck it up, grab my ankles, and bend over for Toyota. I have changed my O2 sensor and A/F Sensor (Before Cats) to get my check engine light to go off- The rear sensor is a Bosch and the front is from Toyota. Upon changing the rear sensor light did not go off and changed the front and it did. I thought the problem was solved until my gas mileage dropped about 7 or 8 miles per gallon! I tried changing the plugs- they all looked ok, I tried seafoam (truck seems to idle a little better), and I cleaned my MAF Sensor and throttle body-- No change....I scratched my head and then remembered another post that talked about "soft codes" the computer stores so I travel to Advance. The guy hooked it up and I pulled 3 codes on the scanner but have no CEL light??? they are....

P0440...EVAP incorrect purge flow
P0441...EVAP VSV Circuit fault
P0446...EVAP vent control malfunction

I have not idea what these mean, nor am i sure that they are related to the drop in MPG that happened. The only stupid thing I did was hack the old front sensor to death trying to get it out- Ohio has bad rust problems, basically cut it in half leaving an exposed hole in the exhaust and then drove it to a buddys house about 30 miles away to use a torch to free the bolts. Then installed sensor. I noticed the MPG drop on the way to his house- you could and still can watch the gas gauge needle go down. I am beyond my knowledge here??? Other than that the truck idles fine, drives fine, no funny smells, no huge loss in power maybe very minor, and sounds ok. Toyota wants $102 flat fee just to look at it and maybe tell me what the problem is and judging by the guy I talked to on the phone (who didn't know that the computer could store codes without throwing a CEL light) I think the minds on this forum are far superior. Any help would be greatly appreciated.....I have to drive to Tennessee next week which is 8 hrs away and 12-14 mpg won't do my wallet any favors.
  Reply With Quote
Old 03-01-2009, 09:15 AM   #2
With sufficient thrust, pigs fly just fine.
chris4x4 is one of the sharper tools in the shedchris4x4 is one of the sharper tools in the shedchris4x4 is one of the sharper tools in the shedchris4x4 is one of the sharper tools in the shedchris4x4 is one of the sharper tools in the shedchris4x4 is one of the sharper tools in the shedchris4x4 is one of the sharper tools in the shedchris4x4 is one of the sharper tools in the shedchris4x4 is one of the sharper tools in the shedchris4x4 is one of the sharper tools in the shedchris4x4 is one of the sharper tools in the shed
 
chris4x4's Avatar
Name: FlimFlubberJAM
Joined: May 2008, #6497
Location: Tenoe, AZ
Gender: Male
Posts: 99,005
chris4x4's Tacoma Gallery
I would clear the codes. AS the engine light is no longer lit, it may be fine now, but the engine could be in "limp mode".......Just thinking out loud.....
  Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
v6 manual 13-14 mpg JimmyBuckets 2nd Gen. Tacomas 103 12-14-2012 12:01 AM
14.5 mpg when i drive like a grandma!? wth.. Tacomatrd2010 Technical Chat 39 04-27-2011 09:22 PM
Just increased my mpg's from 14 - 18.25 BSP4x4 2nd Gen. Tacomas 61 01-26-2010 08:22 PM
14" travel Wysper Suspension 3 06-03-2009 11:36 PM
12-14 mpg!! 06Bluez 2nd Gen. Tacomas 23 10-31-2008 07:32 AM


Copyright © 2014 Tacoma Forum. Tacoma World is not owned by, or affiliated with Toyota Motor Corporation.