Mike "Wuzzy121". Rest in peace, brother

Go Back   Tacoma World Forums > Tacoma Discussion > 1st Gen. Tacomas

Notices

O2 sensor?

Reply
 
Thread Tools Search this Thread
Old 07-16-2013, 05:27 PM   #1
rckstr [OP] rckstr is offline
Junior Member
rckstr is on a distinguished road
Joined: Nov 2012, #92082
Location: Tennessee
Gender: Male
Posts: 14
rckstr's Tacoma Gallery
O2 sensor?

Check engine light is on. Cleaned the MAF and reset the code by disconnecting the battery for 10 min. The light stayed off for a day then came back on. The truck is running poorly if you get into the throttle. Code thrown is too lean in bank one. Think its the O2? Would that cause it to run poorly?
  Reply With Quote
Old 07-16-2013, 05:28 PM   #2
Boss
TPain is one of the sharper tools in the shedTPain is one of the sharper tools in the shedTPain is one of the sharper tools in the shedTPain is one of the sharper tools in the shedTPain is one of the sharper tools in the shedTPain is one of the sharper tools in the shedTPain is one of the sharper tools in the shedTPain is one of the sharper tools in the shedTPain is one of the sharper tools in the shedTPain is one of the sharper tools in the shedTPain is one of the sharper tools in the shed
 
TPain's Avatar
Name: Tanner
Joined: Sep 2012, #87426
Location: Asheville, NC
Age: 20
Gender: Male
Posts: 295
TPain's Tacoma Gallery
Don't know what would be causing it to run poorly but it could be a bad cat
  Reply With Quote
Old 07-16-2013, 05:29 PM   #3
Senior Member
04trd is a name known to all04trd is a name known to all04trd is a name known to all04trd is a name known to all04trd is a name known to all04trd is a name known to all
 
04trd's Avatar
Name: Matt
Joined: Dec 2009, #27696
Location: Cleveland Ohio
Age: 23
Gender: Male
Posts: 786
04trd's Tacoma Gallery
Up stream o2 sensor. I've had mine go bad. My 04 had no power at all and would drink fuel like a fish
  Reply With Quote
Old 07-17-2013, 07:04 AM   #4
rckstr [OP] rckstr is offline
Junior Member
rckstr is on a distinguished road
Joined: Nov 2012, #92082
Location: Tennessee
Gender: Male
Posts: 14
rckstr's Tacoma Gallery
Does the bank 1 code mean its upstream? Where is the best place to buy a new Denso sensor? The truck runs fine at low rpm, but when you mash on the gas, the truck spits and sputters (backfired once). Im thinking it may be the sensor.
  Reply With Quote
Old 07-17-2013, 11:22 AM   #5
ASE Master Tech
BamaToy1997 is one of the sharper tools in the shedBamaToy1997 is one of the sharper tools in the shedBamaToy1997 is one of the sharper tools in the shedBamaToy1997 is one of the sharper tools in the shedBamaToy1997 is one of the sharper tools in the shedBamaToy1997 is one of the sharper tools in the shedBamaToy1997 is one of the sharper tools in the shedBamaToy1997 is one of the sharper tools in the shedBamaToy1997 is one of the sharper tools in the shedBamaToy1997 is one of the sharper tools in the shedBamaToy1997 is one of the sharper tools in the shed
 
BamaToy1997's Avatar
Marines: M1A2 hull/turret technician, 4th Maint Btn. 4th FSSG.
Name: Bill
Joined: Jan 2012, #71846
Location: Marion, AL
Age: 45
Gender: Male
Posts: 7,660
BamaToy1997's Tacoma Gallery
If your engine is sputtering and backfiring, and the code is a lean code, I would look more towards a vacuum leak off-idle (ported vacuum) or something along those lines. Maybe even a fuel supply issue (Which would cause a lean code as well) The bank 1 A/F sensor IS upstream, so it is the closest one to the engine.
  Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
o2 sensor? 13dolphan72 1st Gen. Tacomas 3 01-25-2012 02:06 AM
Help needed for a live reading of rear o2 sensor (bank 1 sensor 2) geoff06 Technical Chat 7 11-30-2011 04:57 AM
99 Tacoma 4x4 O2 Sensor Bank1 Sensor 2 GASKET?? vapovick 4 Cylinder 2 08-17-2010 05:04 PM
Part Number A/F sensor and O2 sensor derekp 1st Gen. Tacomas 4 04-07-2010 10:34 AM
3.4 coil packs, rear O2 sensor, water temp sensor glassdoc Buy / Sell / Trade 6 01-28-2009 06:51 AM


Copyright © 2014 Tacoma Forum. Tacoma World is not owned by, or affiliated with Toyota Motor Corporation.