Mike "Wuzzy121". Rest in peace, brother

Go Back   Tacoma World Forums > Tacoma Discussion > 1st Gen. Tacomas

Notices

Lost all electric while starting

Reply
 
Thread Tools Search this Thread
Old 09-16-2013, 08:52 PM   #1
Stretch815 [OP] Stretch815 is offline
Junior Member
Stretch815 is on a distinguished road
 
Stretch815's Avatar
Name: Stretch
Joined: Aug 2013, #111099
Location: Chicagoland
Gender: Male
Posts: 15
Stretch815's Tacoma Gallery
Lost all electric while starting

So my taco is a 5 speed - it seems to have a very sensitive switch on the clutch pedal to start this truck. Tonight I jumped in and tried to go but I turned the key and my foot must have moved- then a fairly loud click and everything went dark. No power.

I popped off the negative battery cable for ten seconds and reattached, started with no apparent issues - other than having to reset my radio presets and the clock.

Do you think its a bad switch on the clutch pedal?

Thanks for you suggestions!
  Reply With Quote
Old 09-17-2013, 06:25 AM   #2
Senior Member
MowTaco is one of the sharper tools in the shedMowTaco is one of the sharper tools in the shedMowTaco is one of the sharper tools in the shedMowTaco is one of the sharper tools in the shedMowTaco is one of the sharper tools in the shedMowTaco is one of the sharper tools in the shedMowTaco is one of the sharper tools in the shedMowTaco is one of the sharper tools in the shedMowTaco is one of the sharper tools in the shedMowTaco is one of the sharper tools in the shedMowTaco is one of the sharper tools in the shed
 
MowTaco's Avatar
Name: Matt
Joined: Sep 2009, #22530
Location: Kansas/Iowa/South Dakota
Age: 21
Gender: Male
Posts: 3,773
MowTaco's Tacoma Gallery
I've noticed my switch to be quite touchy as well, but never caused anything like this.
  Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
I'm lost... Xewkija631 2nd Gen. Tacomas 4 03-04-2011 05:20 PM
I'm still lost bragado 2nd Gen. Tacomas 6 01-24-2011 07:28 PM
I Seem To Have Lost My Way Around Justin626 Off-Topic Discussion 30 04-10-2010 10:15 PM
S**T I lost them Tacoguy 1st Gen. Tacomas 5 01-16-2010 04:50 PM
Help I Am Lost!!! ace99025 Audio & Video 6 10-29-2009 09:32 PM


Copyright © 2014 Tacoma Forum. Tacoma World is not owned by, or affiliated with Toyota Motor Corporation.