Mike "Wuzzy121". Rest in peace, brother

Go Back   Tacoma World Forums > Tacoma Discussion > 1st Gen. Tacomas

Notices

Need ideas Lack of power/ poor idle /exhaust sound 2.7

Reply
 
Thread Tools Search this Thread
Old 09-18-2013, 06:54 AM   #1
bully280 [OP] bully280 is offline
Junior Member
bully280 is on a distinguished road
 
bully280's Avatar
Name: dave
Joined: Sep 2013, #112152
Location: farr west, utah
Gender: Male
Posts: 17
bully280's Tacoma Gallery
Question Need ideas Lack of power/ poor idle /exhaust sound 2.7

Ok I'll try 2 B quick here ! I have a 99 Taco 158K 2.7 I have 25K on new wires an plugs. A couple months ago it started 2 hesitate during acceleration/shifting. I have done the following cleaned throttle body, TBsenor checked @ Autozone, Inspected & didn't find any vaccume leaks, new fule filter,new air filter, injector cleaner (2 tanks) It Ran alot better but only a couple of weeks and it came back ! Not only that but now it has a rough idle and will die at stops ! So I Found TW.com since then I have cleaned the MAF sensor, connections, new battery terms., since all these attemps it still lacks power in 5th ( Cant do more than 70-75 on hwy) and it still idles bad. Now its making a cherping sound when it starts for only a few seconds then its a sssst.....ssssst .....ssssst sound from the exhaust manifold kinda sounds like a lifter knock ??? I have read a few post about cracking manifolds is this common for 1st Gen taco's ? Any ideas what I can check next ?
  Reply With Quote
Old 09-18-2013, 07:18 PM   #2
Member
Bamo is one of the sharper tools in the shedBamo is one of the sharper tools in the shedBamo is one of the sharper tools in the shedBamo is one of the sharper tools in the shedBamo is one of the sharper tools in the shedBamo is one of the sharper tools in the shedBamo is one of the sharper tools in the shedBamo is one of the sharper tools in the shedBamo is one of the sharper tools in the shedBamo is one of the sharper tools in the shedBamo is one of the sharper tools in the shed
 
Bamo's Avatar
Law Enforcement: CERT Team
Name: Barry
Joined: Jun 2013, #105539
Location: North Port, FL
Gender: Male
Posts: 43
Bamo's Tacoma Gallery
Sorry I re-read your post and noticed you did change the fuel filter. My bad.
  Reply With Quote
Old 09-18-2013, 08:00 PM   #3
Senior Member
toastyjosh is on a distinguished road
Firefighter: helitack
Joined: Mar 2013, #99289
Location: northern New mexico
Gender: Male
Posts: 248
toastyjosh's Tacoma Gallery
Did you change the PCV valve? Are you using more oil or coolent than normal? Clogged cat? O2 sensors? Things to check as well. Also try seafoam treatment that usually helps out a bit.
  Reply With Quote
Old 09-19-2013, 04:39 AM   #4
bully280 [OP] bully280 is offline
Junior Member
bully280 is on a distinguished road
 
bully280's Avatar
Name: dave
Joined: Sep 2013, #112152
Location: farr west, utah
Gender: Male
Posts: 17
bully280's Tacoma Gallery
No worrie's Barry ! Josh, No not the PCV valve good point ! No on both for the oil & coolent just normal ! I Broke down an made an Appt. to have a full Diagnostic tomorrow morning ! These guys are good but a lil spendy ! I just hate pay $50- $100 bucks on someone to just tell me whats wrong with it ! I'll keep you all updated when I find out ! Thanks !
  Reply With Quote
Old 09-26-2013, 07:21 AM   #5
bully280 [OP] bully280 is offline
Junior Member
bully280 is on a distinguished road
 
bully280's Avatar
Name: dave
Joined: Sep 2013, #112152
Location: farr west, utah
Gender: Male
Posts: 17
bully280's Tacoma Gallery
Well I had my tech look at it and he said he didn't have a lot of time to look at it in detail so he asked me 2 bring it back ! He did confirm that my exhaust mainfold was cracked and that something was wrong with the idle. he wanted me to come back for a compression test on friday ! I explained my sittuation with hunts and the timing i was up against ! Even if he did get all the right answers an found a major issue an could have got it fixed i will never know ! Sorry guy's But I got frustraighted and traded it in and bought an 04 Superduty ! It was only a matter of time anyway ! I haul to many toy's a boat, wheelers, & a trailer. Sorry Guys ! I really would like to have kept the truck for running but, I just got tired of working pon it !
  Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
Need ideas Lack of power/ poor idle /exhaust sound 2.7 bully280 4 Cylinder 1 09-26-2013 07:21 AM
Lack of Power? akdenali118 Toyota Trucks & SUVs 31 11-11-2012 02:25 PM
Lack of power but engine is revving jane 2nd Gen. Tacomas 21 10-27-2011 06:53 AM
Help with lack of power to engine toytaco1 Technical Chat 6 04-08-2011 11:04 AM
Power ideas Cold Air K & N,Thorley header, Exhaust? CAhearn06 4 Cylinder 0 10-09-2010 12:40 PM


Copyright © 2014 Tacoma Forum. Tacoma World is not owned by, or affiliated with Toyota Motor Corporation.