Tacoma World Forums

Tacoma World Forums (http://www.tacomaworld.com/forum/)
-   2nd Gen. Builds (http://www.tacomaworld.com/forum/2nd-gen-builds/)
-   -   switch808's 2013 TRD Sport build (http://www.tacomaworld.com/forum/2nd-gen-builds/246816-switch808s-2013-trd-sport-build.html)

switch808 11-01-2012 12:00 PM

switch808's 2013 TRD Sport build
 
http://www.tacomaworld.com/gallery/d...ock_after.jpeg
Mods to date:
17x9 -15mm Classic II
265/70/17R Terra Grapplers
Daystar 2.5" front spacers
Low Range Off Road 1" blocks
TRD skid plate
OEM running boards
Wet Okole seat covers
Magnaflow Offroad Pro Series exhaust
14"antenna
CV boot slide mod
Yakima Q Tower front rack
TracOne TracRac painted black

Hello! I'm a newb here, and this is my build.

Day 1:
10/3/2012
http://www.tacomaworld.com/gallery/d.../IMG_22971.JPG

A few days later:
17x9 -15mm Classic II on 265/70/17R Terra Grapplers.
Rubbed the mud guards so had to take em off.
http://www.tacomaworld.com/gallery/d.../IMG_23241.JPG

A few days later:
Skid plate, TracRac, Yakima Q Tower rack, OEM running boards
http://www.tacomaworld.com/gallery/d.../IMG_23731.JPG

With canoes. Didn't even notice the wedding in the background:
http://www.tacomaworld.com/gallery/d.../IMG_23542.JPG

10/23/2012
Daystar 2.5" front spacers installed:
No longer rubs the mud guards, putting them back on
http://www.tacomaworld.com/gallery/d.../IMG_23805.JPG

Painted TracRac and front emblem:
http://www.tacomaworld.com/gallery/d.../IMG_23846.JPG
http://www.tacomaworld.com/gallery/d.../IMG_23853.JPG

10/29/2012
CV boot slide mod:
http://www.tacomaworld.com/gallery/d.../IMG_24023.JPG

1" Low Range Off Road rear blocks come today.:bananadance:

This will just be a street truck to carry my boats. I don't plan on doing trails anytime soon with this guy.

I only filled up 3 tanks of gas so far, and I've been averaging about 15.5 MPG driving like an old lady. I don't think my tires are large enough to have a significant effect on MPG. Hope it gets better after it breaks in...

Shoots.

kahului96732 11-01-2012 01:24 PM

Nice truck!

dphan2007 11-01-2012 01:33 PM

sweet truck

krob32 11-01-2012 03:44 PM

Great start. Looking good.

switch808 11-01-2012 07:20 PM

Thanks! Just installed the 1" blocks.

Before:
http://www.tacomaworld.com/gallery/d...ks_before.jpeg

After:
http://www.tacomaworld.com/gallery/d...ock_after.jpeg

IluvTEA 11-01-2012 07:38 PM

Looks great man! Congrats on the new truck!

If you're worried about gas mileage, try removing the roof rack when not in use and keep the rpm's under 2K. Also try non-ethanol gas.

Wren 11-05-2012 08:20 PM

http://i1.kym-cdn.com/photos/images/...53/279/e31.jpg


Quote:

Originally Posted by switch808 (Post 5928793)
Hello! I'm a newb here, and this is my build.

Day 1:
10/3/2012

A few days later:
17x9 -15mm Classic II on 265/70/17R Terra Grapplers.
Rubbed the mud guards so had to take em off.

A few days later:
Skid plate, TracRac, Yakima Q Tower rack, OEM running boards

With canoes. Didn't even notice the wedding in the background:

10/23/2012
Daystar 2.5" front spacers installed:
No longer rubs the mud guards, putting them back on

Painted TracRac and front emblem:

10/29/2012
CV boot slide mod:

1" Low Range Off Road rear blocks come today.:bananadance:

This will just be a street truck to carry my boats. I don't plan on doing trails anytime soon with this guy.

I only filled up 3 tanks of gas so far, and I've been averaging about 15.5 MPG driving like an old lady. I don't think my tires are large enough to have a significant effect on MPG. Hope it gets better after it breaks in...

Shoots.


K3tsurui 11-06-2012 10:14 AM

15.5mpg is slightly high. I have a dclb and drive it like I stole it on occasions and still average 18mpg. That rack cannot possibly have that much of an impact? Maybe you should take that off for a tank or two and see if it does any better....It's just odd to me how all of these ppl are reporting low mpg numbers.

switch808 11-07-2012 05:55 AM

Quote:

Originally Posted by K3tsurui (Post 5951923)
15.5mpg is slightly high. I have a dclb and drive it like I stole it on occasions and still average 18mpg. That rack cannot possibly have that much of an impact? Maybe you should take that off for a tank or two and see if it does any better....It's just odd to me how all of these ppl are reporting low mpg numbers.

Ya I don't think the rack will make that much of a difference, but I plan try a tank without it. Maybe it's the ethanol gas. I just got 15.1 mpg on my last tank.

I just ordered a magnaflow exhaust...maybe that will help :wink:

switch808 11-12-2012 06:17 PM

Wet Okole's and Magnaflow Off-Road Pro Series Turndown exhaust installed! Louder than I expected, we'll see how it goes.

http://www.tacomaworld.com/gallery/d.../IMG_24372.jpg

http://www.tacomaworld.com/gallery/d.../IMG_24434.jpg

Fightman80 11-12-2012 09:55 PM

Nice truck man.... I love these trucks! Can't wait to lift mine!

switch808 11-26-2012 05:43 AM

Added a little bass.

Super Crew Sound box
JL 10W0V3 woofer
Alpine MRP-M500 Amp

http://www.tacomaworld.com/gallery/d...m/DSC05971.JPG

http://www.tacomaworld.com/gallery/d.../DSC059721.JPG


switch808 11-26-2012 06:07 AM

Also went to get our Christmas tree...

http://www.tacomaworld.com/gallery/d.../IMG_24753.JPG

and got this

http://www.tacomaworld.com/gallery/d.../IMG_24793.JPG

http://www.tacomaworld.com/gallery/d.../IMG_24803.JPG

Thank you to the Toyota that stopped to help me.

RCOTaco 11-26-2012 06:24 PM

Quote:

Originally Posted by switch808 (Post 6043568)

:eek: Any clue how it happened?

Blacktacoma23 11-26-2012 06:44 PM

Clean rig man!

MGM Humphreys 12-01-2012 06:12 PM

Awesome truck dude!

switch808 12-05-2012 05:56 AM

Quote:

Originally Posted by RCOTaco (Post 6046660)
:eek: Any clue how it happened?

I was driving through some puddles leaving the tree farm. I think I ran over some metal bracket or something that was submerged. I heard it making noise when I got on the asphalt, then heard if fly off when i sped up.

T4C0CH40S 12-05-2012 06:04 AM

Have to say your truck is looking clean man, gotta love MGM on black wheels!

rka 03-15-2013 06:09 PM

Quote:

Originally Posted by switch808 (Post 6043524)
Added a little bass.

Super Crew Sound box
JL 10W0V3 woofer
Alpine MRP-M500 Amp

http://www.tacomaworld.com/gallery/d...m/DSC05971.JPG

http://www.tacomaworld.com/gallery/d.../DSC059721.JPG

Nice setup. I basically have the same setup but an Alpine sub and rat nest of wires in the compartment with a loose amp. How'd you clean up the wires? Drill holes in the plastic?

switch808 04-04-2013 06:44 AM

Quote:

Originally Posted by rka (Post 6595458)
Nice setup. I basically have the same setup but an Alpine sub and rat nest of wires in the compartment with a loose amp. How'd you clean up the wires? Drill holes in the plastic?

I drilled one hole (about 1/2"? I forget) through the plastic near the amp to route the wires behind the plastic. There's actually a bunch of extra wire hiding behind the plastic.

rka, how did you fix your box to the truck? The plastic panel on the passenger side is actually holding my box in place, the box is sandwiched between the plastic and the back wall. Seems to work fine.


All times are GMT -7. The time now is 07:45 PM.