Mike "Wuzzy121". Rest in peace, brother

Go Back   Tacoma World Forums > Tacoma Discussion > 2nd Gen. Tacomas

Notices

CEL on, truck dies after starting???

Reply
 
Thread Tools Search this Thread
Old 10-04-2010, 02:06 AM   #1
scottj [OP] scottj is offline
Member
scottj is on a distinguished road
Joined: Jul 2010, #40550
Location: York, PA
Gender: Male
Posts: 56
scottj's Tacoma Gallery
CEL on, truck dies after starting???

Well today I went out and started my 07' Tacoma and it dies. Try again and it runs but idles rough and is lacking power. Scanned at AutoZone shows codes for (4) different O2 sensors and (1) for the MAF. Just turned over 60K miles. Any ideas?
  Reply With Quote
Old 10-04-2010, 06:52 AM   #2
Senior Member
BlueT is one of the sharper tools in the shedBlueT is one of the sharper tools in the shedBlueT is one of the sharper tools in the shedBlueT is one of the sharper tools in the shedBlueT is one of the sharper tools in the shedBlueT is one of the sharper tools in the shedBlueT is one of the sharper tools in the shedBlueT is one of the sharper tools in the shedBlueT is one of the sharper tools in the shedBlueT is one of the sharper tools in the shedBlueT is one of the sharper tools in the shed
 
BlueT's Avatar
Joined: Mar 2009, #15341
Location: NorthEast
Gender: Male
Posts: 3,275
BlueT's Tacoma Gallery
Quote:
Originally Posted by scottj View Post
Well today I went out and started my 07' Tacoma and it dies. Try again and it runs but idles rough and is lacking power. Scanned at AutoZone shows codes for (4) different O2 sensors and (1) for the MAF. Just turned over 60K miles. Any ideas?
Post the exact codes ...
  Reply With Quote
Old 10-04-2010, 06:55 AM   #3
Senior Member
tacos is on a distinguished road
 
tacos's Avatar
Name: Andrew
Joined: Mar 2010, #32620
Location: NKY
Gender: Male
Posts: 156
tacos's Tacoma Gallery
I would first start with replacing the MAF meter, it is located on the intake tube. Do that then clear the codes and see if the O2 sensor codes return. The mass air flow code may be throwing the 02 codes because a faulty maf will lean out the truck. A faulty MAF will cause your truck to accelerate like crap and have no power because the a/f ratio is incorrect.
  Reply With Quote
Old 10-04-2010, 06:57 AM   #4
Vivid Illumination
memario1214 is one of the sharper tools in the shedmemario1214 is one of the sharper tools in the shedmemario1214 is one of the sharper tools in the shedmemario1214 is one of the sharper tools in the shedmemario1214 is one of the sharper tools in the shedmemario1214 is one of the sharper tools in the shedmemario1214 is one of the sharper tools in the shedmemario1214 is one of the sharper tools in the shedmemario1214 is one of the sharper tools in the shedmemario1214 is one of the sharper tools in the shedmemario1214 is one of the sharper tools in the shed
 
memario1214's Avatar
Name: Colton
Joined: Oct 2009, #23628
Location: MT recently relocated to Willmar, MN
Age: 24
Gender: Male
Posts: 12,618
memario1214's Tacoma Gallery
Yeah that ^^^ is correct. My cats didn't go out until just recently here at about 85k
  Reply With Quote
Old 10-04-2010, 07:14 AM   #5
Member
tiger955 will become famous soon enough
Joined: Aug 2009, #21948
Location: Carson City
Gender: Male
Posts: 57
tiger955's Tacoma Gallery
Before you replace anything... unplug and plug back in your MAF sensor and check all of the pipes between it and your throttle body. Also check to make sure all vacuum lines are connected. Any air leaks between the MAF and the engine will cause the MAF to read the wrong airflow and a lean mixture, if too lean the O2's will not read properly setting those codes also. The codes will need to be cleared once the repair is made or the light will still stay on.
  Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
Troubles starting engine, CEL. Please help!!! pyroskier Technical Chat 10 04-30-2011 10:53 PM
my truck dies. mossman 1st Gen. Tacomas 0 08-09-2010 06:28 PM
Truck dies after starting. Suggestions? 06RedComa General Automotive 14 12-04-2009 12:00 PM
Hard Starting and a CEL Yaberries 2nd Gen. Tacomas 17 10-06-2008 05:44 PM
truck just dies SchrammMan74 1st Gen. Tacomas 31 10-31-2007 05:44 AM


Copyright © 2014 Tacoma Forum. Tacoma World is not owned by, or affiliated with Toyota Motor Corporation.