Mike "Wuzzy121". Rest in peace, brother

Go Back   Tacoma World Forums > Tacoma Discussion > 2nd Gen. Tacomas

Notices

Oil leak and whistling sound

Reply
 
Thread Tools Search this Thread
Old 09-26-2011, 10:30 AM   #1
JdubTaco06 [OP] JdubTaco06 is offline
Junior Member
JdubTaco06 is on a distinguished road
Name: John
Joined: Sep 2011, #64138
Location: Vista,CA
Gender: Male
Posts: 7
JdubTaco06's Tacoma Gallery
Oil leak and whistling sound

Hey Guys,
I have a 2006 Tacoma 4 cyl 2.7 with 45,000 miles and I noticed the other day when I started it up before work and let it idle a bit I smelled burning oil and I could hear a whistling sound. So I looked under the car and noticed it was wet with oil right below where the altenator is on the engine but can't tell where it is coming from. The whistling sound is coming from that same area. Any ideas what this could be?
  Reply With Quote
Old 09-26-2011, 10:59 AM   #2
Senior Member
saugus is on a distinguished road
Joined: Sep 2011, #62820
Gender: Male
Posts: 340
saugus's Tacoma Gallery
Quote:
Originally Posted by JdubTaco06 View Post
Hey Guys,
I have a 2006 Tacoma 4 cyl 2.7 with 45,000 miles and I noticed the other day when I started it up before work and let it idle a bit I smelled burning oil and I could hear a whistling sound. So I looked under the car and noticed it was wet with oil right below where the altenator is on the engine but can't tell where it is coming from. The whistling sound is coming from that same area. Any ideas what this could be?
Check the valve cover gasket. Wipe a towel around the edge to see if you can locate it. Also check if the vacuum hoses are connected right and that your air filter isn't clogged.
  Reply With Quote
Old 09-26-2011, 11:15 AM   #3
JdubTaco06 [OP] JdubTaco06 is offline
Junior Member
JdubTaco06 is on a distinguished road
Name: John
Joined: Sep 2011, #64138
Location: Vista,CA
Gender: Male
Posts: 7
JdubTaco06's Tacoma Gallery
Valve cover looks clean and I cleaned my K&N filter a couple months ago. I also noticed its wet with oil around where the belt tensoner is under the alt.
  Reply With Quote
Old 09-26-2011, 05:55 PM   #4
JdubTaco06 [OP] JdubTaco06 is offline
Junior Member
JdubTaco06 is on a distinguished road
Name: John
Joined: Sep 2011, #64138
Location: Vista,CA
Gender: Male
Posts: 7
JdubTaco06's Tacoma Gallery
I just checked the valve cover again and it seems to be leaking just a bit in the back so I guess its not to bad. But what is causing the whistle sound?
  Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
2012 Whistling sound indentified Appljaxx 2nd Gen. Tacomas 273 12-26-2014 08:08 AM
whistling sound paully79 1st Gen. Tacomas 5 06-22-2011 04:51 AM
Whistling sound when driving in wind. OB.BAJA 2nd Gen. Tacomas 6 07-13-2010 07:24 PM
Whistling sound at start up brandon121 4 Cylinder 2 04-17-2010 08:16 PM
whistling sound while driving on the highway 4421.frank 1st Gen. Tacomas 2 09-30-2008 07:59 AM


Copyright © 2014 Tacoma Forum. Tacoma World is not owned by, or affiliated with Toyota Motor Corporation.