LSC15's 95 Tacoma 4x4

Go Back   Tacoma World Forums > Tacoma Discussion > 2nd Gen. Tacomas

Notices

K&N 77 Series 2011 TRD Sport (Smell)

Reply
 
Thread Tools Search this Thread Display Modes
Old 09-14-2012, 05:48 PM   #1
Junior Member
WingsTacoma is on a distinguished road
Name: Jeff
Joined: May 2011, #56794
Location: Iowa
Gender: Male
Posts: 12
WingsTacoma's Tacoma Gallery
Question K&N 77 Series 2011 TRD Sport (Smell)

Hey guys. I'm not really new to the forum but this is my first post. Frequent reader!

I have scoured the search portion of this forum looking for a post similar to this and could not find anything. If this has already been discussed I do apologize.

Last week I installed the K&N 77 series air intake on my truck. This is my first Tacoma and this is also my first K&N system :0. I have gone through the installation several times to make sure I have everything tight and nothing seems to be out of place.

I am now noticing a slight odor in the cab of my truck that I've never smelled before. The best way I can describe this odor is a slight chemical smell.... Is this normal for new K&N intake systems? Has anyone else noticed anything like this? Does the filter have a "break in" period?

It doesn't smell like anything I've ever encountered under the hood before. It's not antifreeze or burnt rubber or gas or oil or mold...its just a slight chemical odor and I can't put my finger on it.

Any help or ideas would be greatly appreciated!

I have also just ordered the Flowmaster American Thunder exhaust system for my truck. It should be here next week! I am afraid if I keep reading this forum I am going to be spending LOTS more money on my tacoma.
  Reply With Quote
Old 09-14-2012, 06:06 PM   #2
Member
BaLLZaCH is on a distinguished road
Joined: Sep 2012, #86515
Gender: Male
Posts: 40
BaLLZaCH's Tacoma Gallery
Quote:
Originally Posted by WingsTacoma View Post
Hey guys. I'm not really new to the forum but this is my first post. Frequent reader!

I have scoured the search portion of this forum looking for a post similar to this and could not find anything. If this has already been discussed I do apologize.

Last week I installed the K&N 77 series air intake on my truck. This is my first Tacoma and this is also my first K&N system :0. I have gone through the installation several times to make sure I have everything tight and nothing seems to be out of place.

I am now noticing a slight odor in the cab of my truck that I've never smelled before. The best way I can describe this odor is a slight chemical smell.... Is this normal for new K&N intake systems? Has anyone else noticed anything like this? Does the filter have a "break in" period?

It doesn't smell like anything I've ever encountered under the hood before. It's not antifreeze or burnt rubber or gas or oil or mold...its just a slight chemical odor and I can't put my finger on it.

Any help or ideas would be greatly appreciated!

I have also just ordered the Flowmaster American Thunder exhaust system for my truck. It should be here next week! I am afraid if I keep reading this forum I am going to be spending LOTS more money on my tacoma.


Are you smelling (for whatever reason) the filter oil ? I used to have a can of spray-on k&n air filter oil and it did have a chemicall'y smell, kinda like medical tape or something lol ,,,,

And "77 series" whatttttt, did it take k&n 77 tries to make something that would fit haha sorry...


As far as the Flowmaster you ordered, "I" like them. 3-Chamber delta-flow but still sounds good. (But I also like the poppy-ting sound of Flowmasters, and not the "fart-pipe" sound of whoof pipes)

But as far as installation, I hope you have a lot of patience and are a good mechanical type person; Yes it's "bolt on" but it takes time and effort to get it "on" and to get it STRAIGHT ! Then, those POS clamps will snap if cranked down to semi-tight, so I hope you can weld. It was easier to weld the joints than to put the system on (But I was laying in the driveway) - I used the clamps to 'hold it straight' then welded around.

At first I was pissed cause' I didn't have my old 2 chamber sound, then I realized that it does have a good sound, just not inside the truck at certain speeds - It's that delta flow crap, still sounds good outside (Yup they did that on purpose ... lol) - the American Thunder has a deeper tone but is not as loud or tingy or rumbly.


With your intake, consider getting a dry-flow filter replacement, or synthetic no-oil type. You would eliminate the medical smell of the oil, and personally I just dont trust the oiled on a new vehicle because you can see straight through it (Not trying to start another debate, just' saying ...) - Otherwise I wouldnt worry about it AS LONG AS you are SURE there are no vacuum leaks and the mass air flow sensor is sealed around the hole (It should have a gasket of some kind that was NOT on the stock tube)...

Good luck , you will love your taco !
  Reply With Quote
Old 09-14-2012, 06:10 PM   #3
Junior Member
Ardo K is on a distinguished road
 
Ardo K's Avatar
Name: Ardo
Joined: Sep 2012, #86951
Location: Los Angeles
Gender: Male
Posts: 5
Ardo K's Tacoma Gallery
Hi everyone, i got a question regarding for the differential fluid. Ive been reading up on this site, i have a 2011 Tacoma Trd Sport 4x4 PreRunner 4.0L i called the dealer to find out what kind of differential fluid it takes i have 36K miles it has limited slip (shows Auto LSD) on the dash. Does anyone know what kind of of OEM differential fluid it take ive been getting GL5/75W-85. Also is Redline Differential fluid any good?

If anyone can help i'd really appreciate it ,
Thanks
  Reply With Quote
Old 09-14-2012, 07:21 PM   #4
Junior Member
WingsTacoma is on a distinguished road
Name: Jeff
Joined: May 2011, #56794
Location: Iowa
Gender: Male
Posts: 12
WingsTacoma's Tacoma Gallery
I sprayed the oil and cleaner from the recharger kit that I bought with my intake and it doesn’t have a smell that I can detect.
I just went outside and pulled the filter off my truck and it smells a little bit like gasoline….not the chemical smell I’m picking up in the truck. So I guess that rules out the K&N filter as the culprit…
Thank you for the tip on the on the mass flow sensor gasket. I did think it was odd that the kit did not come with any kind of gasket for that fitting. I put the mass flow sensor in the tube and found that the fit was really tight so I didn’t give it a second thought.
I appreciate the warning on the flowmaster installation as well. I will also attempting this installation in my driveway. I am going to attempt to install the exhaust kit as “bolt on” at first. If I am not happy with it I will have to find someone with a welder 
Thanks for the quick reply!!
  Reply With Quote
Reply

Products Discussed in this Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
K&N series 63 vs. 77 air intakes wildforager Technical Chat 2 12-12-2011 04:57 PM
Just Installed K & N 77 series CAI Delrivpilot 2nd Gen. Tacomas 9 01-24-2011 06:08 PM
K&N 77 series 509TACO 2nd Gen. Tacomas 1 01-20-2011 08:49 AM
K&N Aircharger or 77 series 08_TACO_offroad Performance and Tuning 11 10-15-2008 09:10 PM
05+ 4.0L 77 series K&N jhodge83 Buy / Sell / Trade 8 10-06-2008 07:31 PM


Copyright © 2014 Tacoma Forum. Tacoma World is not owned by, or affiliated with Toyota Motor Corporation.