Mike "Wuzzy121". Rest in peace, brother

Go Back   Tacoma World Forums > Tacoma Discussion > 2nd Gen. Tacomas

Notices

I Need Electrical Help!

Reply
 
Thread Tools Search this Thread
Old 02-18-2013, 06:38 AM   #1
Nutts
stormtrooper37 is on a distinguished road
 
stormtrooper37's Avatar
Name: Tyler
Joined: Feb 2011, #51836
Location: Baltimore MD
Gender: Male
Posts: 387
stormtrooper37's Tacoma Gallery
I Need Electrical Help!

I was driving home yesterday and realized that my speedometer was not working.
I have now came to realize that I have a laundry list of problems.

- windows don't work
- fog lights wont work
- The truck barley starts
- radio turns off
- back up camera wont come on
- I have no air
- and the check engine light is on

Has anyone had this happen or know what it could be?

Thanks.
  Reply With Quote
Old 02-18-2013, 06:40 AM   #2
Well, let's play chess.
DoorDing is one of the sharper tools in the shedDoorDing is one of the sharper tools in the shedDoorDing is one of the sharper tools in the shedDoorDing is one of the sharper tools in the shedDoorDing is one of the sharper tools in the shedDoorDing is one of the sharper tools in the shedDoorDing is one of the sharper tools in the shedDoorDing is one of the sharper tools in the shedDoorDing is one of the sharper tools in the shedDoorDing is one of the sharper tools in the shedDoorDing is one of the sharper tools in the shed
 
DoorDing's Avatar
Joined: Sep 2012, #86445
Posts: 15,320
DoorDing's Tacoma Gallery
Quote:
Originally Posted by stormtrooper37 View Post
I was driving home yesterday and realized that my speedometer was not working.
I have now came to realize that I have a laundry list of problems.

- windows don't work
- fog lights wont work
- The truck barley starts
- radio turns off
- back up camera wont come on
- I have no air
- and the check engine light is on

Has anyone had this happen or know what it could be?

Thanks.
Have the battery and charging system checked. Have you done any electrical work lately? Maybe a battery terminal is loose.
  Reply With Quote
Old 02-18-2013, 06:57 AM   #3
Nutts
stormtrooper37 is on a distinguished road
 
stormtrooper37's Avatar
Name: Tyler
Joined: Feb 2011, #51836
Location: Baltimore MD
Gender: Male
Posts: 387
stormtrooper37's Tacoma Gallery
I put lights in a while ago and I unhooked them ill have to vcheck the terminal when I get home today thanks
  Reply With Quote
Old 02-18-2013, 08:27 AM   #4
Senior Member
TRD 09 is one of the sharper tools in the shedTRD 09 is one of the sharper tools in the shedTRD 09 is one of the sharper tools in the shedTRD 09 is one of the sharper tools in the shedTRD 09 is one of the sharper tools in the shedTRD 09 is one of the sharper tools in the shedTRD 09 is one of the sharper tools in the shedTRD 09 is one of the sharper tools in the shedTRD 09 is one of the sharper tools in the shedTRD 09 is one of the sharper tools in the shedTRD 09 is one of the sharper tools in the shed
 
TRD 09's Avatar
Joined: Aug 2012, #85544
Location: Alberta
Gender: Male
Posts: 484
TRD 09's Tacoma Gallery
Your alternator is most likely dead, if these things happened while driving that means you were not charging the battery through the altenator
  Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
Need some help on electrical - soon! Caduceus 2nd Gen. Tacomas 3 10-15-2012 07:36 AM
Electrical help please frickdogg 1st Gen. Tacomas 4 07-12-2011 02:52 PM
Electrical Help! TacoKurt 2nd Gen. Tacomas 6 05-04-2011 11:42 PM
Electrical Help !! Ktaco 1st Gen. Tacomas 6 04-16-2009 06:11 PM
electrical lexusoftrucks 2nd Gen. Tacomas 10 01-10-2007 12:45 PM


Copyright © 2014 Tacoma Forum. Tacoma World is not owned by, or affiliated with Toyota Motor Corporation.