Mike "Wuzzy121". Rest in peace, brother

Go Back   Tacoma World Forums > Tacoma Discussion > 2nd Gen. Tacomas

Notices

Leaky & Squeaky Units

Reply
 
Thread Tools Search this Thread
Old 04-03-2013, 01:25 PM   #1
Junior Member
MachinesOfGreen is on a distinguished road
Joined: Apr 2010, #34988
Gender: Male
Posts: 14
MachinesOfGreen's Tacoma Gallery
Leaky & Squeaky Units

Got myself a 2006 access cab V6, 4wd Taco with approximately 125K on her.

Recently noticed she has been going through a lot of power steering fluid and leaking what appears to be water or clear fluid in small volume from passenger side area.

Separately I am getting a high pitched squeaking noise from driver side of engine compartment during idle and driving.

Replaced an idler pulley and serpentine built approximately 2,500 miles ago.

I do mostly city driving and probably put more use on the power steering than normal with lots of multi point turns in narrow streets and what not. But it has never required this much fluid.

Crawled under her this morning and took some pictures of what appeared to be the problem area. Photos are taken from underneath passenger side of vehicle.

Any insight in to the cause of these symptoms would be awesome, Thanks!
Attached Thumbnails
Leaky & Squeaky Units-img_4514.jpg   Leaky & Squeaky Units-img_4515.jpg   Leaky & Squeaky Units-img_4516.jpg   Leaky & Squeaky Units-img_4517.jpg  
  Reply With Quote
Old 04-04-2013, 02:23 PM   #2
Senior Member
toyotaman29 is a splendid one to beholdtoyotaman29 is a splendid one to beholdtoyotaman29 is a splendid one to beholdtoyotaman29 is a splendid one to beholdtoyotaman29 is a splendid one to beholdtoyotaman29 is a splendid one to behold
 
toyotaman29's Avatar
Name: Darrell
Joined: Aug 2012, #85919
Location: North Carolina
Gender: Male
Posts: 432
toyotaman29's Tacoma Gallery
I would clean the engine bay good, spray some purple cleaner or de-greaser and hose it down, then see if it's a hose or the pump. The noise could be another idler pulley or the belt slipping from some fluid leaking on it, i would try that first...
  Reply With Quote
Old 04-04-2013, 11:59 PM   #3
Senior Member
Jimmyh is one of the sharper tools in the shedJimmyh is one of the sharper tools in the shedJimmyh is one of the sharper tools in the shedJimmyh is one of the sharper tools in the shedJimmyh is one of the sharper tools in the shedJimmyh is one of the sharper tools in the shedJimmyh is one of the sharper tools in the shedJimmyh is one of the sharper tools in the shedJimmyh is one of the sharper tools in the shedJimmyh is one of the sharper tools in the shedJimmyh is one of the sharper tools in the shed
 
Jimmyh's Avatar
Navy: MT1 (SS) retired
Joined: May 2012, #78991
Location: SC
Gender: Male
Posts: 2,580
Jimmyh's Tacoma Gallery
That second picture looks like the power steering pump has a leak. Of course what toyotaman29 said is a good start to verify this.

Clean it really well then drive it around slowly so it doesn't blow the fluid everywhere and then get another look see.
  Reply With Quote
Old 04-09-2013, 09:45 AM   #4
Junior Member
MachinesOfGreen is on a distinguished road
Joined: Apr 2010, #34988
Gender: Male
Posts: 14
MachinesOfGreen's Tacoma Gallery
thanks guys. Going to get on this in the next few days. trying to keep her off the road until then. Suspecting power steering pump is the issue.
  Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
Leaky 5100 lynyrd3 Suspension 6 07-05-2014 07:40 AM
Leaky engine pinchetaco 2nd Gen. Tacomas 28 03-11-2013 07:55 PM
Leaky lifter?? Steve E 2nd Gen. Tacomas 2 01-17-2013 02:46 PM
Leaky 5100?! Chris(NJ) Suspension 5 12-02-2012 02:35 PM
Double Din (DVD & Nav) Units & Theft IrishPilot Audio & Video 7 03-11-2010 03:26 PM


Copyright © 2014 Tacoma Forum. Tacoma World is not owned by, or affiliated with Toyota Motor Corporation.