Mike "Wuzzy121". Rest in peace, brother

Go Back   Tacoma World Forums > Tacoma Discussion > 2nd Gen. Tacomas

Notices

2014 radio into 2012 USB issue

Reply
 
Referenced Products Thread Tools Search this Thread
Old 03-04-2014, 09:12 AM   #1
Junior Member
MGMFire 711 is on a distinguished road
Firefighter:
Name: Gio
Joined: Jan 2014, #121275
Location: South florida
Gender: Male
Posts: 22
MGMFire 711's Tacoma Gallery
2014 radio into 2012 USB issue

So I just installed a 2014 entune radio with navigation and xm in my 2012. It seems like everything plugged up and no wires missing. Everything works perfect except for the USB connection. Is there any difference between the 2 plugs between both units? I don't see why it wouldn't work. The aux connector seems to work though.
  Reply With Quote
Old 03-04-2014, 10:22 AM   #2
Senior Member
MudFlap is a splendid one to beholdMudFlap is a splendid one to beholdMudFlap is a splendid one to beholdMudFlap is a splendid one to beholdMudFlap is a splendid one to beholdMudFlap is a splendid one to beholdMudFlap is a splendid one to behold
 
MudFlap's Avatar
Name: Tim
Joined: Jul 2011, #59794
Location: Memphis (north mississippi)
Age: 38
Gender: Dude
Posts: 363
MudFlap's Tacoma Gallery
Subed..... I plan to do this swap myself and need all the info I can get.
  Reply With Quote
Old 03-04-2014, 10:36 AM   #3
Junior Member
Tigmandick is on a distinguished road
Name: Richard
Joined: Aug 2012, #84768
Location: G I
Gender: Male
Posts: 17
Tigmandick's Tacoma Gallery
You'll need this USB cable from eBay to make the USB connection work properly. Then follow these instructions to get it hooked up. I didn't bother with the input jack modification on those instructions, between the USB port and Bluetooth I don't think I'll ever need it. Also, that USB cable comes from China so it will take a while to get here. Mine took about two and half weeks.

Credit goes to member yellowrubiu

And on a side not does your xm still work?
  Reply With Quote
Old 03-04-2014, 10:50 AM   #4
Junior Member
MGMFire 711 is on a distinguished road
Firefighter:
Name: Gio
Joined: Jan 2014, #121275
Location: South florida
Gender: Male
Posts: 22
MGMFire 711's Tacoma Gallery
Yea I did get the xm to work. My 2012 already had xm and just needed the xm module and adapter cable which I received from FLtrucks and plugged right up. The link didn't work for me but I found the original post thanks. Did your 2012 already have the USB connector? I was wondering since everything plugged right in why it wouldn't work. The plugs seem to be the same. Can't there be a way to make it work without having to modify the cable?
  Reply With Quote
Old 03-04-2014, 10:56 AM   #5
Junior Member
Tigmandick is on a distinguished road
Name: Richard
Joined: Aug 2012, #84768
Location: G I
Gender: Male
Posts: 17
Tigmandick's Tacoma Gallery
I haven't receved my radio from fl yet did you ask for the xm adapter if so what was the part number .
But my truck also came with xm and USB.
  Reply With Quote
Old 03-04-2014, 11:07 AM   #6
Junior Member
MGMFire 711 is on a distinguished road
Firefighter:
Name: Gio
Joined: Jan 2014, #121275
Location: South florida
Gender: Male
Posts: 22
MGMFire 711's Tacoma Gallery
Can't recall a part number on it. It was a loose cable that came in the box. I just asked for the xm and he included all the cables along with it. I do remember it was a long cable with one side similar to the gps connector, which went to the xm unit and the other side was a blue connector which I assume plugged into the shark fin connector which was also blue I believe.
  Reply With Quote
Old 03-04-2014, 01:14 PM   #7
Junior Member
MGMFire 711 is on a distinguished road
Firefighter:
Name: Gio
Joined: Jan 2014, #121275
Location: South florida
Gender: Male
Posts: 22
MGMFire 711's Tacoma Gallery
Quote:
Originally Posted by Tigmandick View Post
You'll need this USB cable from eBay to make the USB connection work properly. Then follow these instructions to get it hooked up. I didn't bother with the input jack modification on those instructions, between the USB port and Bluetooth I don't think I'll ever need it. Also, that USB cable comes from China so it will take a while to get here. Mine took about two and half weeks.

Credit goes to member yellowrubiu

And on a side not does your xm still work?
Tigmandick, do you remember where you plugged that into in the back of the radio to make the USB work?
  Reply With Quote
Old 03-04-2014, 03:21 PM   #8
Junior Member
Tigmandick is on a distinguished road
Name: Richard
Joined: Aug 2012, #84768
Location: G I
Gender: Male
Posts: 17
Tigmandick's Tacoma Gallery
I have no t received mine but that's the solution I have found sorry I am not more helpful.
  Reply With Quote
Old 03-04-2014, 04:02 PM   #9
Junior Member
MGMFire 711 is on a distinguished road
Firefighter:
Name: Gio
Joined: Jan 2014, #121275
Location: South florida
Gender: Male
Posts: 22
MGMFire 711's Tacoma Gallery
Been trying to search for differences in the connections between 2012's and 2013+ but no luck. If anyone can find it somewhere it would be helpful. I'm kinda picky about keeping the stock look and don't wanna lose the function of the stock usb connection
  Reply With Quote
Old 03-05-2014, 01:10 PM   #10
Junior Member
Tigmandick is on a distinguished road
Name: Richard
Joined: Aug 2012, #84768
Location: G I
Gender: Male
Posts: 17
Tigmandick's Tacoma Gallery
Ok so i did some digging and found this picture.

http://s1050.photobucket.com/user/sf...b1c6a.png.html

So you would use this cable http://www.ebay.com/itm/Axxess-AX-TO...item2ecd3dc0c0
and plug it into number 2 on the picture.

  Reply With Quote
Old 03-05-2014, 07:48 PM   #11
Junior Member
MGMFire 711 is on a distinguished road
Firefighter:
Name: Gio
Joined: Jan 2014, #121275
Location: South florida
Gender: Male
Posts: 22
MGMFire 711's Tacoma Gallery
Thanks. That makes sense. But you think maybe there's a way to maybe find the cable similar to the 2013+ ones and just plug it into the back? Or you think it's more complicated than that?
  Reply With Quote
Old 03-05-2014, 07:57 PM   #12
Junior Member
Tigmandick is on a distinguished road
Name: Richard
Joined: Aug 2012, #84768
Location: G I
Gender: Male
Posts: 17
Tigmandick's Tacoma Gallery
I am gonna do some continuity tests see if it just needs repined to somewhere in the harness but unfortunately I won't be able to do that till about the 20th as I will be out of the country till then can't wait to get my hands on it.
  Reply With Quote
Old 03-05-2014, 08:57 PM   #13
Senior Member
steveo27 is one of the sharper tools in the shedsteveo27 is one of the sharper tools in the shedsteveo27 is one of the sharper tools in the shedsteveo27 is one of the sharper tools in the shedsteveo27 is one of the sharper tools in the shedsteveo27 is one of the sharper tools in the shedsteveo27 is one of the sharper tools in the shedsteveo27 is one of the sharper tools in the shedsteveo27 is one of the sharper tools in the shedsteveo27 is one of the sharper tools in the shedsteveo27 is one of the sharper tools in the shed
 
steveo27's Avatar
Name: Steveo
Joined: Aug 2013, #110326
Location: Pittsburgh
Age: 28
Gender: Male
Posts: 631
steveo27's Tacoma Gallery
Quote:
Originally Posted by Tigmandick View Post
Ok so i did some digging and found this picture.

http://s1050.photobucket.com/user/sf...b1c6a.png.html

So you would use this cable http://www.ebay.com/itm/Axxess-AX-TO...item2ecd3dc0c0
and plug it into number 2 on the picture.
Thats my stuff. My radio is installed, but I am still waiting on the USB adapter to show up.
  Reply With Quote
Old 03-06-2014, 08:21 PM   #14
Junior Member
MGMFire 711 is on a distinguished road
Firefighter:
Name: Gio
Joined: Jan 2014, #121275
Location: South florida
Gender: Male
Posts: 22
MGMFire 711's Tacoma Gallery
Quote:
Originally Posted by Tigmandick View Post
I am gonna do some continuity tests see if it just needs repined to somewhere in the harness but unfortunately I won't be able to do that till about the 20th as I will be out of the country till then can't wait to get my hands on it.
Whenever you figure it out post it up please.
  Reply With Quote
Old 10-17-2014, 05:22 PM   #15
Senior Member
JPA2002 is a splendid one to beholdJPA2002 is a splendid one to beholdJPA2002 is a splendid one to beholdJPA2002 is a splendid one to beholdJPA2002 is a splendid one to beholdJPA2002 is a splendid one to beholdJPA2002 is a splendid one to behold
Joined: May 2014, #129995
Location: Roanoke
Gender: Male
Posts: 200
JPA2002's Tacoma Gallery
Any updates?
  Reply With Quote
Old 10-17-2014, 05:37 PM   #16
Junior Member
JHSwafford is on a distinguished road
 
JHSwafford's Avatar
Name: Justin
Joined: Apr 2014, #127901
Location: Charlotte, NC
Gender: Male
Posts: 6
JHSwafford's Tacoma Gallery
I had this same issue when I installed my 2014 nav unit into my 2012. I would say I am atleast moderately educated on electronics and circuitry as well as audio but could not figure out how to make the 2 adapters work that FLTrucks said we would need to keep the USB function. The reason is that the factory wiring for the USB port is in an unlikely location.

After reading multiple threads, I finally tracked down a member that had successfully used the 2 adapters that FLTrucks said were needed. I PM'ed him and we exchanged a few messages and he was nice enought to snap this picture for me.



Credit for this picture goes to warriors_03

This is located BEHIND the glove box. If you notice on the right hand side of the picture that black canister is actually the "shock" for the glove box that keeps it from falling open.

The adapter with the female brown end hooks into the brown male end that is plugged into the multimedia unit behind the glove box.

The blue adapter (if i remember the color correctly) plugs into the back of the head unit.

You will need about a 2-3 foot MALE to FEMALE USB cable to extend the 2 adapters and connect them together. I ordered 1 off Amazon for around $5. May be able to find 1 at Best Buy but I do know these are a lot less common than your average male to male USB cable.
  Reply With Quote
Old 10-17-2014, 07:16 PM   #17
Senior Member
JPA2002 is a splendid one to beholdJPA2002 is a splendid one to beholdJPA2002 is a splendid one to beholdJPA2002 is a splendid one to beholdJPA2002 is a splendid one to beholdJPA2002 is a splendid one to beholdJPA2002 is a splendid one to behold
Joined: May 2014, #129995
Location: Roanoke
Gender: Male
Posts: 200
JPA2002's Tacoma Gallery
Bingo! I just found that thread and figured it out myself. Thanks for the reply!!!!!!
  Reply With Quote
Old 10-17-2014, 07:44 PM   #18
Member
ssilence is on a distinguished road
Joined: Aug 2014, #135979
Location: Middle Georgia
Gender: Male
Posts: 87
ssilence's Tacoma Gallery
Thanks for this info. Just so I follow. You unplugged the male brown connector from multimedia unit. Plugged this into the brown female adapter that goes to a standard USB plug. Run a male to female USB extension behind the radio and the plug into another adapter before going into the radio???

Do we have part numbers for the 2 adapters?
  Reply With Quote
Old 10-17-2014, 08:12 PM   #19
Junior Member
JHSwafford is on a distinguished road
 
JHSwafford's Avatar
Name: Justin
Joined: Apr 2014, #127901
Location: Charlotte, NC
Gender: Male
Posts: 6
JHSwafford's Tacoma Gallery
Quote:
Originally Posted by ssilence View Post
Thanks for this info. Just so I follow. You unplugged the male brown connector from multimedia unit. Plugged this into the brown female adapter that goes to a standard USB plug. Run a male to female USB extension behind the radio and the plug into another adapter before going into the radio???

Do we have part numbers for the 2 adapters?
That is correct. I can't remember part #'s for the adapters. I've had mine installed for about 6 months now with no issues and full functionality of all features as if it were equipped with the unit when purchased new. I know those adapters are called out specifically in fltrucks 2014 navigation unit thread.
  Reply With Quote
Old 10-18-2014, 03:34 AM   #20
Senior Member
JPA2002 is a splendid one to beholdJPA2002 is a splendid one to beholdJPA2002 is a splendid one to beholdJPA2002 is a splendid one to beholdJPA2002 is a splendid one to beholdJPA2002 is a splendid one to beholdJPA2002 is a splendid one to behold
Joined: May 2014, #129995
Location: Roanoke
Gender: Male
Posts: 200
JPA2002's Tacoma Gallery
Connector that plugs into back of radio:
http://m.ebay.com/itm?itemId=161444026232

Connector that plugs into connection behind glovebox:
http://m.ebay.com/itm?itemId=181308235500

Then you need a male to female usb extension:
http://www.amazon.com/gp/aw/d/B001TH...332200_TE_item

Jon
  Reply With Quote
Reply

Products Discussed in this Thread

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
2014 oem Navigation radio into a 2012 chrispy Audio & Video 26 10-17-2014 07:15 PM
2014 USB iOS7 fail C1ph3r Audio & Video 3 10-01-2013 06:36 AM
2014 USB iOS7 fail C1ph3r Audio & Video 0 09-30-2013 09:13 PM
Usb to stock radio? Ludo Audio & Video 2 06-05-2013 05:48 AM
Has anyone added a second USB connector to the stock radio? lowstature Audio & Video 5 03-08-2012 03:55 AM


Copyright © 2014 Tacoma Forum. Tacoma World is not owned by, or affiliated with Toyota Motor Corporation.