Mike "Wuzzy121". Rest in peace, brother

Go Back   Tacoma World Forums > Tacoma Discussion > 2nd Gen. Tacomas

Notices

Check engine light on after cold air setup...

Reply
 
Thread Tools Search this Thread
Old 10-08-2007, 02:59 PM   #1
07kKlR_TRD [OP] 07kKlR_TRD is offline
Junior Member
07kKlR_TRD is on a distinguished road
Joined: Oct 2007, #2971
Posts: 2
07kKlR_TRD's Tacoma Gallery
Check engine light on after cold air setup...

Hey, So I installed an afe cold air intake on my 07 tacoma, trd sport v6 and a after i had got it all instaled the check engline light came on.. I figured it was because of the change in air flow or what not so I disconected the battery and reset the comp.. the light went away for a few hours and then came back on. Since then I put back the stock intake because i didnt want anything to get messed up.. has anyone else had this issue, is their a quick fix or do i need to get a programer if so does anyone have any recomendations or good web sites for performance parts. Thanks for the help!
  Reply With Quote
Old 10-08-2007, 03:46 PM   #2
Carolina Alliance: Lead, follow, or get the hell outta my way
tacomaman06 is one of the sharper tools in the shedtacomaman06 is one of the sharper tools in the shedtacomaman06 is one of the sharper tools in the shedtacomaman06 is one of the sharper tools in the shedtacomaman06 is one of the sharper tools in the shedtacomaman06 is one of the sharper tools in the shedtacomaman06 is one of the sharper tools in the shedtacomaman06 is one of the sharper tools in the shedtacomaman06 is one of the sharper tools in the shedtacomaman06 is one of the sharper tools in the shedtacomaman06 is one of the sharper tools in the shed
 
tacomaman06's Avatar
Name: Will
Joined: May 2007, #1475
Location: York,South Carolina
Age: 35
Gender: Male
Posts: 26,353
tacomaman06's Tacoma Gallery
i think if you go ahead and burn a complete tank of gas, the light will correct itself. plus it will give it time to relearn the new mixture. unhooking the battery on these trucks doesnt reset anything but the clock. so go ahead and reinstall the afe, it isnt gonna hurt anything.
  Reply With Quote
Old 10-08-2007, 05:09 PM   #3
07kKlR_TRD [OP] 07kKlR_TRD is offline
Junior Member
07kKlR_TRD is on a distinguished road
Joined: Oct 2007, #2971
Posts: 2
07kKlR_TRD's Tacoma Gallery
I figured the light would go away aswell but unfortunately it didnt.. maybe i need to give it another try, but thanks for the suggestion. Anyone else got some good tips??
  Reply With Quote
Old 10-08-2007, 05:47 PM   #4
Senior Member
kngharley is on a distinguished road
 
kngharley's Avatar
Joined: Oct 2006, #110
Location: Corona, Ca
Age: 46
Posts: 107
kngharley's Tacoma Gallery
You will need to have the computer set up by a speed shop once you have the new intake installed. The computer is seeing too much air flow/oxygen for the emissions system. The computer wil not reset it's self it has to be told what the new set up is. You may want to check the paperwork that came with the intake for any flow rates ect to give to the speed shop. Thats why the check engine light comes on.
  Reply With Quote
Old 10-08-2007, 05:51 PM   #5
Member
ellsworth is on a distinguished road
Joined: Aug 2007, #2433
Location: Buffalo
Posts: 96
ellsworth's Tacoma Gallery
what is the dtc in the pcm????? Have friends at a toyo dealer???
  Reply With Quote
Old 10-08-2007, 08:44 PM   #6
Senior Member
Viet2100 is one of the sharper tools in the shedViet2100 is one of the sharper tools in the shedViet2100 is one of the sharper tools in the shedViet2100 is one of the sharper tools in the shedViet2100 is one of the sharper tools in the shedViet2100 is one of the sharper tools in the shedViet2100 is one of the sharper tools in the shedViet2100 is one of the sharper tools in the shedViet2100 is one of the sharper tools in the shedViet2100 is one of the sharper tools in the shedViet2100 is one of the sharper tools in the shed
 
Viet2100's Avatar
Name: Viet
Joined: Jun 2007, #1930
Location: Delray Beach, FL
Age: 26
Gender: Male
Posts: 2,520
Viet2100's Tacoma Gallery
Send a message via Skype™ to Viet2100
It will go away after about a tank of gas. It goes away when you disconnect the batt because it has to learn the problem, then it will adjust itself. If you want the best out of your setup, pick up a URD MAF calibrator.
  Reply With Quote
Old 01-02-2008, 08:56 PM   #7
Junior Member
MATTRESS is on a distinguished road
Joined: Oct 2007, #3255
Location: LONG BEACH, CA
Posts: 25
MATTRESS's Tacoma Gallery
Yea I had the same prob. I just installed a VOLANT cold air system in my truck, and the next day it threw a code. I noticed that my truck was running through the gears differently then before. Right as its about to change gears (3rd or 4th gear) it revs slightly and then kicks into gear. Im not sure if this is related to the check engine or not, is it the computer doing this? I could also use some help from you guys...any ideas? (dont mean to intrude on your thread)
  Reply With Quote
Old 01-02-2008, 09:27 PM   #8
Carolina Alliance: Lead, follow, or get the hell outta my way
tacomaman06 is one of the sharper tools in the shedtacomaman06 is one of the sharper tools in the shedtacomaman06 is one of the sharper tools in the shedtacomaman06 is one of the sharper tools in the shedtacomaman06 is one of the sharper tools in the shedtacomaman06 is one of the sharper tools in the shedtacomaman06 is one of the sharper tools in the shedtacomaman06 is one of the sharper tools in the shedtacomaman06 is one of the sharper tools in the shedtacomaman06 is one of the sharper tools in the shedtacomaman06 is one of the sharper tools in the shed
 
tacomaman06's Avatar
Name: Will
Joined: May 2007, #1475
Location: York,South Carolina
Age: 35
Gender: Male
Posts: 26,353
tacomaman06's Tacoma Gallery
Quote:
Originally Posted by MATTRESS View Post
Yea I had the same prob. I just installed a VOLANT cold air system in my truck, and the next day it threw a code. I noticed that my truck was running through the gears differently then before. Right as its about to change gears (3rd or 4th gear) it revs slightly and then kicks into gear. Im not sure if this is related to the check engine or not, is it the computer doing this? I could also use some help from you guys...any ideas? (dont mean to intrude on your thread)

it will be like that for a few days until it learns the new air/fuel mix, then it will straighten out. cel should go away after a tank or 2 of gas.
  Reply With Quote
Old 01-04-2008, 07:48 PM   #9
Junior Member
MATTRESS is on a distinguished road
Joined: Oct 2007, #3255
Location: LONG BEACH, CA
Posts: 25
MATTRESS's Tacoma Gallery
but does that explain the gears acting strange?
  Reply With Quote
Old 01-04-2008, 07:59 PM   #10
Carolina Alliance: Lead, follow, or get the hell outta my way
tacomaman06 is one of the sharper tools in the shedtacomaman06 is one of the sharper tools in the shedtacomaman06 is one of the sharper tools in the shedtacomaman06 is one of the sharper tools in the shedtacomaman06 is one of the sharper tools in the shedtacomaman06 is one of the sharper tools in the shedtacomaman06 is one of the sharper tools in the shedtacomaman06 is one of the sharper tools in the shedtacomaman06 is one of the sharper tools in the shedtacomaman06 is one of the sharper tools in the shedtacomaman06 is one of the sharper tools in the shed
 
tacomaman06's Avatar
Name: Will
Joined: May 2007, #1475
Location: York,South Carolina
Age: 35
Gender: Male
Posts: 26,353
tacomaman06's Tacoma Gallery
Quote:
Originally Posted by MATTRESS View Post
but does that explain the gears acting strange?

i think it may seem like the gears are shifting funny....but more than likely,its the computer relearning everything, and it will be back to normal shortly. did you unhook the battery for a little while after the install?? im not saying this will automatically bring it back to normal...........but it may speed up the process if you havent done so yet.
  Reply With Quote
Old 01-06-2008, 04:48 PM   #11
Junior Member
MATTRESS is on a distinguished road
Joined: Oct 2007, #3255
Location: LONG BEACH, CA
Posts: 25
MATTRESS's Tacoma Gallery
you could be right, but im pretty sure that the engine over revs before kicking into gear..I will reset the comp. tonight and see what happens........
  Reply With Quote
Old 01-06-2008, 06:49 PM   #12
Member
ellsworth is on a distinguished road
Joined: Aug 2007, #2433
Location: Buffalo
Posts: 96
ellsworth's Tacoma Gallery
Trans

it is an adaptive strategy software in the trans portion of the ECM. It constantly changes cells in shift points and patterns.
  Reply With Quote
Old 01-07-2008, 08:03 PM   #13
Junior Member
MATTRESS is on a distinguished road
Joined: Oct 2007, #3255
Location: LONG BEACH, CA
Posts: 25
MATTRESS's Tacoma Gallery
Ecu Reset

Well today I reset the ECU and went for a short drive..I noticed that when I started it the RPMs seemed high, but after a minute it went down under 1500. Everything seemed to work fine on the road..it went through the gears smoothly..When I took my foot off the gas the engine reved a few times, but I figure thats just the ECU doing its work..For now everything is running good and the check engine is gone...we'll see how it goes.

Quote:
it is an adaptive strategy software in the trans portion of the ECM. It constantly changes cells in shift points and patterns
so now that I reset the ECU the shifting set points should be where there supposed to be right? Is that just an automatic change according to air / fuel mixture? So If I removed a plastic cap in front of my CAI box to allow more air thats going to change the set points..?
thanks
  Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
Check engine light off after check codes CUtacomaTIGER Technical Chat 3 02-03-2012 05:07 PM
volant cold air intake, engine light on k2jacob789 2nd Gen. Tacomas 11 04-06-2011 01:26 PM
Deck plate mod/check engine light/cold weather. "READ". Matic Technical Chat 3 02-17-2011 05:55 PM
Check engine light in cold weather CoreyF 1st Gen. Tacomas 4 01-17-2010 01:19 PM
Installed Cold Air Intake--check Engine And Shift Point Issues MATTRESS Technical Chat 28 02-05-2008 12:57 AM


Copyright © 2014 Tacoma Forum. Tacoma World is not owned by, or affiliated with Toyota Motor Corporation.