Mike "Wuzzy121". Rest in peace, brother

Go Back   Tacoma World Forums > Tacoma Garage > 4 Cylinder

Notices

2002 Taco 2.4 liter inconsistent rough idle

Reply
 
Thread Tools Search this Thread
Old 12-26-2010, 11:53 PM   #1
Junior Member
ToyotaCoupe is on a distinguished road
Joined: Aug 2010, #42028
Location: Georgia
Gender: Male
Posts: 14
ToyotaCoupe's Tacoma Gallery
2002 Taco 2.4 liter inconsistent rough idle

I have a 2002 Reg Cab 2.4/5sp 2wd 104,000 miles. I recently purchased it at 100K. It is stock. I essentially freshened up all the systems. Complete Fr and Rr brake job including fluid, flushed coolant, new shocks and front springs, wheel bearings, 4 new tires, alignment, new fuel filter, air filter, plugs (gapped correctly) pcv valve, tranny and diff fluid, Amsoil 5w30 oil and filter change, cleaned the MAF and sea-foamed the motor. It is does not burn or leak oil, does not appear to have any head gasket or vacuum leaks, tech went over entire motor with stethoscope. No plumes of white or blue smoke or coolant in the oil. I did have trouble with the exhaust. There were leaks throughout the system and I was throwing a rear 02 sensor code, someone had also butchered the header flange trying to change the header gasket(which was still leaking) and took a little chunk of the block with it. My exhaust guy went over the entire exhaust system and replaced the mid pipe and muffler, replaced all gaskets including the header gasket, welded all leaks around the cats and 02 sensor mounts, remounted clamped and welded the heat shields and just for safe keeping I also did the 02 sensor simulator for the rear 02 sensor since I had a code prior to the exhaust fix and the cats which are on there appear to be after-market cats (which will throw a code in and among themselves). Code was fixed exhaust seems to work well.

When I start the motor she idles strong until warm up. After the engine is warm and I have been driving for a while I notice if I role up to a light at idle there is a subtle vibration and idle quality seems to fall off. It is not severe, just subtle and is also inconsistent. It does change more dramatically with weather conditions. Seems to be more prevalent when it is extreme warm or extreme cold out. The vehicle does not tend to loose power. There is no code. It is more of an annoyance but I do fear it may get worse. I also notice some valve clatter but my mechanic mentioned these motors are prone to this. Is this true? If true is it an issue or should I just turn the radio up LOL.
Any Help is appreciated!
Thanks
Happy Holidays
  Reply With Quote
Old 12-27-2010, 02:01 PM   #2
Junior Member
ToyotaCoupe is on a distinguished road
Joined: Aug 2010, #42028
Location: Georgia
Gender: Male
Posts: 14
ToyotaCoupe's Tacoma Gallery
Bump for a mod to move thread please. I am assuming folks have not replied because maybe this needs to be in "Technical Chat" sorry.
Thanks
  Reply With Quote
Old 12-29-2010, 03:39 PM   #3
White Tank
SkyHighTacoma has much to be proud ofSkyHighTacoma has much to be proud ofSkyHighTacoma has much to be proud ofSkyHighTacoma has much to be proud ofSkyHighTacoma has much to be proud ofSkyHighTacoma has much to be proud ofSkyHighTacoma has much to be proud ofSkyHighTacoma has much to be proud of
 
SkyHighTacoma's Avatar
Name: Josh
Joined: Aug 2009, #21054
Location: Angleton,Texas
Age: 22
Gender: Male
Posts: 1,232
SkyHighTacoma's Tacoma Gallery
Well it seems you replaced alot but just a few other things that I can think of. Check and clean you IACV (Idle Air Control Valve) if it still idles bad after cleaning, replace it. And also maybe your TPS (Throttle Poisition Sensor) or maybe your spak plug wires. Maybe that could be the cause?

And yes, all Tacoma's have loud valve trains. Just turn the radio up if it runs good lol.
  Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
Rough Idle? BOLLINGERTACO Technical Chat 9 03-02-2012 10:59 AM
inconsistent idle JdubTaco06 2nd Gen. Tacomas 7 12-16-2011 08:18 AM
misfire in engine 3.4 liter V6 2002 ak90799763 Technical Chat 0 03-17-2010 02:22 PM
01 taco rough idle/throttle response. engine light on 01taco4x4 1st Gen. Tacomas 6 12-30-2009 09:18 PM
Proper Octane Fuel for 2002 2.7 liter Wood's Double Cab 1st Gen. Tacomas 11 04-30-2009 06:18 PM


Copyright © 2014 Tacoma Forum. Tacoma World is not owned by, or affiliated with Toyota Motor Corporation.