LSC15's 95 Tacoma 4x4

Go Back   Tacoma World Forums > Tacoma Garage > 4 Cylinder

Notices

Bad fuel pump or circuit opening relay

Reply
 
Thread Tools Search this Thread Display Modes
Old 07-04-2011, 12:45 PM   #1
Junior Member
George Schenfeld is on a distinguished road
Name: George
Joined: Jul 2011, #59295
Location: Wyoming
Gender: Male
Posts: 7
George Schenfeld's Tacoma Gallery
Bad fuel pump or circuit opening relay

1995 Tacoma 2.7L will not start. No fuel pump running. EFI relay good. Can't find the circuit opening relay. It is not where the Chilton book says it is, just under the steering column in the cab. I want to check the relay before ordering a fuel pump. Does anybody know where it is?
  Reply With Quote
Old 07-06-2011, 03:19 PM   #2
Junior Member
George Schenfeld is on a distinguished road
Name: George
Joined: Jul 2011, #59295
Location: Wyoming
Gender: Male
Posts: 7
George Schenfeld's Tacoma Gallery
I Found It.

Guess what. I found the relay way down the steering column above the brake pedal linkage. It is on the left side of the column, almost on top of it. Fortunately it can be pulled off the mounting bracket for checking.
  Reply With Quote
Old 08-08-2011, 05:35 PM   #3
Junior Member
ashok1999 is on a distinguished road
Name: Kris
Joined: Aug 2011, #61315
Location: Mamou, La.
Gender: Male
Posts: 4
ashok1999's Tacoma Gallery
Well, What was the final outcome? relay? fuel pump?
  Reply With Quote
Old 08-09-2011, 09:07 PM   #4
Junior Member
George Schenfeld is on a distinguished road
Name: George
Joined: Jul 2011, #59295
Location: Wyoming
Gender: Male
Posts: 7
George Schenfeld's Tacoma Gallery
Job still in progress

I have come to the conclusion that it is the ECM. I can remove the COR which is wired after the EFI relay and jump the leads from B+ to FP and the pump works. When I try starting the truck in this configuration it won't, even though there is fuel pressure. The COR tests ok using battery voltage and checking resistance with an ohm-meter. The ignition fires when cranking. I have checked voltage and resistance on all the circuits associated with the EFI system and can find nothing else out of spec. I am trying to find an ECM with the proper numbers on ebay and have looked at several sites on the internet. Will post again when I get an ECM installed.
  Reply With Quote
Old 08-16-2011, 10:33 PM   #5
Junior Member
George Schenfeld is on a distinguished road
Name: George
Joined: Jul 2011, #59295
Location: Wyoming
Gender: Male
Posts: 7
George Schenfeld's Tacoma Gallery
Got her fixed.

The problem was the ECM. All of the relays and fuses connected with the fuel pump and starting circuits tested ok. I put a different ECM in it today and it started right up. Runs fine.
  Reply With Quote
Old 04-06-2014, 12:14 PM   #6
Founder of NOX
kriskross has much to be proud ofkriskross has much to be proud ofkriskross has much to be proud ofkriskross has much to be proud ofkriskross has much to be proud ofkriskross has much to be proud ofkriskross has much to be proud ofkriskross has much to be proud of
 
kriskross's Avatar
Navy: Naval Flight Officer
Name: Chris
Joined: Oct 2011, #64585
Location: Western Florida
Age: 26
Gender: Male
Posts: 1,122
kriskross's Tacoma Gallery
Where did you get your new ECM?
  Reply With Quote
Old 04-09-2014, 01:25 AM   #7
Junior Member
George Schenfeld is on a distinguished road
Name: George
Joined: Jul 2011, #59295
Location: Wyoming
Gender: Male
Posts: 7
George Schenfeld's Tacoma Gallery
ECM module

I got it online from an auto recycler out Spokane Washington. I don't remember the name. Cost $100 which I thought was cheap compared to $900 from the Toyota dealer. I think most recyclers will guarantee what they send out so go ahead and google a "Toyota ECM" and you should find pages of them available. One word of caution is to make sure you have the part number off of the old unit as each engine and transmission configuration can/may require a different module. My Toyota hasn't missed a beat since replacing the ECM. Good Luck
  Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
New 2012 - Weird Sound Coming From Fuel Tank (Fuel Pump) When Off Hotwire 2nd Gen. Tacomas 2 12-10-2011 06:07 PM
Is the FUEL PUMP or something else?? 95TacoChick Technical Chat 26 11-28-2011 05:14 PM
Truck shakes and then shuts off. is this a bad fuel pump? sir1123 1st Gen. Tacomas 2 06-21-2011 08:27 PM
I think my fuel pump went bad??? Jayson 1st Gen. Tacomas 8 01-03-2010 09:23 AM
Fuel pump relay acryloman 2nd Gen. Tacomas 0 05-06-2008 05:41 PM


Copyright © 2014 Tacoma Forum. Tacoma World is not owned by, or affiliated with Toyota Motor Corporation.