Mike "Wuzzy121". Rest in peace, brother

Go Back   Tacoma World Forums > Tacoma Garage > 4 Cylinder

Notices

Engine running poorly

Reply
 
Thread Tools Search this Thread
Old 12-06-2008, 04:22 PM   #1
Junior Member
94FlatTracker is on a distinguished road
Joined: Dec 2008, #11339
Location: Hagerstown
Gender: Male
Posts: 1
94FlatTracker's Tacoma Gallery
Engine running poorly

My 1998 Tacoma just started to run poorly this week. I ran the codes and it came up with: TPS/ throttle position malfunction and catylist above threshold bank 1. I replaced the TPS sensor and cleaned the throttle body out, that did nothing, also replaced fuel filter and that did not help. Anyone have any pointers. Im starting to think it may be ignition related. Thanks Curtis Fisk
  Reply With Quote
Old 12-06-2008, 05:14 PM   #2
Carolina Alliance: LAZY DIVISION
AUDITECH has a brilliant futureAUDITECH has a brilliant futureAUDITECH has a brilliant futureAUDITECH has a brilliant futureAUDITECH has a brilliant futureAUDITECH has a brilliant futureAUDITECH has a brilliant futureAUDITECH has a brilliant futureAUDITECH has a brilliant futureAUDITECH has a brilliant futureAUDITECH has a brilliant future
Joined: Feb 2007, #875
Location: charlotte nc
Posts: 840
AUDITECH's Tacoma Gallery
do you have a 6 cyl or 4cyl sounds like you might have an o2 sensor that might be going bad. if the o2 sensor is reading wrong you could be running rich or lean.
  Reply With Quote
Old 12-06-2008, 05:17 PM   #3
With sufficient thrust, pigs fly just fine.
chris4x4 is one of the sharper tools in the shedchris4x4 is one of the sharper tools in the shedchris4x4 is one of the sharper tools in the shedchris4x4 is one of the sharper tools in the shedchris4x4 is one of the sharper tools in the shedchris4x4 is one of the sharper tools in the shedchris4x4 is one of the sharper tools in the shedchris4x4 is one of the sharper tools in the shedchris4x4 is one of the sharper tools in the shedchris4x4 is one of the sharper tools in the shedchris4x4 is one of the sharper tools in the shed
 
chris4x4's Avatar
Name: FlimFlubberJAM
Joined: May 2008, #6497
Location: Tenoe, AZ
Gender: Male
Posts: 97,110
chris4x4's Tacoma Gallery
Quote:
Originally Posted by AUDITECH View Post
do you have a 6 cyl or 4cyl sounds like you might have an o2 sensor that might be going bad. if the o2 sensor is reading wrong you could be running rich or lean.
He has the 2.7

OP, Post up the code/s your getting so we can help.
  Reply With Quote
Old 12-07-2008, 07:46 PM   #4
SickTacoFoSho
piratesvarsity22 is on a distinguished road
Joined: Sep 2008, #9136
Location: florida
Age: 26
Gender: Male
Posts: 59
piratesvarsity22's Tacoma Gallery
Send a message via AIM to piratesvarsity22
heyyy

again same problem. o2 is bad. replace it and watch the difference in gas mileage and performance
  Reply With Quote
Old 12-07-2008, 07:50 PM   #5
Lord of Tomfoolery
genxer36 is one of the sharper tools in the shedgenxer36 is one of the sharper tools in the shedgenxer36 is one of the sharper tools in the shedgenxer36 is one of the sharper tools in the shedgenxer36 is one of the sharper tools in the shedgenxer36 is one of the sharper tools in the shedgenxer36 is one of the sharper tools in the shedgenxer36 is one of the sharper tools in the shedgenxer36 is one of the sharper tools in the shedgenxer36 is one of the sharper tools in the shedgenxer36 is one of the sharper tools in the shed
 
genxer36's Avatar
Name: Sean
Joined: Nov 2007, #3442
Location: Bethlehem,GA
Age: 46
Gender: Dude
Posts: 10,664
genxer36's Tacoma Gallery
Welcome to TW!
  Reply With Quote
Old 12-07-2008, 07:53 PM   #6
Senior Member
JJ Customs is one of the sharper tools in the shedJJ Customs is one of the sharper tools in the shedJJ Customs is one of the sharper tools in the shedJJ Customs is one of the sharper tools in the shedJJ Customs is one of the sharper tools in the shedJJ Customs is one of the sharper tools in the shedJJ Customs is one of the sharper tools in the shedJJ Customs is one of the sharper tools in the shedJJ Customs is one of the sharper tools in the shedJJ Customs is one of the sharper tools in the shedJJ Customs is one of the sharper tools in the shed
 
JJ Customs's Avatar
Marines: Sgt (Advisor Instructor 0311)
Name: Jay
Joined: Feb 2008, #4935
Location: Sparks, NV
Age: 35
Gender: Dude
Posts: 1,003
JJ Customs's Tacoma Gallery
On my 97 2.7 the TPS went out. The problem I was having was the RPM's would jump up and down at idle. As stated before, the O2 sensor can have the same effect.
  Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
Engine seems to be running too much?!?! plz help Babbar Khalsa 1st Gen. Tacomas 0 03-17-2011 12:09 PM
Why do Hankook's rate so poorly on TireRack eckcessive Wheels & Tires 43 02-09-2011 08:09 PM
Locking doors when engine is running. greg muncy Technical Chat 17 01-09-2011 03:16 PM
Truck runs poorly, need diagnosis help tmantstud 1st Gen. Tacomas 15 08-15-2009 11:33 PM
Whats running in your engine?? tarheelfan_08 1st Gen. Tacomas 2 04-07-2008 05:10 PM


Copyright © 2014 Tacoma Forum. Tacoma World is not owned by, or affiliated with Toyota Motor Corporation.