Mike "Wuzzy121". Rest in peace, brother

Go Back   Tacoma World Forums > Tacoma Garage > 4 Cylinder

Notices

'97 tacoma 2.7l detonation, "pinging"

Reply
 
Thread Tools Search this Thread
Old 10-31-2013, 02:03 PM   #1
vern650 [OP] vern650 is offline
Senior Member
vern650 is on a distinguished road
 
vern650's Avatar
Name: brandon
Joined: Sep 2013, #111738
Location: hyrum, ut
Gender: Male
Posts: 105
vern650's Tacoma Gallery
'97 tacoma 2.7l detonation, "pinging"

so couple months ago i picked up this truck for pretty cheap for a hunting/beater rig and have slowly been working out the bugs. a bit of background, 97 4x4 ext. cab speedometer is dead at 248k miles but I'm estimating its pushing the 300k mark and judging by the condition and fact it came from a farm the last few years have not been kind to it. so far I've replaced a cracked manifold with a pacesetter header(i know, not the best but remember its just a beater and don't need a $400 header) threw on a imco muffler, cleaned maf sensor, replaced a belt and tensioner pulley, cleaned the throttle body, seafoamed through the vac. lines in intake and in gas tank, and a couple days ago replaced the ect sensor on back of the head which so far has seemed to improved the performance quite a bit.

it seems to run pretty good, but on the hills when its under pretty good load I'm getting what sounds to be detonation ping, this is happening at about 2k rpm in 5th and will still do it on occasion if downshifted to 4th. i have ran up to 91 octane(highest we have around here) and it still pings. if I'm not mistaken it shouldn't need that high of octane which makes me wonder if i got something else goin on, a bad sensor or something. just wondering if anyone might have an idea what's goin on or if this is normal for a toyota(my first yota)

also, i have a cheap scanner that will read some sensor outputs but not sure what normal output is for like the maf sensor, o2 sensors, timing etc.. i know atleast the upstream o2 sensor should rapidly fluctuate up and down if functioning properly but what about the downstream? if anyone knows what all the norm. values are for the various sensors, it would be greatly appreciated as i would atleast know what I'm lookin for.

thanks for any info, and sorry for the long winded post.
  Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
2013 Tacoma "Pinging" Domreis Technical Chat 61 08-08-2014 02:41 AM
2011 2.7L Cold Start Pinging 11Taco2.7 4 Cylinder 3 07-29-2013 09:53 PM
1995 tacoma 2.7l with 35" tsl boggers 6" lift, I need the best advice on Regearing bwall 1st Gen. Tacomas 33 06-26-2012 06:47 PM
Which 3" lift is best for 97 Tacoma mj1168 1st Gen. Tacomas 8 12-11-2010 10:40 AM
"Wish I was 3" Taller 97 Taco Neube Here" DTRD New Members 3 03-17-2010 09:48 AM


Copyright © 2014 Tacoma Forum. Tacoma World is not owned by, or affiliated with Toyota Motor Corporation.