Delta00's 2002 Tacoma 4WD

Go Back   Tacoma World Forums > Tacoma Garage > 4 Cylinder

Notices

Engine hesitation...

Reply
 
Thread Tools Search this Thread
Old 03-27-2014, 07:09 PM   #1
moondog [OP] moondog is offline
Junior Member
moondog is on a distinguished road
Joined: Mar 2014, #126348
Location: East Central IL
Gender: Male
Posts: 7
moondog's Tacoma Gallery
Smile Engine hesitation...

My 1996 Tacoma 2.4L has 157K on it and engine seems to idle fine, but has intermittent stutter/hesitation when accelerating and cruising on interstate. I've read about TPS issues, but not sure if this is what I have or not. I went thru drive thru car wash and drove in rain, and seems to run better. How would moisture affect the TPS or is it something else? I just got it, and service records indicate a tune up (plugs and wires) in last 3k mi., new MAF 2 yrs ago and, so I'm kinda lost on this. It's my first Toyota so any help is appreciated. Thanks.
  Reply With Quote
Old 03-27-2014, 08:08 PM   #2
Senior Member
dispatch55126 is one of the sharper tools in the sheddispatch55126 is one of the sharper tools in the sheddispatch55126 is one of the sharper tools in the sheddispatch55126 is one of the sharper tools in the sheddispatch55126 is one of the sharper tools in the sheddispatch55126 is one of the sharper tools in the sheddispatch55126 is one of the sharper tools in the sheddispatch55126 is one of the sharper tools in the sheddispatch55126 is one of the sharper tools in the sheddispatch55126 is one of the sharper tools in the sheddispatch55126 is one of the sharper tools in the shed
 
dispatch55126's Avatar
Firefighter:
Joined: Mar 2014, #125193
Location: MN
Gender: Male
Posts: 965
dispatch55126's Tacoma Gallery
Is it throwing any codes?
  Reply With Quote
Old 03-28-2014, 05:24 AM   #3
moondog [OP] moondog is offline
Junior Member
moondog is on a distinguished road
Joined: Mar 2014, #126348
Location: East Central IL
Gender: Male
Posts: 7
moondog's Tacoma Gallery
CEL isn't on.
  Reply With Quote
Old 03-29-2014, 07:18 PM   #4
moondog [OP] moondog is offline
Junior Member
moondog is on a distinguished road
Joined: Mar 2014, #126348
Location: East Central IL
Gender: Male
Posts: 7
moondog's Tacoma Gallery
^bump^ changed spark plugs, went with OE NGK plugs and did the Seafoam spray in the throttle body, it smoked a little, but not much. It idles a little smoother though. I still have the intermittent miss on acceleration and with cruise set on highway. I'm not sure if it's ignition or fuel issue here. I can tell there's slight improvement, but maybe it's just me..
  Reply With Quote
Old 04-05-2014, 05:04 PM   #5
moondog [OP] moondog is offline
Junior Member
moondog is on a distinguished road
Joined: Mar 2014, #126348
Location: East Central IL
Gender: Male
Posts: 7
moondog's Tacoma Gallery
I've been troubleshooting this for a few days now and it seems to run pretty good when engine is cold, and starts the "hiccup" when it warms up some. It also happens mostly around the 2200-2700 rpm range. I've read about the TPS, any ideas on if this could be the culprit? Thanks!
  Reply With Quote
Old 03-13-2015, 11:01 AM   #6
Junior Member
98yodaboat is on a distinguished road
Joined: Feb 2015, #147796
Location: Portland oregon
Gender: Male
Posts: 1
98yodaboat's Tacoma Gallery
I've been having what sounds like the same problems for the past 3 months and have chased everything. I can't figure it out. Threw a cel on Jan 1st for misfire and lean on bank 1. Plugs replaced, a couple vacuum leaks found and fixed. Continued to have stuttering, hesitation, rough low idle, rough starts. Here's what's been done so far. Would love to hear if you found the problem or if anyone has any direction to point me in. Mines a 98 2.4 with 220k miles. So far, have replaced plugs and wires twice, cleaned throttle body, out of body injector cleaning, fuel filter replaced, normal oil change done, MAF replaced, IAC valve cleaned, pcv valve replaced, new battery, TPS replaced, o2 sensors tested working in proper range, coolant temp sensor tested working. I don't know if this is fuel or alternator related but we have testes just about anything we can. No cel comes on. Fuel pressure reads at what it should according to mechanic. Help. I'm about to cut and run on this truck but I've had it for 14 years and don't want to give up on it.
  Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
Engine Hesitation chvymechanic 1st Gen. Tacomas 11 07-21-2014 07:51 PM
Engine Hesitation RPain 1st Gen. Tacomas 12 08-05-2011 07:25 AM
Engine hesitation Drtierra 1st Gen. Tacomas 5 03-13-2010 05:14 PM
Hesitation??? Vander18 Technical Chat 24 01-05-2010 04:33 PM
Engine Hesitation klavallee 2nd Gen. Tacomas 2 07-25-2009 07:41 PM


Copyright © 2015 Tacoma Forum. Tacoma World is not owned by, or affiliated with Toyota Motor Corporation.