Mike "Wuzzy121". Rest in peace, brother

Go Back   Tacoma World Forums > Tacoma Garage > 4 Cylinder

Notices

P0402 excessive flow

Reply
 
Thread Tools Search this Thread
Old 06-03-2014, 11:25 AM   #1
duggravs [OP] duggravs is offline
Member
duggravs is on a distinguished road
Name: ricky
Joined: Apr 2014, #128350
Location: torrance, ca
Gender: Male
Posts: 42
duggravs's Tacoma Gallery
P0402 excessive flow

I have a 04 3rz the check engine light came on with code p0402 (excessive flow) I cleaned the iac and the egr (with carb cleaner). The egr seemed ok. It moved up n down when I added vacume to it. And after I installed it. I added vacume to it. And the motor stalled. (Isn't that what's suppose to happen?) all the vacume lines are good. for some reason the check engine light came on again. Should I look at something else? Or should I just replace the egr?
I checked a couple forums. I can't seem to find a straight answer what it could be.
  Reply With Quote
Old 06-05-2014, 07:17 PM   #2
duggravs [OP] duggravs is offline
Member
duggravs is on a distinguished road
Name: ricky
Joined: Apr 2014, #128350
Location: torrance, ca
Gender: Male
Posts: 42
duggravs's Tacoma Gallery
someone must of had this problem besides me.
  Reply With Quote
Old 06-05-2014, 08:42 PM   #4
Senior Member
avw4x4 is one of the sharper tools in the shedavw4x4 is one of the sharper tools in the shedavw4x4 is one of the sharper tools in the shedavw4x4 is one of the sharper tools in the shedavw4x4 is one of the sharper tools in the shedavw4x4 is one of the sharper tools in the shedavw4x4 is one of the sharper tools in the shedavw4x4 is one of the sharper tools in the shedavw4x4 is one of the sharper tools in the shedavw4x4 is one of the sharper tools in the shedavw4x4 is one of the sharper tools in the shed
 
avw4x4's Avatar
Name: Andrew
Joined: Oct 2013, #114886
Location: Rochester, NY
Age: 25
Gender: Male
Posts: 1,833
avw4x4's Tacoma Gallery
I believe this is one of the more common codes. Could be as simple as an exhaust leak or bad o2 sensor.


Scratch that, dyslexia got the better of me. I was thinking p0420
  Reply With Quote
Old 06-05-2014, 08:51 PM   #5
duggravs [OP] duggravs is offline
Member
duggravs is on a distinguished road
Name: ricky
Joined: Apr 2014, #128350
Location: torrance, ca
Gender: Male
Posts: 42
duggravs's Tacoma Gallery
I just noticed that the r port on my throttle body was going to the vacuum switch valve. And not to the r port on the vacuum modulator. And the vacuum modulator hose was going to the R port on the throttlebody. Let see if that makes a diffrence.
I'm going to be kicking my self in the ass if that was the problem.
  Reply With Quote
Old 06-05-2014, 08:52 PM   #6
Senior Member
avw4x4 is one of the sharper tools in the shedavw4x4 is one of the sharper tools in the shedavw4x4 is one of the sharper tools in the shedavw4x4 is one of the sharper tools in the shedavw4x4 is one of the sharper tools in the shedavw4x4 is one of the sharper tools in the shedavw4x4 is one of the sharper tools in the shedavw4x4 is one of the sharper tools in the shedavw4x4 is one of the sharper tools in the shedavw4x4 is one of the sharper tools in the shedavw4x4 is one of the sharper tools in the shed
 
avw4x4's Avatar
Name: Andrew
Joined: Oct 2013, #114886
Location: Rochester, NY
Age: 25
Gender: Male
Posts: 1,833
avw4x4's Tacoma Gallery
Be sure to post up if it was the issue!
  Reply With Quote
Old 06-05-2014, 09:10 PM   #7
duggravs [OP] duggravs is offline
Member
duggravs is on a distinguished road
Name: ricky
Joined: Apr 2014, #128350
Location: torrance, ca
Gender: Male
Posts: 42
duggravs's Tacoma Gallery
Quote:
Originally Posted by avw4x4 View Post
Be sure to post up if it was the issue!
I will.
  Reply With Quote
Old 06-10-2014, 12:32 PM   #8
duggravs [OP] duggravs is offline
Member
duggravs is on a distinguished road
Name: ricky
Joined: Apr 2014, #128350
Location: torrance, ca
Gender: Male
Posts: 42
duggravs's Tacoma Gallery
I can confidently say that I fixed the problem. It was two vacuum hoses that were switched around. I've been driving around for a couple days now with no check engine light.
Thanks for all the hell everyone.
  Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
2.7L auto weak with error code p0402 "EGR EXCESSIVE FLOW" outlaw8950 1st Gen. Tacomas 20 10-07-2014 08:51 AM
That 402 Excessive EGR Flow error mtbluedog 1st Gen. Tacomas 0 04-18-2014 10:54 AM
p0402 Exhaust Gas Recirculation Flow (EGR) Excessive Detect - 99 Prerunner 2.7L HELP! Waterfowl HD 1st Gen. Tacomas 7 03-21-2014 11:39 PM
EGR Excessive Flow code LoriB01 Technical Chat 7 06-09-2013 11:20 PM
P0402 EGR Excessive Flow vapovick 4 Cylinder 14 10-26-2011 04:12 PM


Copyright © 2014 Tacoma Forum. Tacoma World is not owned by, or affiliated with Toyota Motor Corporation.