Mike "Wuzzy121". Rest in peace, brother

Go Back   Tacoma World Forums > Tacoma Garage > 4 Cylinder

Notices

2001 4cyl AT shift problem problem

Reply
 
Thread Tools Search this Thread
Old 09-25-2009, 02:43 PM   #1
Junior Member
springfield59 is on a distinguished road
Army: intel ofcr & aviator
Name: Craig
Joined: Sep 2009, #23304
Location: Tuscaloosa
Gender: Male
Posts: 15
springfield59's Tacoma Gallery
2001 4cyl AT shift problem problem

I am new and have a 2001 4 cyl SR5 Xtra Cab with AT, 205k miles.. Just recently the trans started acting strange. If I take off gently from a standing start it will shift from 1st to second, no problem, shifting somewhere between 1000-2000 engine rpm. However, if I maintain a constant pressure on the accelerator it will go up to 3200-3400 rpm before shifting into second. I have changed the AT fluid and filter twice in the past 2 weeks, checked the valve body for any obvious damage, no large metal flakes, removed the EFI fuse for 10 seconds that somebody suggested, have checked the resistance on the TPS, was in spec; all to no avail. No engine trouble light either. I have an Alldata subscription and am using that to troubleshoot. About all that is left is to check is the vehicle speed sensor, and then the governor valve. If it's not one of those last two things, i don't know what else to do short of replacing the transmission. Does anybody else have any other ideas? thank you.
  Reply With Quote
Old 09-25-2009, 02:54 PM   #2
:POOPCORN:
98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed
 
98tacoma27's Avatar
Marines:
Name: Ben
Joined: Dec 2008, #11714
Location: Beech Creek
Gender: Dude
Posts: 48,263
98tacoma27's Tacoma Gallery
Have you check the throttle cable for looseness?
Here are some other things to check out.

http://www.ncttora.com/fsm/2003/Repa...thrcab/ovr.pdf
http://www.ncttora.com/fsm/2003/Repa...d/atsy/pst.pdf

http://www.ncttora.com/fsm/2003/Repa...govbod/ovr.pdf
  Reply With Quote
Old 09-28-2009, 06:38 PM   #3
Junior Member
springfield59 is on a distinguished road
Army: intel ofcr & aviator
Name: Craig
Joined: Sep 2009, #23304
Location: Tuscaloosa
Gender: Male
Posts: 15
springfield59's Tacoma Gallery
2001 4cyl AT shift problem

When I look at and disassemble the governor valve and/or the vehicle speed sensor, what do I need to be looking for that might indicate one or the other is the problem? Do I clean the governor valve and the VSS or do I just need to replace one or both? Or is there something else I should do? Thank you. -Craig
  Reply With Quote
Old 09-28-2009, 06:50 PM   #4
:POOPCORN:
98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed
 
98tacoma27's Avatar
Marines:
Name: Ben
Joined: Dec 2008, #11714
Location: Beech Creek
Gender: Dude
Posts: 48,263
98tacoma27's Tacoma Gallery
Do you have any problems at free way speeds (high end)?
  Reply With Quote
Old 09-28-2009, 07:29 PM   #5
Junior Member
springfield59 is on a distinguished road
Army: intel ofcr & aviator
Name: Craig
Joined: Sep 2009, #23304
Location: Tuscaloosa
Gender: Male
Posts: 15
springfield59's Tacoma Gallery
2001 4cyl AT shift problem problem

None. Once it shifts into 2nd and beyond, there are no problems. I routinely commute an hour to work on the interstate and stay at 70 mph. O/D works fine, etc. -Craig
  Reply With Quote
Old 09-29-2009, 02:11 PM   #6
:POOPCORN:
98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed
 
98tacoma27's Avatar
Marines:
Name: Ben
Joined: Dec 2008, #11714
Location: Beech Creek
Gender: Dude
Posts: 48,263
98tacoma27's Tacoma Gallery
So the problems seem to be low end associated. You may have a bad torque converter
  Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
Major clutch problem 4cyl 4x4 evil_umbrellacorp 2nd Gen. Tacomas 8 12-22-2011 03:33 PM
SHIFT PROBLEM? hamsterhater 2nd Gen. Tacomas 2 12-19-2011 01:49 PM
2001 shifting problem protoadies 1st Gen. Tacomas 5 11-25-2011 05:03 AM
Toyota Tacoma 2008 4x4 shift problem ritetoyota Toyota Trucks & SUVs 11 03-22-2011 02:44 PM
Header problem on the 4cyl engine cshoe98 1st Gen. Tacomas 8 12-16-2007 12:25 PM


Copyright © 2014 Tacoma Forum. Tacoma World is not owned by, or affiliated with Toyota Motor Corporation.