Mike "Wuzzy121". Rest in peace, brother

Go Back   Tacoma World Forums > Tacoma Garage > 4 Cylinder

Notices

Code p0441 and wont start w/ full tank of gas etc HELP

Reply
 
Thread Tools Search this Thread
Old 04-06-2010, 11:03 AM   #1
snoozeworm [OP] snoozeworm is offline
taco king
snoozeworm is one of the sharper tools in the shedsnoozeworm is one of the sharper tools in the shedsnoozeworm is one of the sharper tools in the shedsnoozeworm is one of the sharper tools in the shedsnoozeworm is one of the sharper tools in the shedsnoozeworm is one of the sharper tools in the shedsnoozeworm is one of the sharper tools in the shedsnoozeworm is one of the sharper tools in the shedsnoozeworm is one of the sharper tools in the shedsnoozeworm is one of the sharper tools in the shedsnoozeworm is one of the sharper tools in the shed
Joined: Mar 2010, #33432
Location: wheeling,wv
Age: 23
Gender: Male
Posts: 218
snoozeworm's Tacoma Gallery
Code p0441 and wont start w/ full tank of gas etc HELP

I have a 2004 tacoma 4cyl 5 speed regular cab with 46,000 miles. In december it threw the evap purge code p0441, i took it to the dealer and payed 360 for them to "fix" it. Now just the other day i cranked it and it didnt start, i cranked a second time and it barley started and took 20 seconds to get to idle. Then it threw the p0441 code again, since then it randomly takes 2-3 cranks to start. I cleared the code, the light went away for 2 weeks but the starting issue persisted, now the code is back.

NOTE** The truck NEVER starts after i fill it up with gas, and NO, I DO NOT OVERFILL. When the pump stops for the first time i quit filling, and do not go a penny over.

So does anyone have an idea what could be wrong?
  Reply With Quote
Old 04-06-2010, 11:04 AM   #2
Senior Member
macgyver is one of the sharper tools in the shedmacgyver is one of the sharper tools in the shedmacgyver is one of the sharper tools in the shedmacgyver is one of the sharper tools in the shedmacgyver is one of the sharper tools in the shedmacgyver is one of the sharper tools in the shedmacgyver is one of the sharper tools in the shedmacgyver is one of the sharper tools in the shedmacgyver is one of the sharper tools in the shedmacgyver is one of the sharper tools in the shedmacgyver is one of the sharper tools in the shed
 
macgyver's Avatar
Name: Brad
Joined: Aug 2009, #21173
Location: Canton, GA
Gender: Male
Posts: 3,566
macgyver's Tacoma Gallery
Bad gas cap?
  Reply With Quote
Old 04-06-2010, 01:05 PM   #3
:POOPCORN:
98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed
 
98tacoma27's Avatar
Marines:
Name: Ben
Joined: Dec 2008, #11714
Location: Beech Creek
Gender: Dude
Posts: 52,623
98tacoma27's Tacoma Gallery
A code P0441 could mean one or more of the following has happened:
  • Bad vacuum switch
  • Broken or damaged EVAP line or canister
  • Open in PCM purge command circuit
  • Open or short in Voltage feed circuit to Purge Solenoid
  • Faulty purge solenoid
  • Restriction in EVAP solenoid, line or canister
  • Corrosion or resistance in purge connector
  • Bad PCM
With a P0441 OBD-II trouble code, diagnosis can be tricky at times. Here are some things to try:

Repair damaged EVAP lines or canister
  • Repair open or short in voltage feed circuit to Purge Solenoid
  • Repair open in PCM purge command circuit
  • Replace purge Solenoid
  • Replace vacuum switch
  • Repair restriction in Evap line or canister or soleniod
  • Repair resistance in purge connector
  • Replace PCM
http://www.ncttora.com/fsm/2003/Repa...3/cip0441p.pdf

Simple things first. Get a replacemnet gas cap.
  Reply With Quote
Old 11-03-2010, 03:43 AM   #4
snoozeworm [OP] snoozeworm is offline
taco king
snoozeworm is one of the sharper tools in the shedsnoozeworm is one of the sharper tools in the shedsnoozeworm is one of the sharper tools in the shedsnoozeworm is one of the sharper tools in the shedsnoozeworm is one of the sharper tools in the shedsnoozeworm is one of the sharper tools in the shedsnoozeworm is one of the sharper tools in the shedsnoozeworm is one of the sharper tools in the shedsnoozeworm is one of the sharper tools in the shedsnoozeworm is one of the sharper tools in the shedsnoozeworm is one of the sharper tools in the shed
Joined: Mar 2010, #33432
Location: wheeling,wv
Age: 23
Gender: Male
Posts: 218
snoozeworm's Tacoma Gallery
bump for some answers, this is an ongoing problem. I removed all the vsv's and they worked on the bench test. Which vsv lets fumes into the engine, my guess is it sticks open, lets fumes into the engine, the engine has to much vapor (air) and therfor when i put my foot on the gas while cranking it gives it more gas to = out the air and will start.
  Reply With Quote
Old 03-27-2011, 07:56 PM   #5
Junior Member
Jax Fresco is on a distinguished road
Name: Mark
Joined: Mar 2011, #53848
Location: Jacksonville, FL
Gender: Male
Posts: 1
Jax Fresco's Tacoma Gallery
Can anyone help with this? I also have the exact same problem with my 03 PreRunner 2.7 4cyl. It doesn't start after sitting for a few hours or when I fill up with gas. Cranks over fine but just won't fire unless I give it gas. Once its started I can shut it off and it will fire right back up. Once running it runs great. It also gave code P0441
  Reply With Quote
Old 03-28-2011, 05:28 AM   #6
:POOPCORN:
98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed98tacoma27 is one of the sharper tools in the shed
 
98tacoma27's Avatar
Marines:
Name: Ben
Joined: Dec 2008, #11714
Location: Beech Creek
Gender: Dude
Posts: 52,623
98tacoma27's Tacoma Gallery
Quote:
Originally Posted by snoozeworm View Post
bump for some answers, this is an ongoing problem. I removed all the vsv's and they worked on the bench test. Which vsv lets fumes into the engine, my guess is it sticks open, lets fumes into the engine, the engine has to much vapor (air) and therfor when i put my foot on the gas while cranking it gives it more gas to = out the air and will start.
Quote:
Originally Posted by Jax Fresco View Post
Can anyone help with this? I also have the exact same problem with my 03 PreRunner 2.7 4cyl. It doesn't start after sitting for a few hours or when I fill up with gas. Cranks over fine but just won't fire unless I give it gas. Once its started I can shut it off and it will fire right back up. Once running it runs great. It also gave code P0441
The CCV and EVAP VSV's both let excess vapor back into the motor. The CCV vents into the air box and the EVAP vents into the throttle body behind the butterfly plate.

This system's sole purpose is to keep excess gas vapor from getting into the atmosphere. To do this it relies on the vacuum system. I would suggest you two go over all of you vacuum lines and connections to insure there are no leaks.
  Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
Code P0441 bsandb 1st Gen. Tacomas 12 12-01-2012 06:19 PM
Poll - AVG MILES traveled on full tank of gas. Opihiman10 2nd Gen. Tacomas 47 03-23-2012 11:06 PM
GAS TANK SKID PLATE (Metal cover that protects your gas tank) question TacomaFrank 1st Gen. Tacomas 5 12-31-2011 06:40 PM
P0102 code, truck won't start without gas Evildcustoms 2nd Gen. Tacomas 12 12-07-2010 04:02 PM
wont start code reads crank positioning sensor tacofred 2nd Gen. Tacomas 5 03-20-2010 06:01 PM


Copyright © 2014 Tacoma Forum. Tacoma World is not owned by, or affiliated with Toyota Motor Corporation.