Tacoma World Forums

Tacoma World Forums (http://www.tacomaworld.com/forum/)
-   4 Cylinder (http://www.tacomaworld.com/forum/4-cylinder/)
-   -   Modified my 2012 Tacoma 2.4L (http://www.tacomaworld.com/forum/4-cylinder/277025-modified-my-2012-tacoma-2-4l.html)

Fish Killer 05-08-2013 02:49 PM

Modified my 2012 Tacoma 2.4L
 
Hello everyone,

I went and modified my 2012 base cab 2.7l 4 cylinder truck. Wanted a little bit more get up and go!

With less than 2500 miles on it, the 2012 tacoma seemed to be slower than the 2003 with Cold air intake.

So, the Doug Thorley Short Headers, since I'm in CALI helped significantly, along with the Aero 2525 Muff, and the AFE Cold Air intake.

It seems the ECU did self adjust itself after driving it like I stole it, and finding what to do from some other site.

One note, the AFE COLD Air Intake for up to 2011 has an issue with the positive Crankcase valve the engine. Ended up going to the hardware store for several 90 degree union valves to make the connection the engine.

Truck runs great, and base tone loud!

I do have th say that the front bumper scratches way to easy, and flimsy.. have some small scuffs from stupid people, and etc.

97Blk_one 05-08-2013 02:53 PM

Are Afe Cool Air intake any better then the KNFilter? fixing to install Afe on 2009 4 Runner soon....

Fish Killer 05-08-2013 03:11 PM

From what I ready from previous post in this forum, the AFE's are great, cause they seem to trap more particals. Also, it seems it gets slightly more HP gain, but that may all be marketing. I did also have to take the weather stripping off for the cold air intake heatshield to also fit.

The good thing with AFE, is that they have a dry filter. I opted with that! Less issues with that filter oil clogging things up, and easier to clean, less messy.

DriverSound 05-08-2013 03:53 PM

I use the AFE Pro Dry S on both the tacoma and 4runner.

Any pics of the header/intake?

Gelo760 05-08-2013 04:04 PM

Why did the afe need all those modification ?

Fish Killer 05-08-2013 04:11 PM

Quote:

Originally Posted by Gelo760 (Post 6861015)
Why did the afe need all those modification ?

Perhaps the 2012, there are minor changes.

The weather stripping on the heat shield was causing the hood not close properly. when I slammed, it closed but was sticking up slighlty where the heat shield was.

The 90 degree union was necessary. The 90 degree PCV valve it came with, the stock did not fit the engine correctly, in them model i had, the attachment to the engine was off by several more inches. So we ended up getting a straight sprinkler valve, then rubber piping, and then a 90 degree union, and more pipe.

PSJ 05-09-2013 05:29 AM

My afe fit perfect. I have read a thread here that some have installed these filters upside down. :confused: May create a fitment issue. I love the easy maintenance of these filters...:D

Fish Killer 05-09-2013 07:47 AM

Quote:

Originally Posted by PSJ (Post 6863847)
My afe fit perfect. I have read a thread here that some have installed these filters upside down. :confused: May create a fitment issue. I love the easy maintenance of these filters...:D


Filter is fine. the air duct pipe is where the hang up is. If you rotated the pipe, the same issue would occur. Will post pictures tonight

Fish Killer 05-11-2013 05:31 PM

3 Attachment(s)
Here are the pictures finally, of what I was talking about, about the AFE Cold air intake and the Doug Thorley Exhaust headers. We just used the stock stud setup on it. Did loose one nut, replaced with autozone nut.. Didn't see the extra parts for the headers, until it was all done. Oh well.

In the 3rd picture, I ran to the hardware store for it to work! I think thats the PCV to the air duct?

Sorry for the delay.

crawl 05-14-2013 03:42 PM

^^Its just a breather for VC/crankcase, not the PCV.

Cant you just run a single piece of hose?...it doesn't need to be a 90* bend there. I think it would look much better.
Your engine bay with intake and header looks super nice man!

Fish Killer 05-16-2013 09:07 PM

Just got engine check light today. troubleshooting Saturday. Error Code P2441. Some bank stuck closed. I think the truck with less than 300 miles, that its gotta be some vacuum leak, or maybe bad set of headers.

crawl 05-17-2013 02:57 PM

Quote:

Originally Posted by Fish Killer (Post 6900250)
Just got engine check light today. troubleshooting Saturday. Error Code P2441. Some bank stuck closed. I think the truck with less than 300 miles, that its gotta be some vacuum leak, or maybe bad set of headers.

Secondary Air Injection System...


http://carphotos.cardomain.com/ride_...0019_large.jpg

The pressure sensor you removed from the stock intake and mounted to the valve cover is part of the system. Check the vacuum hose and electrical connection... it could be as simple as one of those two not connected.

If the air pump is working, you can hear it turn on when you first start the engine..cold start..and shut off within 20 seconds or so.


All times are GMT -7. The time now is 11:08 PM.