SCRunner12's 4Runner Limited

Go Back   Tacoma World Forums > Tacoma Discussion > 4Runners

Notices

I can't figure out this misfire.

Reply
 
Thread Tools Search this Thread
Old 08-09-2012, 09:43 PM   #1
josh700 [OP] josh700 is offline
Junior Member
josh700 is on a distinguished road
Joined: Jun 2012, #80899
Gender: Male
Posts: 10
josh700's Tacoma Gallery
I can't figure out this misfire.

Well here is where I am at with my problem. '99 4runner with 3.4L and it started an occasional misfire on Cyl #3. I say occasional, and I mean every 2 or 3 days, and the misfire only happens for a few minutes and then goes away.
New plugs, no fix. Swapped coil packs 3 and 1 to isolate the problem. Still misfires on 3. So this points me towards the injector. When I ohm tested it today, I touched the probes to the terminals and got a reading of 37 and then it worked its way down to 15.7 and then settled there. I think the 15 is normal, but should be be starting up so high? I've never tested an injector before so maybe that was a foolish question, but I just don't know. Can an injector be bad, even if it ohms properly?
I've been chasing this demon for weeks now and I have two more weeks to figure it out before I am supposed to take the 4runner on a fairly lengthy drive. Can anyone shed any light on this for me, or should I just bite the bullet and take it to a shop and bend over when the bill comes?
  Reply With Quote
Old 08-12-2012, 10:26 AM   #2
josh700 [OP] josh700 is offline
Junior Member
josh700 is on a distinguished road
Joined: Jun 2012, #80899
Gender: Male
Posts: 10
josh700's Tacoma Gallery
Replaced injector, problem solved
  Reply With Quote
Old 09-06-2012, 11:52 PM   #3
Taco Schlagzeuger
907doublebass is on a distinguished road
Army: Disabled Vet, former truck driver(88M) of 377th and 11th HET
Joined: May 2012, #78812
Location: Kodiak,Alaska
Gender: Male
Posts: 16
907doublebass's Tacoma Gallery
Had that same problem with my 99 limited, cylinder 1 misfire. Injector was replaced and gas tank was seafoamed, still threw the misfire code. Finally my wife noticed the rubber fuel hose leading to the steel fuel line on the injector was cracked, rotted, and leaking fuel. 2 bucks for a new 12" piece of 1/4 inch hose from NAPA later, problem solved. Bottomline...check all the hoses for cracks and whatnot, any air or off- pressure causes that engine to throw a fit like my 2 year old. Glad to hear you fixed it. Regards,
  Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
Cylinder misfire 2 and 3 random misfire. Meangene Technical Chat 4 12-12-2012 04:58 PM
2.7 misfire help! evansjos 1st Gen. Tacomas 12 02-28-2012 02:31 AM
misfire help MrMackey89 2nd Gen. Tacomas 0 11-02-2011 04:58 PM
bumming with misfire gofas 1st Gen. Tacomas 1 05-22-2011 06:42 AM
Misfire toyotadan 1st Gen. Tacomas 5 07-10-2010 12:13 AM


Copyright © 2014 Tacoma Forum. Tacoma World is not owned by, or affiliated with Toyota Motor Corporation.