SCRunner12's 4Runner Limited

Go Back   Tacoma World Forums > Tacoma Discussion > 4Runners

Notices

1986 4runner engine will not idle please help!

Reply
 
Thread Tools Search this Thread
Old 04-02-2013, 05:07 AM   #1
sbarn5390 [OP] sbarn5390 is offline
Junior Member
sbarn5390 is on a distinguished road
Name: Seth
Joined: Aug 2012, #85216
Location: Sylva,NC
Gender: Male
Posts: 24
sbarn5390's Tacoma Gallery
1986 4runner engine will not idle please help!

Alright so here we go I noticed that my 4runner was starting to run a little warm the past few days and decided that it was time to look into the cooling system a little bit. My 4runner is an 86 22-re

I have since replaced the following:
Thermostat
All radiator hoses
Water pump
and lastly head gasket.

I replaced all the of the parts in that order after diagnosing that they were of no help keeping the engine cool. After replacing the head gasket I had the head professionally machined and completely gone through and rebuilt. I have put all the parts back together set the timing and now it will not idle. I have to keep giving it just a little throttle to keep it to where it wants to idle. I didn't take anything off or disconnect anything other than what was needed to take the intake off in order for me to complete the head gasket project. The engine will rev like no other now and is very strong since the rebuild but as I have stated it will not idle it just chokes itself out. Any help would be greatly appreciated I am just confused as to what would be the cause of this as I have never heard of this problem. Thanks in advance!
  Reply With Quote
Old 04-02-2013, 05:25 AM   #2
Senior Member
hetkind is one of the sharper tools in the shedhetkind is one of the sharper tools in the shedhetkind is one of the sharper tools in the shedhetkind is one of the sharper tools in the shedhetkind is one of the sharper tools in the shedhetkind is one of the sharper tools in the shedhetkind is one of the sharper tools in the shedhetkind is one of the sharper tools in the shedhetkind is one of the sharper tools in the shedhetkind is one of the sharper tools in the shedhetkind is one of the sharper tools in the shed
Army: Defense Contract Management Agency
Name: Howard
Joined: Feb 2011, #50679
Location: Johnson City
Gender: Male
Posts: 1,038
hetkind's Tacoma Gallery
I would look at valve clearances and vacuum leaks...and I would also verify ignition timing.

As for cooling, have you EVER replaced the fan clutch?

Now is the 86 carb or FI?

Howard
  Reply With Quote
Old 04-02-2013, 05:35 AM   #3
I'll be your huckleberry!
Millertime187 is one of the sharper tools in the shedMillertime187 is one of the sharper tools in the shedMillertime187 is one of the sharper tools in the shedMillertime187 is one of the sharper tools in the shedMillertime187 is one of the sharper tools in the shedMillertime187 is one of the sharper tools in the shedMillertime187 is one of the sharper tools in the shedMillertime187 is one of the sharper tools in the shedMillertime187 is one of the sharper tools in the shedMillertime187 is one of the sharper tools in the shedMillertime187 is one of the sharper tools in the shed
 
Millertime187's Avatar
Army: Iraq vet
Name: David
Joined: Sep 2012, #87698
Location: Clay City, KY
Age: 31
Gender: Male
Posts: 1,901
Millertime187's Tacoma Gallery
Quote:
Originally Posted by hetkind View Post
I would look at valve clearances and vacuum leaks...and I would also verify ignition timing.

As for cooling, have you EVER replaced the fan clutch?

Now is the 86 carb or FI?

Howard
+1

check your vacume hoses!
  Reply With Quote
Old 04-02-2013, 05:50 AM   #4
sbarn5390 [OP] sbarn5390 is offline
Junior Member
sbarn5390 is on a distinguished road
Name: Seth
Joined: Aug 2012, #85216
Location: Sylva,NC
Gender: Male
Posts: 24
sbarn5390's Tacoma Gallery
I have checked for leaks and was able to set the correct valve clearance it will run smooth and very quiet since the rebuild but just wont hold an idle I am almost certain that the timing is set properly because while I am reving it and holding a little throttle to it nothing seems out of the ordinary but once I left off the throttle it sputters then dies. Also to answer the question 86 is a fuel injected.
  Reply With Quote
Old 04-02-2013, 06:19 AM   #5
I'll be your huckleberry!
Millertime187 is one of the sharper tools in the shedMillertime187 is one of the sharper tools in the shedMillertime187 is one of the sharper tools in the shedMillertime187 is one of the sharper tools in the shedMillertime187 is one of the sharper tools in the shedMillertime187 is one of the sharper tools in the shedMillertime187 is one of the sharper tools in the shedMillertime187 is one of the sharper tools in the shedMillertime187 is one of the sharper tools in the shedMillertime187 is one of the sharper tools in the shedMillertime187 is one of the sharper tools in the shed
 
Millertime187's Avatar
Army: Iraq vet
Name: David
Joined: Sep 2012, #87698
Location: Clay City, KY
Age: 31
Gender: Male
Posts: 1,901
Millertime187's Tacoma Gallery
is it pulsing or just wont idle? have you tried turning idle up a little?(50 or so RPMS)
if the timing was off it should run funny not just no idle?
  Reply With Quote
Old 04-02-2013, 06:46 AM   #6
sbarn5390 [OP] sbarn5390 is offline
Junior Member
sbarn5390 is on a distinguished road
Name: Seth
Joined: Aug 2012, #85216
Location: Sylva,NC
Gender: Male
Posts: 24
sbarn5390's Tacoma Gallery
It has no idle at all just burns what fuel I guess is left to burn after letting off throttle then dies. I havent tried turning up the idle yet I am just confused as to why it would be acting like this now if I hadn't messed with anything other than having the head rebuilt and installing new gaskets ??
  Reply With Quote
Old 04-02-2013, 06:47 AM   #7
Senior Member
stroked383z has a spectacular aura aboutstroked383z has a spectacular aura about
Joined: Mar 2013, #100276
Gender: Male
Posts: 129
stroked383z's Tacoma Gallery
sounds like vacuum leak. checked fuel filter as well?
  Reply With Quote
Old 04-02-2013, 06:57 AM   #8
sbarn5390 [OP] sbarn5390 is offline
Junior Member
sbarn5390 is on a distinguished road
Name: Seth
Joined: Aug 2012, #85216
Location: Sylva,NC
Gender: Male
Posts: 24
sbarn5390's Tacoma Gallery
I sprayed around all my gaskets to see if I had a leak there but I will check with the vac lines but I am pretty sure I am all good there as well but I will double check to make sure. I haven't checked the fuel filter but would this be a problem since I am able to rev it and it will continue to run just needs assistance with idle like I have to add about 500rpm to throttle to keep it idling
  Reply With Quote
Old 04-02-2013, 07:00 AM   #9
I'll be your huckleberry!
Millertime187 is one of the sharper tools in the shedMillertime187 is one of the sharper tools in the shedMillertime187 is one of the sharper tools in the shedMillertime187 is one of the sharper tools in the shedMillertime187 is one of the sharper tools in the shedMillertime187 is one of the sharper tools in the shedMillertime187 is one of the sharper tools in the shedMillertime187 is one of the sharper tools in the shedMillertime187 is one of the sharper tools in the shedMillertime187 is one of the sharper tools in the shedMillertime187 is one of the sharper tools in the shed
 
Millertime187's Avatar
Army: Iraq vet
Name: David
Joined: Sep 2012, #87698
Location: Clay City, KY
Age: 31
Gender: Male
Posts: 1,901
Millertime187's Tacoma Gallery
If they done head work than its possible they have a vacuum line crossed or kinked. It doesn't take much to interrupt they vacuum system. It really sounds like vacuum if it idle before work. if truck is running good other than idle I'd start checking vacuum lines.
  Reply With Quote
Old 04-02-2013, 07:02 AM   #10
sbarn5390 [OP] sbarn5390 is offline
Junior Member
sbarn5390 is on a distinguished road
Name: Seth
Joined: Aug 2012, #85216
Location: Sylva,NC
Gender: Male
Posts: 24
sbarn5390's Tacoma Gallery
Thanks for all the help everyone! I will go and double check all my vac lines this seriously has me confused as to why it worked perfectly before even though the head was in bad shape and now that I have all new parts it runs like crap
  Reply With Quote
Old 04-02-2013, 07:16 AM   #11
Senior Member
stroked383z has a spectacular aura aboutstroked383z has a spectacular aura about
Joined: Mar 2013, #100276
Gender: Male
Posts: 129
stroked383z's Tacoma Gallery
Also pull off the oil fill cap... check to see if there's blowby (air pressure coming out of the oil fill tube). Still sounds like a vacuum line issue to me though
  Reply With Quote
Old 04-02-2013, 07:27 AM   #12
sbarn5390 [OP] sbarn5390 is offline
Junior Member
sbarn5390 is on a distinguished road
Name: Seth
Joined: Aug 2012, #85216
Location: Sylva,NC
Gender: Male
Posts: 24
sbarn5390's Tacoma Gallery
Alright I will check all this once I am able to get back to my shop where my 4runner is located.
  Reply With Quote
Old 04-02-2013, 08:33 AM   #13
Senior Member
hetkind is one of the sharper tools in the shedhetkind is one of the sharper tools in the shedhetkind is one of the sharper tools in the shedhetkind is one of the sharper tools in the shedhetkind is one of the sharper tools in the shedhetkind is one of the sharper tools in the shedhetkind is one of the sharper tools in the shedhetkind is one of the sharper tools in the shedhetkind is one of the sharper tools in the shedhetkind is one of the sharper tools in the shedhetkind is one of the sharper tools in the shed
Army: Defense Contract Management Agency
Name: Howard
Joined: Feb 2011, #50679
Location: Johnson City
Gender: Male
Posts: 1,038
hetkind's Tacoma Gallery
heck you are almost local to me, I live an hour north of Asheville...I would look at the quality of each vacuum line and where it terminate, it could be that a vacuum line got unhooked at the other end...or a dashpot or somesuch got damaged.

Also, turn you idle up while you trouble shoot, the engine with a good sealing valves needs a far different fuel/air mixture now.

And one last thing, I had a idle issue on the same motor that was VERY hard to trouble shoot and it was a bad coil, so make sure all your electrical grounds are good and double check your coil, coil grounds and secondary wiring.

Can you stick a vacuum gage on the motor and watch it while someone else keep the motor running, just above idle?

And could this be as simple as nothing more than a throttle cable adjustment?

Howard
  Reply With Quote
Old 04-02-2013, 09:30 AM   #14
sbarn5390 [OP] sbarn5390 is offline
Junior Member
sbarn5390 is on a distinguished road
Name: Seth
Joined: Aug 2012, #85216
Location: Sylva,NC
Gender: Male
Posts: 24
sbarn5390's Tacoma Gallery
Yeah I live about an hour west of Asheville...I will check all the lines and make sure that they are connected and not damaged. Hopefully it is something as simple as turning up my idle speed a hair I mean I just barely have to move the throttle in order to keep it running at what I would consider to be a normal idle I mean other than that this thing is a real runner nnow with the head rebuilt. A friend that works on these engines says he hasn't had such a quick rev response like this ever.
  Reply With Quote
Old 04-03-2013, 03:35 PM   #15
sbarn5390 [OP] sbarn5390 is offline
Junior Member
sbarn5390 is on a distinguished road
Name: Seth
Joined: Aug 2012, #85216
Location: Sylva,NC
Gender: Male
Posts: 24
sbarn5390's Tacoma Gallery
Alright so I've checked all vacuum lines and adjusted the idle speed with no success at keeping an idle. Very stumped at this point to what could be wrong with it not wanting to keep an idle.
  Reply With Quote
Old 04-03-2013, 04:35 PM   #16
I'll be your huckleberry!
Millertime187 is one of the sharper tools in the shedMillertime187 is one of the sharper tools in the shedMillertime187 is one of the sharper tools in the shedMillertime187 is one of the sharper tools in the shedMillertime187 is one of the sharper tools in the shedMillertime187 is one of the sharper tools in the shedMillertime187 is one of the sharper tools in the shedMillertime187 is one of the sharper tools in the shedMillertime187 is one of the sharper tools in the shedMillertime187 is one of the sharper tools in the shedMillertime187 is one of the sharper tools in the shed
 
Millertime187's Avatar
Army: Iraq vet
Name: David
Joined: Sep 2012, #87698
Location: Clay City, KY
Age: 31
Gender: Male
Posts: 1,901
Millertime187's Tacoma Gallery
Quote:
Originally Posted by sbarn5390 View Post
Alright so I've checked all vacuum lines and adjusted the idle speed with no success at keeping an idle. Very stumped at this point to what could be wrong with it not wanting to keep an idle.
Is it running good besides the idle?
  Reply With Quote
Old 04-03-2013, 05:37 PM   #17
sbarn5390 [OP] sbarn5390 is offline
Junior Member
sbarn5390 is on a distinguished road
Name: Seth
Joined: Aug 2012, #85216
Location: Sylva,NC
Gender: Male
Posts: 24
sbarn5390's Tacoma Gallery
yeah runs real strong just no idle
  Reply With Quote
Old 04-03-2013, 06:28 PM   #18
I'll be your huckleberry!
Millertime187 is one of the sharper tools in the shedMillertime187 is one of the sharper tools in the shedMillertime187 is one of the sharper tools in the shedMillertime187 is one of the sharper tools in the shedMillertime187 is one of the sharper tools in the shedMillertime187 is one of the sharper tools in the shedMillertime187 is one of the sharper tools in the shedMillertime187 is one of the sharper tools in the shedMillertime187 is one of the sharper tools in the shedMillertime187 is one of the sharper tools in the shedMillertime187 is one of the sharper tools in the shed
 
Millertime187's Avatar
Army: Iraq vet
Name: David
Joined: Sep 2012, #87698
Location: Clay City, KY
Age: 31
Gender: Male
Posts: 1,901
Millertime187's Tacoma Gallery
If it idle good before head work I would look over what they done. i.e.- check intake make sure it's not cracked, throttle body, make sure there is no vacuum line missing... Just have to look an play.

Do you have RPM gauge? What is the RPM trying to idle?
  Reply With Quote
Old 04-04-2013, 06:33 AM   #19
I'll be your huckleberry!
Millertime187 is one of the sharper tools in the shedMillertime187 is one of the sharper tools in the shedMillertime187 is one of the sharper tools in the shedMillertime187 is one of the sharper tools in the shedMillertime187 is one of the sharper tools in the shedMillertime187 is one of the sharper tools in the shedMillertime187 is one of the sharper tools in the shedMillertime187 is one of the sharper tools in the shedMillertime187 is one of the sharper tools in the shedMillertime187 is one of the sharper tools in the shedMillertime187 is one of the sharper tools in the shed
 
Millertime187's Avatar
Army: Iraq vet
Name: David
Joined: Sep 2012, #87698
Location: Clay City, KY
Age: 31
Gender: Male
Posts: 1,901
Millertime187's Tacoma Gallery
Well thanks for the NEG REP whoever?
  Reply With Quote
Old 04-04-2013, 01:36 PM   #20
Senior Member
stroked383z has a spectacular aura aboutstroked383z has a spectacular aura about
Joined: Mar 2013, #100276
Gender: Male
Posts: 129
stroked383z's Tacoma Gallery
Did you check to see if you were getting blowby from the oil fill tube while the engine is running?
  Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
1986 4Runner for sale. Ready to wheel! Swimmerboy2112 Buy / Sell / Trade 33 10-15-2012 10:19 PM
Feeler: 1986 4Runner 4x4 Muy Grande Texas 7 06-22-2012 09:15 PM
serious engine trouble, loud engine rough idle...HELP! PVT Clark 2nd Gen. Tacomas 15 01-03-2012 03:55 PM
FS: 1986 SAS 4Runner RU55ELL Buy / Sell / Trade 3 02-05-2010 01:53 PM
1986 Toyota 4Runner justalilcrazy625 Toyota Trucks & SUVs 2 05-18-2009 03:07 AM


Copyright © 2014 Tacoma Forum. Tacoma World is not owned by, or affiliated with Toyota Motor Corporation.