Mike "Wuzzy121". Rest in peace, brother

Go Back   Tacoma World Forums > Tacoma Garage > Audio & Video

Notices

radio not working

Reply
 
Thread Tools Search this Thread
Old 09-16-2011, 09:10 PM   #1
mat [OP] mat is offline
Senior Member
mat is on a distinguished road
Joined: Nov 2010, #46468
Gender: Male
Posts: 127
mat's Tacoma Gallery
radio not working

ok so the other day my battery died, and when i tried to jump it all the lights would come on but it would not start, the battery was old so i figured id just go ahead and replace it, i did that but it still wouldnt work, so i go through and start checking fuses and realize that the alternator fuse was blown, so i replaced the fuse and now everything works except for my radio, i read that either the dome fuse or the acc fuse being blown could cause this so i checked both of them and they were fine, could any other fuses be blown.

Also when i was jumping it off a little wisp of smoke came out of the radio area

please help with this as i am clueless
  Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
Half Non Working Cb radio Anthony250 Buy / Sell / Trade - Other 0 01-24-2012 02:15 PM
Radio and Clock Stopped Working ttran 1st Gen. Tacomas 2 09-25-2011 07:25 PM
Radio controls on steering not working. EricGagne Off-Roading & Trails 7 08-13-2010 01:30 PM
Radio AVL seems to not be working 2010TACO 2nd Gen. Tacomas 2 01-01-2010 10:43 AM
Radio and clock stopped working. GunMetalSteak 2nd Gen. Tacomas 8 05-19-2008 08:16 AM


Copyright © 2014 Tacoma Forum. Tacoma World is not owned by, or affiliated with Toyota Motor Corporation.