Mike "Wuzzy121". Rest in peace, brother

Go Back   Tacoma World Forums > Tacoma Garage > Audio & Video

Notices

Possible fried head unit or bad speakers?

Reply
 
Thread Tools Search this Thread
Old 12-02-2012, 10:08 PM   #1
Junior Member
cornel.dupreez is on a distinguished road
Joined: Dec 2012, #92331
Location: Georgia
Gender: Male
Posts: 5
cornel.dupreez's Tacoma Gallery
Possible fried head unit or bad speakers?

So my battery went bad the other day and my truck wouldn't start so we tried jumping it from a Dodge RAM which still didn't work so we hooked it up to an industrial quick battery charger. Bad idea, smoke came out from my cab, not much but you could definitely see it coming from the dash. Eventually I bought a new battery and my truck started right up. The high voltage blew out both my front head lights and now I have bad static every time the base hits or if I have the volume turned up past 20.

If I adjust the balance however to only one side, the speakers on that side of the truck work fine no matter how loud. This applies to both sides.

Is this a bad head unit or something with the speakers, how much does a new head unit normally run?
  Reply With Quote
Old 12-02-2012, 10:25 PM   #2
It burns when I pee....
ABA180 is one of the sharper tools in the shedABA180 is one of the sharper tools in the shedABA180 is one of the sharper tools in the shedABA180 is one of the sharper tools in the shedABA180 is one of the sharper tools in the shedABA180 is one of the sharper tools in the shedABA180 is one of the sharper tools in the shedABA180 is one of the sharper tools in the shedABA180 is one of the sharper tools in the shedABA180 is one of the sharper tools in the shedABA180 is one of the sharper tools in the shed
 
ABA180's Avatar
Name: Chris
Joined: Oct 2012, #88520
Location: East Bridgewater MA
Age: 40
Gender: Male
Posts: 5,425
ABA180's Tacoma Gallery
I'd be inclined to blame the head unit. You've confirmed it's possible to get clean sound out of all the speakers, just not all at the same time, by flipping the balance.

You can get a decent head unit installed for $200 or less usually. Pioneer and Alpine have some good ones..I have a Kenwood myself. Depends on what features you want..
  Reply With Quote
Old 12-03-2012, 08:30 AM   #3
Junior Member
cornel.dupreez is on a distinguished road
Joined: Dec 2012, #92331
Location: Georgia
Gender: Male
Posts: 5
cornel.dupreez's Tacoma Gallery
Thanks for the quick reply, I think you're probably right about it being the head unit but if at all possible, I'd rather just see if I can fix it than having to buy a new one, I've already modded it by adding an auxiliary port, I'd like to not have to go through that whole process again. Doesn't the factory head units have 2 fuses in the back that can be replaced? I could be completely wrong, but I'm just hoping for the best haha
  Reply With Quote
Old 12-03-2012, 10:40 AM   #4
It burns when I pee....
ABA180 is one of the sharper tools in the shedABA180 is one of the sharper tools in the shedABA180 is one of the sharper tools in the shedABA180 is one of the sharper tools in the shedABA180 is one of the sharper tools in the shedABA180 is one of the sharper tools in the shedABA180 is one of the sharper tools in the shedABA180 is one of the sharper tools in the shedABA180 is one of the sharper tools in the shedABA180 is one of the sharper tools in the shedABA180 is one of the sharper tools in the shed
 
ABA180's Avatar
Name: Chris
Joined: Oct 2012, #88520
Location: East Bridgewater MA
Age: 40
Gender: Male
Posts: 5,425
ABA180's Tacoma Gallery
It might. I have my factory at home on my shelf, I will check tonight but that won't be till about 11pm EST. I'd be inclined to think if that's the case they wouldn't work at all but it is possible.

That said, did you add the USB or the 3.5mm aux? The reason I ask is aftermarket head units almost all come with at least one of those 2 nowadays so that wouldn't be an additional time/money expenditure if you change up.

My Kenwood has both USB and 3.5 aux on the front. I didn't really care b/c I don't use MP3 players but I know when I looked at radios summer 2011 I couldn't find one that didn't have at least one of the 2.
  Reply With Quote
Old 12-03-2012, 10:45 AM   #5
It burns when I pee....
ABA180 is one of the sharper tools in the shedABA180 is one of the sharper tools in the shedABA180 is one of the sharper tools in the shedABA180 is one of the sharper tools in the shedABA180 is one of the sharper tools in the shedABA180 is one of the sharper tools in the shedABA180 is one of the sharper tools in the shedABA180 is one of the sharper tools in the shedABA180 is one of the sharper tools in the shedABA180 is one of the sharper tools in the shedABA180 is one of the sharper tools in the shed
 
ABA180's Avatar
Name: Chris
Joined: Oct 2012, #88520
Location: East Bridgewater MA
Age: 40
Gender: Male
Posts: 5,425
ABA180's Tacoma Gallery
This happened to me some years ago with a Blaupunkt pull out..yes it was a while back haha. I thought it was my amp but turned out the right side of the radio was dead. The radio was 3 yrs old and about $650 new but I found it in a car my parents bought, for the $120 I already had into it plus an estimated $200 more I thought it best to buy a new radio without as many bells and whistles.

Oh yes, welcome to the forums!
  Reply With Quote
Old 12-03-2012, 08:49 PM   #6
It burns when I pee....
ABA180 is one of the sharper tools in the shedABA180 is one of the sharper tools in the shedABA180 is one of the sharper tools in the shedABA180 is one of the sharper tools in the shedABA180 is one of the sharper tools in the shedABA180 is one of the sharper tools in the shedABA180 is one of the sharper tools in the shedABA180 is one of the sharper tools in the shedABA180 is one of the sharper tools in the shedABA180 is one of the sharper tools in the shedABA180 is one of the sharper tools in the shed
 
ABA180's Avatar
Name: Chris
Joined: Oct 2012, #88520
Location: East Bridgewater MA
Age: 40
Gender: Male
Posts: 5,425
ABA180's Tacoma Gallery
I just pulled my radio out and looked at it. No fuses of any kind on the outside of it. Mine is the factory 2010 CD player (non-JBL).

That said, go into your fuse box and check your fuse for the radio. It's a longshot but I guess it's worth 2 minutes of time before you throw in the towel..
  Reply With Quote
Old 12-03-2012, 08:58 PM   #7
Member
uhmmmar15 is on a distinguished road
Name: Uhmmm
Joined: Dec 2012, #92297
Location: Texas
Gender: Male
Posts: 37
uhmmmar15's Tacoma Gallery
"blew out both front headlights" hahahaha! that sucks man hope it all works out for yah my buddy installed headlights once and just said fuck it and clamped some wires together next thing you know his blowing fuses left and right one day driving home he calls me and saids it smells like there is burning plastic the back of his headlight housing was all melted! Ha.
  Reply With Quote
Old 12-04-2012, 08:17 AM   #8
Junior Member
cornel.dupreez is on a distinguished road
Joined: Dec 2012, #92331
Location: Georgia
Gender: Male
Posts: 5
cornel.dupreez's Tacoma Gallery
Thanks everyone for the responses, I'll double check the fuse box to make sure no fuses are blown but, I from what it sounds like, I'll be looking for a new head unit soon. The aux input I installed was the 3.5 mm aux, cost about $3.00 for the actual input ring and that was about all the expenses I had. Installed a year and a half ago and haven't had any problems with it, perfect sound quality.
  Reply With Quote
Old 12-04-2012, 01:26 PM   #9
It burns when I pee....
ABA180 is one of the sharper tools in the shedABA180 is one of the sharper tools in the shedABA180 is one of the sharper tools in the shedABA180 is one of the sharper tools in the shedABA180 is one of the sharper tools in the shedABA180 is one of the sharper tools in the shedABA180 is one of the sharper tools in the shedABA180 is one of the sharper tools in the shedABA180 is one of the sharper tools in the shedABA180 is one of the sharper tools in the shedABA180 is one of the sharper tools in the shed
 
ABA180's Avatar
Name: Chris
Joined: Oct 2012, #88520
Location: East Bridgewater MA
Age: 40
Gender: Male
Posts: 5,425
ABA180's Tacoma Gallery
Good luck, keep us posted.

Honestly, I think you'll find a good priced unit that you'll be happy with and probably happier than stock..so perhaps there's some good to come of it
  Reply With Quote
Old 12-05-2012, 04:54 PM   #10
Junior Member
cornel.dupreez is on a distinguished road
Joined: Dec 2012, #92331
Location: Georgia
Gender: Male
Posts: 5
cornel.dupreez's Tacoma Gallery
I'm not sure what anyone can make of this but, sometimes when I start my truck the radio works perfect with flawless sound, then other times when I start it I can't go past 15 on the volume without hearing a ton of feed back... any ideas?
  Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
speakers or head unit? rogerkamp8817 Audio & Video 13 08-24-2011 11:32 AM
2010 Head Unit and Speakers Gossamer Buy / Sell / Trade 0 03-04-2011 07:32 PM
aftermarket head unit and new speakers 4421.frank 1st Gen. Tacomas 6 05-21-2010 11:51 AM
Head Unit or Speakers First? TacomaGus Audio & Video 14 12-31-2009 08:45 AM
New Speakers installed with stock head unit. Winger12003 Audio & Video 8 08-27-2009 08:17 AM


Copyright © 2014 Tacoma Forum. Tacoma World is not owned by, or affiliated with Toyota Motor Corporation.