Mike "Wuzzy121". Rest in peace, brother

Go Back   Tacoma World Forums > Tacoma Garage > Audio & Video

Notices

Blown Amp?

Reply
 
Thread Tools Search this Thread
Old 07-02-2013, 12:55 PM   #1
thebigsmit [OP] thebigsmit is offline
Useful Idiot
thebigsmit is on a distinguished road
 
thebigsmit's Avatar
Name: Brent
Joined: Jan 2013, #95107
Location: South Carolina
Gender: Guy
Posts: 94
thebigsmit's Tacoma Gallery
Blown Amp?

This issue isnt with my truck, its with my boat. I have a 2006 Sea Ray with a Clarion stereo system. It has a source unit (radio), amplifier, a sub, and about 4 speakers. I'm almost certain the amp is blown. The radio comes on but the amp it self does not. Checked every fuse, I have also confirmed there is 12v power all the way up the the amp. It just doesnt freakin turn on. Has to be blown amp? Also, when the speakers were working, they sounded very staticky and crackly.
  Reply With Quote
Old 07-03-2013, 08:25 PM   #2
Senior Member
Tj0hn is one of the sharper tools in the shedTj0hn is one of the sharper tools in the shedTj0hn is one of the sharper tools in the shedTj0hn is one of the sharper tools in the shedTj0hn is one of the sharper tools in the shedTj0hn is one of the sharper tools in the shedTj0hn is one of the sharper tools in the shedTj0hn is one of the sharper tools in the shedTj0hn is one of the sharper tools in the shedTj0hn is one of the sharper tools in the shedTj0hn is one of the sharper tools in the shed
 
Tj0hn's Avatar
Joined: Jun 2013, #106827
Location: Florida
Gender: Male
Posts: 231
Tj0hn's Tacoma Gallery
If you are positive that there is 12V at the wire going into the amp then do this.

Take a jumper wire and jump from the "positive" into the amp over to the "remote wire in" on the amp. Make sure you have a solid ground....if it doesn't come on then, it's prolly shot.

If it does come on with the jumper wire, then your remote wire from your deck is shot. Just find another source that comes on with the key, tap into it and run that wire into the remote wire on the amp.
  Reply With Quote
Old 07-03-2013, 08:44 PM   #3
Thin Blue Line
ProForce is one of the sharper tools in the shedProForce is one of the sharper tools in the shedProForce is one of the sharper tools in the shedProForce is one of the sharper tools in the shedProForce is one of the sharper tools in the shedProForce is one of the sharper tools in the shedProForce is one of the sharper tools in the shedProForce is one of the sharper tools in the shedProForce is one of the sharper tools in the shedProForce is one of the sharper tools in the shedProForce is one of the sharper tools in the shed
 
ProForce's Avatar
Name: Anthony
Joined: Oct 2009, #24205
Location: SoCal-Ontario
Age: 27
Gender: Male
Posts: 5,043
ProForce's Tacoma Gallery
Do you have a good ground? Boats are extremely difficult to get good grounds because they are mostly fiberglass. Most boat amps have to have power and ground run straight to battery.

And x2 on the remote wire. You should have 3 connections for amp power:
12v battery with its own fuse
12v remote turn on to the radio
(-) ground probably to battery.

Check all 3. Also if a speaker is grounded out or blown it is possible that it is setting your amp into protection mode and your not realizing it.

Also, replace the main amp fuse on the power line. Sometimes they appear to be good and even test good for 12v and continuity but they may be broken and not allowing any significant current to travel through thus giving a false reading for power. Check the amp itself for small fuses on it. Many amps have 2 or more fuses on the amp itself. All have to be checked. Good luck.
  Reply With Quote
Old 07-03-2013, 08:48 PM   #4
It burns when I pee....
ABA180 is one of the sharper tools in the shedABA180 is one of the sharper tools in the shedABA180 is one of the sharper tools in the shedABA180 is one of the sharper tools in the shedABA180 is one of the sharper tools in the shedABA180 is one of the sharper tools in the shedABA180 is one of the sharper tools in the shedABA180 is one of the sharper tools in the shedABA180 is one of the sharper tools in the shedABA180 is one of the sharper tools in the shedABA180 is one of the sharper tools in the shed
 
ABA180's Avatar
Name: Chris
Joined: Oct 2012, #88520
Location: East Bridgewater MA
Age: 41
Gender: Male
Posts: 5,888
ABA180's Tacoma Gallery
Easy way is if you have an extra speaker and some wire, run the speaker right to the deck. If the speaker plays, bum amp or amp wiring.

Did you check the fuses on the amp and the power wire?
  Reply With Quote
Old 07-03-2013, 08:54 PM   #5
Senior Member
ANT2013taco is one of the sharper tools in the shedANT2013taco is one of the sharper tools in the shedANT2013taco is one of the sharper tools in the shedANT2013taco is one of the sharper tools in the shedANT2013taco is one of the sharper tools in the shedANT2013taco is one of the sharper tools in the shedANT2013taco is one of the sharper tools in the shedANT2013taco is one of the sharper tools in the shedANT2013taco is one of the sharper tools in the shedANT2013taco is one of the sharper tools in the shedANT2013taco is one of the sharper tools in the shed
 
ANT2013taco's Avatar
Coast Guard:
Joined: Apr 2013, #103007
Location: McAllen Texas
Age: 46
Gender: Male
Posts: 171
ANT2013taco's Tacoma Gallery
Definitely make sure you have ground to the battery. Boats are notorious for grounding issues, especially in the engine compartment. I have a Crownline and found the main ground corroded after only 2 years.
  Reply With Quote
Old 07-04-2013, 11:52 AM   #6
thebigsmit [OP] thebigsmit is offline
Useful Idiot
thebigsmit is on a distinguished road
 
thebigsmit's Avatar
Name: Brent
Joined: Jan 2013, #95107
Location: South Carolina
Gender: Guy
Posts: 94
thebigsmit's Tacoma Gallery
Quote:
Originally Posted by ABA180 View Post
Easy way is if you have an extra speaker and some wire, run the speaker right to the deck. If the speaker plays, bum amp or amp wiring.

Did you check the fuses on the amp and the power wire?
Fuses good. Speakers wire directly to the amp. No speaker outputs on the deck.

Quote:
If you are positive that there is 12V at the wire going into the amp then do this.
I am absolutely 100 million percent sure I'm getting 12v all the way up to the amp. Literally every other piece of equipment that draws power on my boat works, so its hard to believe its the ground because they all ground back to the neg battery terminal.

Quote:
And x2 on the remote wire. You should have 3 connections for amp power:
12v battery with its own fuse
12v remote turn on to the radio
(-) ground probably to battery.
The amp is actually double fused, one 40amp near the battery and another 40amp actually inside the amp. Both are good. I will try to jump the remote after it stops raining.

I am almost certain the amp is completely shot though, the speakers were sounding very crackly and staticky right up until it just quit working.
  Reply With Quote
Old 07-04-2013, 12:50 PM   #7
thebigsmit [OP] thebigsmit is offline
Useful Idiot
thebigsmit is on a distinguished road
 
thebigsmit's Avatar
Name: Brent
Joined: Jan 2013, #95107
Location: South Carolina
Gender: Guy
Posts: 94
thebigsmit's Tacoma Gallery
Update: I got an extra car battery I had and wired the amp's ground, hot, and remote to the battery. It turns on. I traced it back to the remote wire on the boats wiring, it was corroded. New wire in place. Though only the right side speakers work. The deck and amp is connected via a regular L/R (red and white) audio cable. I think I screwed up some of the knobs on the amp while I was fiddling around. Anyways thanks for the help fellas.
  Reply With Quote
Old 07-04-2013, 07:44 PM   #8
Senior Member
Tj0hn is one of the sharper tools in the shedTj0hn is one of the sharper tools in the shedTj0hn is one of the sharper tools in the shedTj0hn is one of the sharper tools in the shedTj0hn is one of the sharper tools in the shedTj0hn is one of the sharper tools in the shedTj0hn is one of the sharper tools in the shedTj0hn is one of the sharper tools in the shedTj0hn is one of the sharper tools in the shedTj0hn is one of the sharper tools in the shedTj0hn is one of the sharper tools in the shed
 
Tj0hn's Avatar
Joined: Jun 2013, #106827
Location: Florida
Gender: Male
Posts: 231
Tj0hn's Tacoma Gallery
Boom. You are welcome. Glad you got it.
  Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
Blown speakers or bad amp? rondog Audio & Video 22 11-30-2012 05:22 PM
Blown amp pinktaco808 Audio & Video 15 01-17-2012 08:33 AM
Mind = Blown Large Off-Topic Discussion 13 11-27-2011 09:38 AM
blown shocks 4ari trd Suspension 7 12-21-2009 11:06 PM


Copyright © 2014 Tacoma Forum. Tacoma World is not owned by, or affiliated with Toyota Motor Corporation.