Tacoma World Forums

Tacoma World Forums (http://www.tacomaworld.com/forum/)
-   General Automotive (http://www.tacomaworld.com/forum/general-automotive/)
-   -   pain in my @$$ (http://www.tacomaworld.com/forum/general-automotive/40873-pain-my.html)

Timicha 06-13-2009 03:34 AM

pain in my @$$
 
hey everyone,
So before i got out of school i noticed that my front tires would not turn at all when i had the front end picked up. it took all my strength to turn them. well i got done with college on thursday. i had to drive 300 miles home with them like that and tonight i jacked my front end up and found that i couldn't turn my tires at all no matter how hard i tried. I even thew a bar on there and couldnt spin them. well i tore them apart and it turns out that BOTH of my calipers are froze up full of rust and mud.... they couldnt happen just one at a time, they had to both freeze at the same time. so now im working on getting them to work and trying to avoid buying new ones but i know eventually ill have too. i just need to get back to work so i can get some money..
just thought i would share haha.

Burgman 06-13-2009 03:36 AM

good luck man

Janster 06-13-2009 04:53 AM

You drove 300 miles like that without any problems? No smoke....no burning smell...??

You're probably gonna need some rotors and check your bearings also.

Good Luck

Timicha 06-14-2009 02:22 PM

Ya but i think they loosened up or somthing because i still got 20 mpg on my scan guage but when i got home and jacked it up they were stuck so i dunno. my truck didn't have any problems no smoke or nothin and was running at normal temp

Quote:

Originally Posted by Janster (Post 682625)
You drove 300 miles like that without any problems? No smoke....no burning smell...??

You're probably gonna need some rotors and check your bearings also.

Good Luck



All times are GMT -7. The time now is 02:51 AM.