Mike "Wuzzy121". Rest in peace, brother

Go Back   Tacoma World Forums > Tacoma Garage > Lighting

Notices

Turn Signal does not work

Reply
 
Thread Tools Search this Thread
Old 12-13-2010, 05:26 PM   #1
FooD2000 [OP] FooD2000 is offline
Junior Member
FooD2000 is on a distinguished road
 
FooD2000's Avatar
Joined: May 2008, #6395
Location: San Diego
Gender: Male
Posts: 12
FooD2000's Tacoma Gallery
Turn Signal does not work

1996 Tacoma, I did a radio install (blew 1 fuse to dome light) but after, my signals don't work:

- My hazards work (the arrows light up as well)
- Checked fuses both place inside the car and under hood
- I've switch the other relays and found no change.
- replaced flasher (part #ep 35 from autozone).
- bought a used junk yard turn signal switch
- i've also pulled my radio to look for exposed wires, looked fine from what i could tell.

Any Suggestions or ideas?

Thanks!
  Reply With Quote
Old 12-15-2010, 08:52 AM   #2
Senior Member
EnolaGaia is one of the sharper tools in the shedEnolaGaia is one of the sharper tools in the shedEnolaGaia is one of the sharper tools in the shedEnolaGaia is one of the sharper tools in the shedEnolaGaia is one of the sharper tools in the shedEnolaGaia is one of the sharper tools in the shedEnolaGaia is one of the sharper tools in the shedEnolaGaia is one of the sharper tools in the shedEnolaGaia is one of the sharper tools in the shedEnolaGaia is one of the sharper tools in the shedEnolaGaia is one of the sharper tools in the shed
Joined: Sep 2006, #9
Location: Midwest USA
Gender: Male
Posts: 1,136
EnolaGaia's Tacoma Gallery
A blown 15A HORN fuse might explain it ...
  Reply With Quote
Old 12-15-2010, 03:37 PM   #3
FooD2000 [OP] FooD2000 is offline
Junior Member
FooD2000 is on a distinguished road
 
FooD2000's Avatar
Joined: May 2008, #6395
Location: San Diego
Gender: Male
Posts: 12
FooD2000's Tacoma Gallery
Quote:
Originally Posted by EnolaGaia View Post
A blown 15A HORN fuse might explain it ...
Yea i triple checked the fuses, all of them are good (under the dash and hood) and i've also switch the relays around and nothing changes so they're good.

I checked out the wires and i don't think i have any shorting anywhere?

ONly think i can think of is the turn signal switch which is weird that it'd go bad after the radio install...
  Reply With Quote
Old 12-29-2010, 07:12 PM   #4
FooD2000 [OP] FooD2000 is offline
Junior Member
FooD2000 is on a distinguished road
 
FooD2000's Avatar
Joined: May 2008, #6395
Location: San Diego
Gender: Male
Posts: 12
FooD2000's Tacoma Gallery
So i went to the junk yard and replaced the turn signal switch, still no turn signals and i went back into the radio to make sure no wire is exposed or loose wires grounding out.

also tried replacing the flasher underneath the dash (ep 35 part from autozone).

Any ideas?
  Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
Turn Signal Wont Turn OFF!! priebedog Lighting 5 01-03-2014 08:48 PM
Turn signal doesn't work, hazards do! FooD2000 Technical Chat 7 12-29-2010 10:18 PM
turn signal gymclaws Technical Chat 4 11-16-2010 07:50 PM
Did my Parking light to Turn signal / Turn signal to Fog light mod today Desiel 1st Gen. Tacomas 20 09-17-2010 08:55 PM
Left front turn signal will not work SMG26 2nd Gen. Tacomas 7 01-05-2010 02:12 PM


Copyright © 2014 Tacoma Forum. Tacoma World is not owned by, or affiliated with Toyota Motor Corporation.