Mike "Wuzzy121". Rest in peace, brother

Go Back   Tacoma World Forums > Tacoma Garage > Lighting

Notices

turn signals not working

Reply
 
Thread Tools Search this Thread
Old 06-05-2012, 02:10 PM   #1
Junior Member
justin ensor is on a distinguished road
Joined: Jun 2012, #80141
Gender: Male
Posts: 1
justin ensor's Tacoma Gallery
turn signals not working

I've got a 1983 Tacoma four wheel drive and just recently all the turn signals stopped working so far I've changed all the bulbs checked the fuses, could it be a wiring issue or a bad relay or maybe the turn signal switch?
  Reply With Quote
Old 06-05-2012, 10:27 PM   #2
Senior Member
joes06tacoma is one of the sharper tools in the shedjoes06tacoma is one of the sharper tools in the shedjoes06tacoma is one of the sharper tools in the shedjoes06tacoma is one of the sharper tools in the shedjoes06tacoma is one of the sharper tools in the shedjoes06tacoma is one of the sharper tools in the shedjoes06tacoma is one of the sharper tools in the shedjoes06tacoma is one of the sharper tools in the shedjoes06tacoma is one of the sharper tools in the shedjoes06tacoma is one of the sharper tools in the shedjoes06tacoma is one of the sharper tools in the shed
Name: Joe
Joined: Jan 2010, #28588
Location: Central Coast, CA
Gender: Male
Posts: 3,073
joes06tacoma's Tacoma Gallery
Could be a lot of things. Do the hazards work? Not familiar with the older trucks, but there might be two flasher relays.....one for the signals, one for the hazards. If that's the case, might try swapping them.
  Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
turn signals not working, airbag light on, and speedo not working.....:( Jeremiah Stewart Lighting 7 07-01-2014 11:57 AM
Side turn signals westport toyota 2nd Gen. Tacomas 18 01-20-2014 03:14 PM
Alternating Turn Signals DriverSound 2nd Gen. Tacomas 1 04-28-2009 10:21 AM
Turn signals mod wbhvacer 2nd Gen. Tacomas 6 05-18-2008 09:25 AM
PLEASE HELP - No Turn Signals 05PreRunner 2nd Gen. Tacomas 12 02-23-2008 03:49 PM


Copyright © 2014 Tacoma Forum. Tacoma World is not owned by, or affiliated with Toyota Motor Corporation.