Mike "Wuzzy121". Rest in peace, brother

Go Back   Tacoma World Forums > Tacoma Garage > Lighting

Notices

LED Turn Signals Bulbs

Reply
 
Thread Tools Search this Thread
Old 09-23-2009, 11:17 AM   #1
SMG26 [OP] SMG26 is offline
Senior Member
SMG26 has a brilliant futureSMG26 has a brilliant futureSMG26 has a brilliant futureSMG26 has a brilliant futureSMG26 has a brilliant futureSMG26 has a brilliant futureSMG26 has a brilliant futureSMG26 has a brilliant futureSMG26 has a brilliant futureSMG26 has a brilliant futureSMG26 has a brilliant future
Name: Steve
Joined: Aug 2008, #8786
Location: Woodstock,GA
Gender: Male
Posts: 186
SMG26's Tacoma Gallery
LED Turn Signals Bulbs

I just finished putting in my LED flasher that I got from superbrightleds.com and some bulbs. I turned the truck on and tested to see if the turn signals work. The front signals do not work but the rear signals do. I even tried putting the old 3157 stock bulbs in and they would not even flash. Any help would be great.
  Reply With Quote
Old 09-23-2009, 11:56 AM   #3
SMG26 [OP] SMG26 is offline
Senior Member
SMG26 has a brilliant futureSMG26 has a brilliant futureSMG26 has a brilliant futureSMG26 has a brilliant futureSMG26 has a brilliant futureSMG26 has a brilliant futureSMG26 has a brilliant futureSMG26 has a brilliant futureSMG26 has a brilliant futureSMG26 has a brilliant futureSMG26 has a brilliant future
Name: Steve
Joined: Aug 2008, #8786
Location: Woodstock,GA
Gender: Male
Posts: 186
SMG26's Tacoma Gallery
Yeah checked all fuses and none are blow any other suggestions
  Reply With Quote
Old 09-23-2009, 12:02 PM   #4
SMG26 [OP] SMG26 is offline
Senior Member
SMG26 has a brilliant futureSMG26 has a brilliant futureSMG26 has a brilliant futureSMG26 has a brilliant futureSMG26 has a brilliant futureSMG26 has a brilliant futureSMG26 has a brilliant futureSMG26 has a brilliant futureSMG26 has a brilliant futureSMG26 has a brilliant futureSMG26 has a brilliant future
Name: Steve
Joined: Aug 2008, #8786
Location: Woodstock,GA
Gender: Male
Posts: 186
SMG26's Tacoma Gallery
Also I had the DRL jumper and harness in there when I bought the truck would this maybe the problem.
  Reply With Quote
Old 09-23-2009, 12:03 PM   #5
Senior Member
Rollinn is a jewel in the roughRollinn is a jewel in the roughRollinn is a jewel in the roughRollinn is a jewel in the rough
Joined: Jul 2009, #19274
Location: Vegas
Gender: Male
Posts: 259
Rollinn's Tacoma Gallery
I had the exact same problem when I went to install led bulbs up front.. They didnto work, I switched back to the stock ones and they worked.. I think they draw a different amount of amperage possibly.. I think if you put ALL the bulbs back to stock they would work again..
But am unsure of why they wouldnt work..
  Reply With Quote
Old 09-27-2009, 07:55 PM   #7
Senior Member
Viet2100 is one of the sharper tools in the shedViet2100 is one of the sharper tools in the shedViet2100 is one of the sharper tools in the shedViet2100 is one of the sharper tools in the shedViet2100 is one of the sharper tools in the shedViet2100 is one of the sharper tools in the shedViet2100 is one of the sharper tools in the shedViet2100 is one of the sharper tools in the shedViet2100 is one of the sharper tools in the shedViet2100 is one of the sharper tools in the shedViet2100 is one of the sharper tools in the shed
 
Viet2100's Avatar
Name: Viet
Joined: Jun 2007, #1930
Location: Delray Beach, FL
Age: 25
Gender: Male
Posts: 2,520
Viet2100's Tacoma Gallery
Send a message via Skype™ to Viet2100
Quote:
Originally Posted by SRQ TACO View Post
You have the bulb in backwards. LED's are only polar one way I'm pretty sure.
He stated that even the stock bulbs don't work.

OP, try looking for a blown fuse.
  Reply With Quote
Old 09-27-2009, 08:06 PM   #8
Senior Member
PPD934 is on a distinguished road
Joined: Feb 2008, #4621
Location: Western Kentucky
Posts: 142
PPD934's Tacoma Gallery
I have changed many motorcycles bulbs to led... on all of them I had to install a load equalizer on them in order to get them to flash... you have to be really careful with them though disconnect the battery or you wil burn the equalizer out.....
  Reply With Quote
Old 09-30-2009, 09:58 PM   #9
Victory through supreme firepower!
GUNNERGREEN is on a distinguished road
 
GUNNERGREEN's Avatar
Name: James
Joined: Jul 2009, #20268
Location: Georgia
Gender: Male
Posts: 34
GUNNERGREEN's Tacoma Gallery
Send a message via Yahoo to GUNNERGREEN
Led's draw alot less amperage than regular bulbs. The flash relay will not function properly due to the loss of amps being pulled. It could possibly damage the relay as well if not carefull. Make sure to add a load equilizer to keep the amperage where it needs to be.
  Reply With Quote
Old 09-30-2009, 10:35 PM   #10
Ban Pending
HBMurphy is one of the sharper tools in the shedHBMurphy is one of the sharper tools in the shedHBMurphy is one of the sharper tools in the shedHBMurphy is one of the sharper tools in the shedHBMurphy is one of the sharper tools in the shedHBMurphy is one of the sharper tools in the shedHBMurphy is one of the sharper tools in the shedHBMurphy is one of the sharper tools in the shedHBMurphy is one of the sharper tools in the shedHBMurphy is one of the sharper tools in the shedHBMurphy is one of the sharper tools in the shed
 
HBMurphy's Avatar
Name: Paul
Joined: Jun 2009, #18993
Location: So California Coast
Gender: Male
Posts: 5,724
HBMurphy's Tacoma Gallery
Load equalizer? Is this a resistor just to increase the resistance? No savings in amperage there? I guess I should stick with the $2 bulb!
  Reply With Quote
Old 05-06-2010, 07:29 AM   #11
Member
cweeks1934 will become famous soon enough
Navy: GMG 1 Retired
Name: clarence
Joined: Mar 2010, #33721
Location: South Carolina
Gender: Male
Posts: 31
cweeks1934's Tacoma Gallery
Arrow Led lights

Quote:
Originally Posted by SMG26 View Post
I just finished putting in my LED flasher that I got from superbrightleds.com and some bulbs. I turned the truck on and tested to see if the turn signals work. The front signals do not work but the rear signals do. I even tried putting the old 3157 stock bulbs in and they would not even flash. Any help would be great.
I had to put in a 6 ohm 50 Watt Resistor for each bulbs ,,, (RL-650)
before I could get the LED lights to work right ,,,,
what is the Flasher no did you get thanks
  Reply With Quote
Old 05-15-2010, 01:01 AM   #12
Junior Member
Hawaiian Taco is on a distinguished road
 
Hawaiian Taco's Avatar
Joined: Mar 2010, #32688
Location: Pacific Ocean
Gender: Male
Posts: 17
Hawaiian Taco's Tacoma Gallery
LEDs

How are your DRL LEds do they work well? Where did you get the resistor, how did you install, and what are the bulb part numbers??

Thanks!
  Reply With Quote
Old 12-21-2010, 10:48 AM   #13
MadeInMaine
MadeInMaine is one of the sharper tools in the shedMadeInMaine is one of the sharper tools in the shedMadeInMaine is one of the sharper tools in the shedMadeInMaine is one of the sharper tools in the shedMadeInMaine is one of the sharper tools in the shedMadeInMaine is one of the sharper tools in the shedMadeInMaine is one of the sharper tools in the shedMadeInMaine is one of the sharper tools in the shedMadeInMaine is one of the sharper tools in the shedMadeInMaine is one of the sharper tools in the shedMadeInMaine is one of the sharper tools in the shed
 
MadeInMaine's Avatar
EMS:
Name: Owen
Joined: Nov 2009, #26678
Location: Boston, MA
Age: 31
Gender: Dude
Posts: 1,164
MadeInMaine's Tacoma Gallery
Send a message via AIM to MadeInMaine
hey guys...

i put LED lights in the signal flashers, switched the flasher relay for a LED relay (to slow the flashing) and now I keep blowing the signal fuse..

you guys know whats going on?
  Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
FS: LED turn signals and flasher Gingrbredman Buy / Sell / Trade 12 05-25-2011 10:19 AM
LED TURN SIGNALS blacktacoma09 2nd Gen. Tacomas 0 12-27-2010 03:16 PM
LED Turn Signals from AutoMatCentral.com Doc.SS Product Reviews 5 07-25-2010 11:05 PM
Automatcentral's LED Turn Signals CRfofiddyF Product Reviews 2 07-01-2010 07:52 AM
LED Turn Signals from AutoMatCentral.com automatcentral Group Buys 274 06-04-2010 07:29 AM


Copyright © 2014 Tacoma Forum. Tacoma World is not owned by, or affiliated with Toyota Motor Corporation.