Tacoma World Forums

Tacoma World Forums (http://www.tacomaworld.com/forum/)
-   Off-Topic Discussion (http://www.tacomaworld.com/forum/off-topic-discussion/)
-   -   I absolutely hate comcast!!! (http://www.tacomaworld.com/forum/off-topic-discussion/269745-i-absolutely-hate-comcast.html)

Bennett707 03-23-2013 11:34 PM

I absolutely hate comcast!!!
 
Their product is the best I can get, considering the only other internet provider is still stuck on 10mbps.

But their customer service is terrible. Every time I have an issue, I have to dedicate at least 4 hours of my time to getting it resolved.

2 days ago I was promo'd into a higher teir, and was told I would see changes by 24 hours and if not power cycle my system. So of course I did, and still no upgrade.

Well I just wanted to figure out why I am not seeing results, currently on my 4th representative!!! The first one was so helpful, but during a powercycle we lost connection and that was it. :(

The second one completely ignored me, told me that I was getting the correct speed, and then when I tried to correct him he shot me down and was a smart ass about it.
I asked to speak to another representative that would treat me like a customer and not a number, so he tells me to disconnect and continue for another. Trying to do so, he resets my internet 3 times without my authorization or permission.

My 3rd was a cake walk because all I asked for was a complaint department.

Hoping this 4th rep can help me, my hopes are high, but out of the 4 she is the only one that bothered to verify me so cheers to that I guess.

cmack 03-23-2013 11:36 PM

sounds like everything is working how it should

MGMTacolover55 03-23-2013 11:37 PM

I used to have Comcast and they sucked so I went to century link and I can't notice the difference

Bennett707 03-23-2013 11:37 PM

Quote:

Originally Posted by cmack (Post 6637593)
sounds like everything is working how it should

You mean paying for a upgrade and receiving the same old product is how it should be? :confused:

Gelo760 03-23-2013 11:39 PM

I went back to 3 Mbps . I was at 20-25 but promotion expired . Nice to have I guess but I didn't use it for what it is . I notice no difference for what I do at 3mbps . My LTE is 30-60 Mbps all day if I want speed .
I'm sure it says up to .....

cmack 03-23-2013 11:39 PM

Quote:

Originally Posted by Ipreferwater (Post 6637597)
You mean paying for a upgrade and receiving the same old product is how it should be? :confused:

seems liek the norm these days

Bennett707 03-23-2013 11:41 PM

Quote:

Originally Posted by MGMTacolover55 (Post 6637596)
I used to have Comcast and they sucked so I went to century link and I can't notice the difference

They only offer the 10mbps out here unfortuantly, and the UL speed is not enough for me to stream my media like I do. :(

Quote:

Originally Posted by cmack (Post 6637602)
seems liek the norm these days

must be a jeep thing.

cmack 03-23-2013 11:42 PM

you mean you don't like being ripped off?

Bennett707 03-23-2013 11:42 PM

Quote:

Originally Posted by Gelo760 (Post 6637601)
I went back to 3 Mbps . I was at 20-25 but promotion expired . Nice to have I guess but I didn't use it for what it is . I notice no difference for what I do at 3mbps . My LTE is 30-60 Mbps all day if I want speed .
I'm sure it says up to .....

Even if it says up to, when I am paying for a 20mbps connection and receiving 25mbps (thankfully) and I am now paying for a 50mbps connection and still receiving 25mbps, something is wrong.

MGMTacolover55 03-23-2013 11:44 PM

Well you could go with a 4g uh internet connection or something like that

Bennett707 03-23-2013 11:45 PM

Quote:

Originally Posted by cmack (Post 6637610)
you mean you don't like being ripped off?

I know you like being fucked in the ass, but I don't.

cmack 03-23-2013 11:46 PM

Quote:

Originally Posted by Ipreferwater (Post 6637623)
I know you like being fucked in the ass, but I don't.

whoa buddy, no need to get angry with me because you have shitty service providers..

BMOC 03-23-2013 11:46 PM

yeah i haven't heard anything good about them. ever. i guess since they're the best available then they can get away with it.. lame.

Gelo760 03-23-2013 11:48 PM

Quote:

Originally Posted by Ipreferwater (Post 6637612)
Even if it says up to, when I am paying for a 20mbps connection and receiving 25mbps (thankfully) and I am now paying for a 50mbps connection and still receiving 25mbps, something is wrong.

Nah nothing is wrong it varies . Is this a wifi connection ?

Bennett707 03-23-2013 11:48 PM

Quote:

Originally Posted by Gelo760 (Post 6637632)
Nah nothing is wrong it varies . Is this a wifi connection ?

hardwire.

Gelo760 03-23-2013 11:50 PM

Why do you want / need 50 Mbps ?

Bennett707 03-23-2013 11:51 PM

Quote:

Originally Posted by Gelo760 (Post 6637635)
Why do you want / need 50 Mbps ?

Promo to lower my bill, I don't need 50, but it will be very beneficial to my streaming.

Apparently I have to wait til the 28th for my new speed to go into affect.. Jesus.

Gelo760 03-23-2013 11:57 PM

Quote:

Originally Posted by Ipreferwater (Post 6637637)
Promo to lower my bill, I don't need 50, but it will be very beneficial to my streaming.

Apparently I have to wait til the 28th for my new speed to go into affect.. Jesus.

Kk . I'm down to 3 Mbps and still don't have many issues streaming porn or YouTube . I don't watch movies though . Hopefully it works out for you .

Bennett707 03-23-2013 11:58 PM

You stream 10-100mb files... I stream 10-100GB files.


All times are GMT -7. The time now is 07:16 AM.