Mike "Wuzzy121". Rest in peace, brother

Go Back   Tacoma World Forums > Tacoma Garage > Performance and Tuning

Notices

weird smell after new muffler was installed

Reply
 
Thread Tools Search this Thread
Old 07-03-2009, 09:31 PM   #1
TacomaGus [OP] TacomaGus is offline
Senior Member
TacomaGus is one of the sharper tools in the shedTacomaGus is one of the sharper tools in the shedTacomaGus is one of the sharper tools in the shedTacomaGus is one of the sharper tools in the shedTacomaGus is one of the sharper tools in the shedTacomaGus is one of the sharper tools in the shedTacomaGus is one of the sharper tools in the shedTacomaGus is one of the sharper tools in the shedTacomaGus is one of the sharper tools in the shedTacomaGus is one of the sharper tools in the shedTacomaGus is one of the sharper tools in the shed
 
TacomaGus's Avatar
Name: Gus
Joined: Jun 2009, #19121
Location: Morgantown, WV
Gender: Male
Posts: 1,159
TacomaGus's Tacoma Gallery
weird smell after new muffler was installed

i got my new flowmaster muffler put on 2 days ago and when i got home after the installation it was really smoking and smelt terrible but i figured it was just the smoke from the welds still being hot. But after the past two days of driving the smell has decreased definently but after i drive for an extended period i notice it still smells a little when i'm walking away from the truck.....i just hope nothing is wrong
  Reply With Quote
Old 07-03-2009, 09:33 PM   #2
Senior Member
rab89 is one of the sharper tools in the shedrab89 is one of the sharper tools in the shedrab89 is one of the sharper tools in the shedrab89 is one of the sharper tools in the shedrab89 is one of the sharper tools in the shedrab89 is one of the sharper tools in the shedrab89 is one of the sharper tools in the shedrab89 is one of the sharper tools in the shedrab89 is one of the sharper tools in the shedrab89 is one of the sharper tools in the shedrab89 is one of the sharper tools in the shed
 
rab89's Avatar
Name: Ross
Joined: Jan 2009, #12578
Location: Kelowna b.c canada
Age: 25
Gender: Male
Posts: 5,522
rab89's Tacoma Gallery
i'd think it's just the metals and crap inside the muffler burning off. the sound will change a bit too as this happens
  Reply With Quote
Old 07-03-2009, 09:33 PM   #3
Carolina Alliance: Lead, follow, or get the hell outta my way
tacomaman06 is one of the sharper tools in the shedtacomaman06 is one of the sharper tools in the shedtacomaman06 is one of the sharper tools in the shedtacomaman06 is one of the sharper tools in the shedtacomaman06 is one of the sharper tools in the shedtacomaman06 is one of the sharper tools in the shedtacomaman06 is one of the sharper tools in the shedtacomaman06 is one of the sharper tools in the shedtacomaman06 is one of the sharper tools in the shedtacomaman06 is one of the sharper tools in the shedtacomaman06 is one of the sharper tools in the shed
 
tacomaman06's Avatar
Name: Will
Joined: May 2007, #1475
Location: York,South Carolina
Age: 35
Gender: Male
Posts: 26,352
tacomaman06's Tacoma Gallery
Quote:
Originally Posted by TacomaGus View Post
i got my new flowmaster muffler put on 2 days ago and when i got home after the installation it was really smoking and smelt terrible but i figured it was just the smoke from the welds still being hot. But after the past two days of driving the smell has decreased definently but after i drive for an extended period i notice it still smells a little when i'm walking away from the truck.....i just hope nothing is wrong
nothing to worry about....just the muffler getting hot and breaking in.
  Reply With Quote
Old 07-03-2009, 09:38 PM   #4
Begin With The End In Mind.
carmellocafe is one of the sharper tools in the shedcarmellocafe is one of the sharper tools in the shedcarmellocafe is one of the sharper tools in the shedcarmellocafe is one of the sharper tools in the shedcarmellocafe is one of the sharper tools in the shedcarmellocafe is one of the sharper tools in the shedcarmellocafe is one of the sharper tools in the shedcarmellocafe is one of the sharper tools in the shedcarmellocafe is one of the sharper tools in the shedcarmellocafe is one of the sharper tools in the shedcarmellocafe is one of the sharper tools in the shed
 
carmellocafe's Avatar
Name: KEVIN
Joined: May 2009, #17267
Location: N. California
Age: 39
Gender: Male
Posts: 2,264
carmellocafe's Tacoma Gallery
Mine did this a little bit too. Eventually it went away completely. I don't think it's something too be super worried about. You could take a close look under your truck to make sure all is well though--For peace of mind.
  Reply With Quote
Old 07-03-2009, 09:52 PM   #5
TacomaGus [OP] TacomaGus is offline
Senior Member
TacomaGus is one of the sharper tools in the shedTacomaGus is one of the sharper tools in the shedTacomaGus is one of the sharper tools in the shedTacomaGus is one of the sharper tools in the shedTacomaGus is one of the sharper tools in the shedTacomaGus is one of the sharper tools in the shedTacomaGus is one of the sharper tools in the shedTacomaGus is one of the sharper tools in the shedTacomaGus is one of the sharper tools in the shedTacomaGus is one of the sharper tools in the shedTacomaGus is one of the sharper tools in the shed
 
TacomaGus's Avatar
Name: Gus
Joined: Jun 2009, #19121
Location: Morgantown, WV
Gender: Male
Posts: 1,159
TacomaGus's Tacoma Gallery
thanks for the advice guys! I figured it may just have been the muffler breaking in a little bit but i've never had a new muffler put on before so i didn't know for sure. And the truck has seemed to get a bit of a deeper tone and louder at idle but i like it
  Reply With Quote
Old 07-04-2009, 10:44 AM   #7
Member
09WhiteTaco4x4 is on a distinguished road
 
09WhiteTaco4x4's Avatar
Joined: Jun 2009, #18857
Location: Washington
Age: 33
Gender: Male
Posts: 85
09WhiteTaco4x4's Tacoma Gallery
I've noticed this both times I've gotten new mufflers. Sometimes they paint the pipe around the welds to clean up the look a bit. I don't know if they painted around the welds for yours, but it could just be the paint fumes burning off (I suspect but could very well be wrong). Mine lasted a few days and eventually went away completely, too.
  Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
Weird noise after wheels installed Alpha Q Up 1st Gen. Tacomas 11 10-26-2011 01:50 PM
New muffler maybe installed wrong?? Kansas_SR5 2nd Gen. Tacomas 20 06-17-2011 04:27 PM
Weird results after LR UCA's installed. Fabulous Suspension 13 04-20-2011 06:32 AM
weird noise and smell when i start my truck ross123 2nd Gen. Tacomas 11 10-26-2010 12:57 PM
Got my new magnaflow muffler installed. blackwatertaco 4 Cylinder 9 03-09-2010 06:54 PM


Copyright © 2014 Tacoma Forum. Tacoma World is not owned by, or affiliated with Toyota Motor Corporation.