Mike "Wuzzy121". Rest in peace, brother

Go Back   Tacoma World Forums > Tacoma Garage > Suspension

Notices

Finally did the install, but now there are weird noises...

Reply
 
Thread Tools Search this Thread
Old 05-04-2011, 01:12 PM   #1
dira1987 [OP] dira1987 is offline
Senior Member
dira1987 is a jewel in the roughdira1987 is a jewel in the roughdira1987 is a jewel in the roughdira1987 is a jewel in the rough
 
dira1987's Avatar
Name: David
Joined: Jan 2011, #48740
Location: Chandler AZ
Gender: Male
Posts: 382
dira1987's Tacoma Gallery
Finally did the install, but now there are weird noises...

Hey guys,

So after many months of craigslisting i finally installed the camburg spindles, expended break lines, ome rear leafs and shocks, and moto metal wheels and tires. I did the install myself and it looks like it works pretty well. It runs and nothing has fallen off yet. Unfortunatly now when i drive i hear this screeching coming from the front tires. It sounds like the tires are skidding everywhere i drive. Straight line, turns, everything. I was thinking it was because the wheel offset was too large? Maybe the wheels are just wearing down? I had it aligned and everything so i dont think its the alignment anymore. What do you guys think? Thanks!
Attached Thumbnails
Finally did the install, but now there are weird noises...-1303435807613.jpg   Finally did the install, but now there are weird noises...-1303435812322.jpg   Finally did the install, but now there are weird noises...-1303581233585.jpg   Finally did the install, but now there are weird noises...-1303581238966.jpg   Finally did the install, but now there are weird noises...-1303865151619.jpg  

Finally did the install, but now there are weird noises...-1303865175680.jpg  
  Reply With Quote
Old 05-04-2011, 03:40 PM   #2
Senior Member
Fabulous is one of the sharper tools in the shedFabulous is one of the sharper tools in the shedFabulous is one of the sharper tools in the shedFabulous is one of the sharper tools in the shedFabulous is one of the sharper tools in the shedFabulous is one of the sharper tools in the shedFabulous is one of the sharper tools in the shedFabulous is one of the sharper tools in the shedFabulous is one of the sharper tools in the shedFabulous is one of the sharper tools in the shedFabulous is one of the sharper tools in the shed
 
Fabulous's Avatar
Name: Fabian
Joined: Jul 2009, #19807
Location: Calgary, AB
Age: 36
Gender: Male
Posts: 829
Fabulous's Tacoma Gallery
Did you have it aligned directly after install? If so, when/ if it settled it put the alignment out of spec...

Just an idea.
  Reply With Quote
Old 05-04-2011, 03:54 PM   #3
4WD 4WD is offline
cRaZy oLdmAn
4WD is one of the sharper tools in the shed4WD is one of the sharper tools in the shed4WD is one of the sharper tools in the shed4WD is one of the sharper tools in the shed4WD is one of the sharper tools in the shed4WD is one of the sharper tools in the shed4WD is one of the sharper tools in the shed4WD is one of the sharper tools in the shed4WD is one of the sharper tools in the shed4WD is one of the sharper tools in the shed4WD is one of the sharper tools in the shed
 
4WD's Avatar
Name: Doug
Joined: Jul 2009, #19185
Location: Lakeside,CA
Age: 56
Gender: Male
Posts: 21,503
4WD's Tacoma Gallery
Quote:
Originally Posted by dira1987 View Post
Hey guys,

So after many months of craigslisting i finally installed the camburg spindles, expended break lines, ome rear leafs and shocks, and moto metal wheels and tires. I did the install myself and it looks like it works pretty well. It runs and nothing has fallen off yet. Unfortunatly now when i drive i hear this screeching coming from the front tires. It sounds like the tires are skidding everywhere i drive. Straight line, turns, everything. I was thinking it was because the wheel offset was too large? Maybe the wheels are just wearing down? I had it aligned and everything so i dont think its the alignment anymore. What do you guys think? Thanks!
Can't tell shit from thumbnails OP, can you take some close up pics of your front install?? It'll help a bunch.....
  Reply With Quote
Old 05-04-2011, 05:53 PM   #4
Senior Member
skytower is one of the sharper tools in the shedskytower is one of the sharper tools in the shedskytower is one of the sharper tools in the shedskytower is one of the sharper tools in the shedskytower is one of the sharper tools in the shedskytower is one of the sharper tools in the shedskytower is one of the sharper tools in the shedskytower is one of the sharper tools in the shedskytower is one of the sharper tools in the shedskytower is one of the sharper tools in the shedskytower is one of the sharper tools in the shed
 
skytower's Avatar
Navy: Gunners Mate
Name: Dave
Joined: Jun 2010, #38505
Location: virginia
Gender: Male
Posts: 3,185
skytower's Tacoma Gallery
Look hard for metal to metal contact. New wheels, so look for clearance between caliper/dust sheild and wheel.
  Reply With Quote
Old 05-04-2011, 05:55 PM   #5
Screw your MPG's
jacob_wood is one of the sharper tools in the shedjacob_wood is one of the sharper tools in the shedjacob_wood is one of the sharper tools in the shedjacob_wood is one of the sharper tools in the shedjacob_wood is one of the sharper tools in the shedjacob_wood is one of the sharper tools in the shedjacob_wood is one of the sharper tools in the shedjacob_wood is one of the sharper tools in the shedjacob_wood is one of the sharper tools in the shedjacob_wood is one of the sharper tools in the shedjacob_wood is one of the sharper tools in the shed
 
jacob_wood's Avatar
Name: Jacob
Joined: Jun 2009, #18191
Location: Campbell, CA (Nor-Cal)
Age: 23
Gender: Male
Posts: 3,817
jacob_wood's Tacoma Gallery
Send a message via AIM to jacob_wood
What is the backspacing of the rims? You need at least 4.5" backspacing.
  Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
Weird clicking noises from Shock or UCA.. Help.. RJALLDAY702 Suspension 9 12-08-2011 09:26 AM
Noises after ball joint / tie rod install cmf21 1st Gen. Tacomas 1 10-29-2011 10:38 PM
icon CO, spindles, and weird noises? dira1987 Suspension 2 10-11-2011 06:35 PM
Weird Noises from my Tacoma... veet skeet 2nd Gen. Tacomas 42 09-16-2011 03:47 PM
Drive Shaft making weird noises? MMazz365 Technical Chat 8 06-15-2011 03:13 PM


Copyright © 2014 Tacoma Forum. Tacoma World is not owned by, or affiliated with Toyota Motor Corporation.