Mike "Wuzzy121". Rest in peace, brother

Go Back   Tacoma World Forums > Tacoma Garage > Suspension

Notices

Post lift issues

Reply
 
Thread Tools Search this Thread
Old 10-05-2011, 06:08 PM   #1
Member
UpstateTRDTaco is on a distinguished road
 
UpstateTRDTaco's Avatar
Name: Josh
Joined: Oct 2010, #44392
Location: upstate NY
Age: 23
Gender: Male
Posts: 87
UpstateTRDTaco's Tacoma Gallery
Post lift issues

hey guys, i just installed billies at 2.5 and a 2 inch AAL about 800 miles ago and now i have noticed that my truck starts to wander and feel soft steering, also, the brake pedal is very soft then gets hard quick, almost like no brake pressure, thirdly the shudder is starting to bother me, here is my ideas, just wanted to doulbe check:


Get an alignment, and get some UCAs when i can to get perfect alignment
Maybe bleed the brakes? or did my lines gets streteched? idk please help
Lastly, Carrier bearing drop may fix the shudder?

I know there are threads but thats what i found to assume to fix and i just would like some opinions, thanks.
  Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
did the lift on this truck cause all these issues noxubee boy 2nd Gen. Tacomas 2 01-18-2012 12:39 AM
Bought a zuki sidekick with some issues and would like to know where to post mech?'s BRYLONATOR General Automotive 10 04-07-2011 07:00 AM
Supply Chain Management Issues Post Tsunami? RZRob 2nd Gen. Tacomas 0 03-18-2011 09:21 PM
Lift Kit Issues Dgoodytrd 2nd Gen. Tacomas 3 01-30-2010 04:48 PM
ebrake issues with lift mixaro Suspension 1 10-08-2009 05:39 PM


Copyright © 2014 Tacoma Forum. Tacoma World is not owned by, or affiliated with Toyota Motor Corporation.